]> git.pld-linux.org Git - packages/libwnck.git/blob - libwnck.spec
- updated to 3.4.4
[packages/libwnck.git] / libwnck.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 #
6 Summary:        General Window Manager interfacing for GNOME utilities
7 Summary(pl.UTF-8):      Interfejs General Window Manager dla narzędzi GNOME
8 Name:           libwnck
9 Version:        3.4.4
10 Release:        1
11 License:        LGPL v2+
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libwnck/3.4/%{name}-%{version}.tar.xz
14 # Source0-md5:  c5c0e7793c887037210ad8e9fc557522
15 BuildRequires:  autoconf >= 2.62
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  docbook-dtd412-xml
18 BuildRequires:  gdk-pixbuf2-devel
19 BuildRequires:  gettext-devel
20 BuildRequires:  glib2-devel >= 1:2.32.0
21 BuildRequires:  gnome-common >= 2.20.0
22 BuildRequires:  gobject-introspection-devel >= 0.6.14
23 BuildRequires:  gtk+3-devel >= 3.4.0
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
25 BuildRequires:  gtk-doc-automake >= 1.9
26 BuildRequires:  intltool >= 0.40.6
27 BuildRequires:  libtool >= 2:2.2.6
28 BuildRequires:  pkgconfig
29 BuildRequires:  startup-notification-devel >= 0.8
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xorg-lib-libX11-devel
32 BuildRequires:  xorg-lib-libXres-devel
33 BuildRequires:  xz
34 # sr@Latn vs. sr@latin
35 Conflicts:      glibc-misc < 6:2.7
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 General Window Manager interfacing for GNOME utilities. This library
40 is a part of the GNOME 2 platform.
41
42 %description -l pl.UTF-8
43 Ogólny interfejs zarządcy okien dla narzędzi GNOME. Ta biblioteka jest
44 częścią platformy GNOME 2.
45
46 %package tools
47 Summary:        Small tools to manage windows
48 Summary(pl.UTF-8):      Małe narzędzia do zarządzania oknami
49 Group:          X11/Window Managers/Tools
50 Requires:       %{name} = %{version}-%{release}
51
52 %description tools
53 Small tools to manage windows.
54
55 %description tools -l pl.UTF-8
56 Małe narzędzia do zarządzania oknami.
57
58 %package devel
59 Summary:        Header files and documentation for libwnck
60 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla libwnck
61 Group:          X11/Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       glib2-devel >= 1:2.32.0
64 Requires:       gtk+3-devel >= 3.4.0
65 Requires:       startup-notification-devel >= 0.8
66 Requires:       xorg-lib-libX11-devel
67 Requires:       xorg-lib-libXres-devel
68
69 %description devel
70 Header, docs and development libraries for libwnck.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe i dokumentacja do libwnck.
74
75 %package static
76 Summary:        Static libwnck libraries
77 Summary(pl.UTF-8):      Statyczne biblioteki libwnck
78 Group:          X11/Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Static version of libwnck libraries.
83
84 %description static -l pl.UTF-8
85 Statyczna wersja bibliotek libwnck.
86
87 %package apidocs
88 Summary:        libwnck API documentation
89 Summary(pl.UTF-8):      Dokumentacja API libwnck
90 Group:          Documentation
91 Requires:       gtk-doc-common
92
93 %description apidocs
94 libwnck API documentation.
95
96 %description apidocs -l pl.UTF-8
97 Dokumentacja API libwnck.
98
99 %prep
100 %setup -q
101
102 %build
103 %{__gtkdocize}
104 %{__glib_gettextize}
105 %{__intltoolize}
106 %{__libtoolize}
107 %{__aclocal} -I m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         %{__enable_disable apidocs gtk-doc} \
113         --with-html-dir=%{_gtkdocdir} \
114         %{__enable_disable static_libs static} \
115         --disable-silent-rules
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwnck-3.la
126
127 %find_lang %{name}-3.0
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files -f %{name}-3.0.lang
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
138 %attr(755,root,root) %{_libdir}/libwnck-3.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libwnck-3.so.0
140 %{_libdir}/girepository-1.0/Wnck-3.0.typelib
141
142 %files tools
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/wnck-urgency-monitor
145 %attr(755,root,root) %{_bindir}/wnckprop
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libwnck-3.so
150 %{_includedir}/libwnck-3.0
151 %{_pkgconfigdir}/libwnck-3.0.pc
152 %{_datadir}/gir-1.0/Wnck-3.0.gir
153
154 %if %{with static_libs}
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libwnck-3.a
158 %endif
159
160 %if %{with apidocs}
161 %files apidocs
162 %defattr(644,root,root,755)
163 %{_gtkdocdir}/libwnck-3.0
164 %endif
This page took 0.06514 seconds and 3 git commands to generate.