]> git.pld-linux.org Git - packages/libvterm.git/blob - libvterm.spec
Up to 0.1.3
[packages/libvterm.git] / libvterm.spec
1 Summary:        An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator
2 Name:           libvterm
3 Version:        0.1.3
4 Release:        1
5 License:        MIT
6 Group:          Libraries
7 # using github mirror
8 # as it's just easier to get tarball
9 Source0:        https://github.com/neovim/libvterm/archive/65dbda3/%{name}-%{version}.tar.gz
10 # Source0-md5:  4b28b9a2bd73b558e97b627cfd559678
11 # https://launchpad.net/libvterm
12 URL:            http://www.leonerd.org.uk/code/libvterm/
13 BuildRequires:  gcc
14 BuildRequires:  libtool
15 BuildRequires:  pkgconfig
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 An abstract C99 library which implements a VT220 or xterm-like
20 terminal emulator. It doesn't use any particular graphics toolkit or
21 output system, instead it invokes callback function pointers that its
22 embedding program should provide it to draw on its behalf. It avoids
23 calling malloc() during normal running state, allowing it to be used
24 in embedded kernel situations.
25
26 %package devel
27 Summary:        Development files for %{name}
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 The %{name}-devel package contains libraries and header files for
33 developing applications that use %{name}.
34
35 %prep
36 %setup -q -c %{name}-%{version}
37 mv %{name}-*/* .
38
39 %build
40 %{__make} \
41         VERBOSE=1 \
42         CFLAGS="%{optflags} -std=gnu99" \
43         INCDIR="%{_includedir}" \
44         LIBDIR="%{_libdir}" \
45         MANDIR="%{_mandir}" \
46         PREFIX="%{_prefix}" \
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %{__make} install \
51     CFLAGS="%{optflags} -std=gnu99" \
52     INCDIR="%{_includedir}" \
53     LIBDIR="%{_libdir}" \
54     MANDIR="%{_mandir}" \
55     PREFIX="%{_prefix}" \
56     DESTDIR=$RPM_BUILD_ROOT
57
58 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvterm.a
59 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvterm.la
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post   -p /sbin/ldconfig
65 %postun -p /sbin/ldconfig
66
67 %files
68 %defattr(644,root,root,755)
69 %doc LICENSE
70 %attr(755,root,root) %{_bindir}/unterm
71 %attr(755,root,root) %{_bindir}/vterm-ctrl
72 %attr(755,root,root) %{_bindir}/vterm-dump
73 %attr(755,root,root) %{_libdir}/libvterm.so.*.*.*
74 %ghost %{_libdir}/libvterm.so.0
75
76 %files devel
77 %defattr(644,root,root,755)
78 %{_includedir}/vterm.h
79 %{_includedir}/vterm_keycodes.h
80 %{_libdir}/libvterm.so
81 %{_pkgconfigdir}/vterm.pc
This page took 0.059971 seconds and 3 git commands to generate.