]> git.pld-linux.org Git - packages/libvterm.git/blob - libvterm.spec
147d00d96be1554e10ef8361e6dea09c8b330b75
[packages/libvterm.git] / libvterm.spec
1 Summary:        An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator
2 Name:           libvterm
3 Version:        0.1.3
4 Release:        2
5 License:        MIT
6 Group:          Libraries
7 Source0:        https://www.leonerd.org.uk/code/libvterm/%{name}-%{version}.tar.gz
8 # Source0-md5:  4581aec6b621f5ca5cf5bff97dea6e05
9 URL:            http://www.leonerd.org.uk/code/libvterm/
10 BuildRequires:  libtool
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 An abstract C99 library which implements a VT220 or xterm-like
15 terminal emulator. It doesn't use any particular graphics toolkit or
16 output system, instead it invokes callback function pointers that its
17 embedding program should provide it to draw on its behalf. It avoids
18 calling malloc() during normal running state, allowing it to be used
19 in embedded kernel situations.
20
21 %package devel
22 Summary:        Development files for %{name}
23 Group:          Development/Libraries
24 Requires:       %{name} = %{version}-%{release}
25
26 %description devel
27 The %{name}-devel package contains libraries and header files for
28 developing applications that use %{name}.
29
30 %prep
31 %setup -q
32
33 %build
34 %{__make} \
35         VERBOSE=1 \
36         CFLAGS="%{optflags} -std=gnu99" \
37         INCDIR="%{_includedir}" \
38         LIBDIR="%{_libdir}" \
39         MANDIR="%{_mandir}" \
40         PREFIX="%{_prefix}" \
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 %{__make} install \
45     CFLAGS="%{optflags} -std=gnu99" \
46     INCDIR="%{_includedir}" \
47     LIBDIR="%{_libdir}" \
48     MANDIR="%{_mandir}" \
49     PREFIX="%{_prefix}" \
50     DESTDIR=$RPM_BUILD_ROOT
51
52 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvterm.a
53 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvterm.la
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post   -p /sbin/ldconfig
59 %postun -p /sbin/ldconfig
60
61 %files
62 %defattr(644,root,root,755)
63 %doc LICENSE
64 %attr(755,root,root) %{_bindir}/unterm
65 %attr(755,root,root) %{_bindir}/vterm-ctrl
66 %attr(755,root,root) %{_bindir}/vterm-dump
67 %attr(755,root,root) %{_libdir}/libvterm.so.*.*.*
68 %ghost %{_libdir}/libvterm.so.0
69
70 %files devel
71 %defattr(644,root,root,755)
72 %{_includedir}/vterm.h
73 %{_includedir}/vterm_keycodes.h
74 %{_libdir}/libvterm.so
75 %{_pkgconfigdir}/vterm.pc
This page took 0.06255 seconds and 2 git commands to generate.