]> git.pld-linux.org Git - packages/libvncserver.git/blob - libvncserver.spec
c8445aae240729492adb308383afd578dc811f43
[packages/libvncserver.git] / libvncserver.spec
1 #
2 # Conditional build:
3 %bcond_with     openssl         # use OpenSSL instead of GnuTLS
4 %bcond_without  static_libs     # static libraries
5
6 Summary:        LibVNCServer - a for easy implementation of VNC/RDP server
7 Summary(pl.UTF-8):      LibVNCServer - biblioteka do łatwego implementowania serwera VNC/RDP
8 Name:           libvncserver
9 Version:        0.9.12
10 Release:        1
11 License:        GPL v2
12 Group:          Libraries
13 #Source0Download: https://github.com/LibVNC/libvncserver/releases
14 Source0:        https://github.com/LibVNC/libvncserver/archive/LibVNCServer-%{version}.tar.gz
15 # Source0-md5:  dc2ae6433d2ce45b9f60034c7fb9c10a
16 Patch0:         %{name}-libsuffix.patch
17 URL:            https://github.com/LibVNC/libvncserver/
18 BuildRequires:  cyrus-sasl-devel >= 2
19 %{!?with_openssl:BuildRequires: gnutls-devel >= 2.4.0}
20 BuildRequires:  libgcrypt-devel >= 1.4.0
21 BuildRequires:  libjpeg-devel
22 BuildRequires:  libpng-devel
23 BuildRequires:  libva-devel >= 1.2.0
24 BuildRequires:  libva-x11-devel >= 1.2.0
25 BuildRequires:  lzo-devel
26 %{?with_openssl:BuildRequires:  openssl-devel}
27 BuildRequires:  pkgconfig
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  systemd-devel >= 1:209
30 BuildRequires:  xorg-lib-libX11-devel
31 BuildRequires:  xorg-lib-libXdamage-devel
32 BuildRequires:  xorg-lib-libXext-devel
33 BuildRequires:  xorg-lib-libXfixes-devel
34 BuildRequires:  xorg-lib-libXinerama-devel
35 BuildRequires:  xorg-lib-libXrandr-devel
36 BuildRequires:  xorg-lib-libXtst-devel
37 BuildRequires:  zlib-devel
38 # for noinst client_examples only
39 #BuildRequires: SDL2-devel >= 2.0
40 #BuildRequires: gtk+2-devel >= 2.0
41 # for vnc2mpg example
42 #BuildRequires: ffmpeg-devel >= 3.1.0
43 %{!?with_openssl:Requires:      gnutls >= 2.4.0}
44 Requires:       libgcrypt >= 1.4.0
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 LibVNCServer makes writing a VNC server (or more correctly, a program
49 exporting a framebuffer via the Remote Frame Buffer protocol) easy.
50
51 It is based on OSXvnc, which in turn is based on the original Xvnc by
52 ORL, later AT&T research labs in UK.
53
54 It hides the programmer from the tedious task of managing clients and
55 compression schemata.
56
57 LibVNCServer was put together and is (actively ;-) maintained by
58 Johannes Schindelin <Johannes.Schindelin@gmx.de>.
59
60 %description -l pl.UTF-8
61 LibVNCServer ułatwia pisanie serwera VNC (lub, bardziej poprawnie,
62 programu eksportującego framebuffer poprzez protokół Remote Frame
63 Buffer).
64
65 Jest oparty na OSXvnc, który z kolei bazuje na oryginalnym Xvnc
66 napisanym przez ORL, a później AT&T.
67
68 Biblioteka ukrywa przed programistą nudne zadanie zarządzania
69 klientami i schematami kompresji.
70
71 LibVNCServer została poskładana i jest (aktywnie) utrzymywana przez
72 Johannesa Schindelina <Johannes.Schindelin@gmx.de>.
73
74 %package devel
75 Summary:        LibVNCServer header files
76 Summary(pl.UTF-8):      Pliki nagłówkowe LibVNCServer
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       cyrus-sasl-devel >= 2
80 %{!?with_openssl:Requires:      gnutls-devel >= 2.4.0}
81 Requires:       libgcrypt-devel >= 1.4.0
82 Requires:       libjpeg-devel
83 Requires:       libpng-devel
84 Requires:       lzo-devel
85 %{?with_openssl:Requires:       openssl-devel}
86 Requires:       zlib-devel
87
88 %description devel
89 LibVNCServer header files.
90
91 %description devel -l pl.UTF-8
92 Pliki nagłówkowe LibVNCServer.
93
94 %package static
95 Summary:        Static LibVNCServer libraries
96 Summary(pl.UTF-8):      Statyczne biblioteki LibVNCServer
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 Static LibVNCServer libraries.
102
103 %description static -l pl.UTF-8
104 Statyczne biblioteki LibVNCServer.
105
106 %prep
107 %setup -q -n libvncserver-LibVNCServer-%{version}
108 %patch0 -p1
109
110 %build
111 %if %{with static_libs}
112 install -d build-static
113 cd build-static
114 %cmake .. \
115         -DBUILD_SHARED_LIBS=OFF \
116         -DWITH_FFMPEG=OFF \
117         %{?with_openssl:-DWITH_GNUTLS=OFF} \
118         %{!?with_openssl:-DWITH_OPENSSL=OFF} \
119         -DWITH_SDL=OFF
120
121 %{__make}
122 cd ..
123 %endif
124
125 install -d build
126 cd build
127 %cmake .. \
128         -DWITH_FFMPEG=OFF \
129         %{?with_openssl:-DWITH_GNUTLS=OFF} \
130         %{!?with_openssl:-DWITH_OPENSSL=OFF} \
131         -DWITH_SDL=OFF
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %if %{with static_libs}
139 %{__make} -C build-static install \
140         DESTDIR=$RPM_BUILD_ROOT
141 %endif
142
143 %{__make} -C build install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README.md TODO
155 %attr(755,root,root) %{_libdir}/libvncclient.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libvncclient.so.1
157 %attr(755,root,root) %{_libdir}/libvncserver.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libvncserver.so.1
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libvncclient.so
163 %attr(755,root,root) %{_libdir}/libvncserver.so
164 %{_includedir}/rfb
165 %{_pkgconfigdir}/libvncclient.pc
166 %{_pkgconfigdir}/libvncserver.pc
167
168 %if %{with static_libs}
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/libvncclient.a
172 %{_libdir}/libvncserver.a
173 %endif
This page took 0.076153 seconds and 2 git commands to generate.