]> git.pld-linux.org Git - packages/libvncserver.git/blob - libvncserver.spec
b6ecbe61ec1d107d2e10b427f143c865d3931aa4
[packages/libvncserver.git] / libvncserver.spec
1 #
2 # Conditional build:
3 %bcond_with     openssl # use OpenSSL instead of GnuTLS
4
5 Summary:        LibVNCServer - a for easy implementation of VNC/RDP server
6 Summary(pl.UTF-8):      LibVNCServer - biblioteka do łatwego implementowania serwera VNC/RDP
7 Name:           libvncserver
8 Version:        0.9.11
9 Release:        2
10 License:        GPL v2
11 Group:          Libraries
12 #Source0Download: https://github.com/LibVNC/libvncserver/releases
13 Source0:        https://github.com/LibVNC/libvncserver/archive/LibVNCServer-%{version}.tar.gz
14 # Source0-md5:  7f06104d5c009813e95142932c4ddb06
15 Patch0:         %{name}-linux.patch
16 URL:            https://github.com/LibVNC/libvncserver/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 %{!?with_openssl:BuildRequires: gnutls-devel >= 2.4.0}
20 BuildRequires:  libgcrypt-devel >= 1.4.0
21 BuildRequires:  libjpeg-devel
22 BuildRequires:  libpng-devel
23 BuildRequires:  libtool
24 BuildRequires:  libva-devel >= 1.2.0
25 BuildRequires:  libva-x11-devel >= 1.2.0
26 %{?with_openssl:BuildRequires:  openssl-devel}
27 BuildRequires:  pkgconfig
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  systemd-devel >= 1:209
30 BuildRequires:  xorg-lib-libX11-devel
31 BuildRequires:  xorg-lib-libXdamage-devel
32 BuildRequires:  xorg-lib-libXext-devel
33 BuildRequires:  xorg-lib-libXfixes-devel
34 BuildRequires:  xorg-lib-libXinerama-devel
35 BuildRequires:  xorg-lib-libXrandr-devel
36 BuildRequires:  xorg-lib-libXtst-devel
37 BuildRequires:  zlib-devel
38 # for noinst client_examples only
39 #BuildRequires: SDL-devel
40 #BuildRequires: gtk+2-devel >= 2.0
41 # for vnc2mpg example
42 #BuildRequires: ffmpeg-devel || lame-libs-devel
43 %{!?with_openssl:Requires:      gnutls >= 2.4.0}
44 Requires:       libgcrypt >= 1.4.0
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 LibVNCServer makes writing a VNC server (or more correctly, a program
49 exporting a framebuffer via the Remote Frame Buffer protocol) easy.
50
51 It is based on OSXvnc, which in turn is based on the original Xvnc by
52 ORL, later AT&T research labs in UK.
53
54 It hides the programmer from the tedious task of managing clients and
55 compression schemata.
56
57 LibVNCServer was put together and is (actively ;-) maintained by
58 Johannes Schindelin <Johannes.Schindelin@gmx.de>.
59
60 %description -l pl.UTF-8
61 LibVNCServer ułatwia pisanie serwera VNC (lub, bardziej poprawnie,
62 programu eksportującego framebuffer poprzez protokół Remote Frame
63 Buffer).
64
65 Jest oparty na OSXvnc, który z kolei bazuje na oryginalnym Xvnc
66 napisanym przez ORL, a później AT&T.
67
68 Biblioteka ukrywa przed programistą nudne zadanie zarządzania
69 klientami i schematami kompresji.
70
71 LibVNCServer została poskładana i jest (aktywnie) utrzymywana przez
72 Johannesa Schindelina <Johannes.Schindelin@gmx.de>.
73
74 %package devel
75 Summary:        LibVNCServer header files
76 Summary(pl.UTF-8):      Pliki nagłówkowe LibVNCServer
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 %{!?with_openssl:Requires:      gnutls-devel >= 2.4.0}
80 Requires:       libgcrypt-devel >= 1.4.0
81 Requires:       libjpeg-devel
82 Requires:       libpng-devel
83 %{?with_openssl:Requires:       openssl-devel}
84 Requires:       zlib-devel
85
86 %description devel
87 LibVNCServer header files.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe LibVNCServer.
91
92 %package static
93 Summary:        Static LibVNCServer libraries
94 Summary(pl.UTF-8):      Statyczne biblioteki LibVNCServer
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description static
99 Static LibVNCServer libraries.
100
101 %description static -l pl.UTF-8
102 Statyczne biblioteki LibVNCServer.
103
104 %prep
105 %setup -q -n libvncserver-LibVNCServer-%{version}
106 %patch0 -p1
107
108 %build
109 %{__libtoolize}
110 %{__aclocal} -I m4
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         --disable-silent-rules \
116         %{?with_openssl:--without-gnutls} \
117         %{!?with_openssl:--without-ssl}
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 # obsoleted by pkg-config
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvnc*.la
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog NEWS README TODO
138 %attr(755,root,root) %{_libdir}/libvncclient.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libvncclient.so.1
140 %attr(755,root,root) %{_libdir}/libvncserver.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libvncserver.so.1
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/libvncserver-config
146 %attr(755,root,root) %{_libdir}/libvncclient.so
147 %attr(755,root,root) %{_libdir}/libvncserver.so
148 %{_includedir}/rfb
149 %{_pkgconfigdir}/libvncclient.pc
150 %{_pkgconfigdir}/libvncserver.pc
151
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libvncclient.a
155 %{_libdir}/libvncserver.a
This page took 0.080857 seconds and 2 git commands to generate.