]> git.pld-linux.org Git - packages/libvncserver.git/blob - libvncserver.spec
- added noLlibdir patch (avoid /usr/lib* in `libvncserver-config --libs` output)...
[packages/libvncserver.git] / libvncserver.spec
1 #
2 # Conditional build:
3 %bcond_with     openssl # use OpenSSL instead of GnuTLS
4
5 Summary:        LibVNCServer - a for easy implementation of VNC/RDP server
6 Summary(pl.UTF-8):      LibVNCServer - biblioteka do łatwego implementowania serwera VNC/RDP
7 Name:           libvncserver
8 Version:        0.9.11
9 Release:        3
10 License:        GPL v2
11 Group:          Libraries
12 #Source0Download: https://github.com/LibVNC/libvncserver/releases
13 Source0:        https://github.com/LibVNC/libvncserver/archive/LibVNCServer-%{version}.tar.gz
14 # Source0-md5:  7f06104d5c009813e95142932c4ddb06
15 Patch0:         %{name}-linux.patch
16 Patch1:         %{name}-noLlibdir.patch
17 URL:            https://github.com/LibVNC/libvncserver/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 %{!?with_openssl:BuildRequires: gnutls-devel >= 2.4.0}
21 BuildRequires:  libgcrypt-devel >= 1.4.0
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  libpng-devel
24 BuildRequires:  libtool
25 BuildRequires:  libva-devel >= 1.2.0
26 BuildRequires:  libva-x11-devel >= 1.2.0
27 %{?with_openssl:BuildRequires:  openssl-devel}
28 BuildRequires:  pkgconfig
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  systemd-devel >= 1:209
31 BuildRequires:  xorg-lib-libX11-devel
32 BuildRequires:  xorg-lib-libXdamage-devel
33 BuildRequires:  xorg-lib-libXext-devel
34 BuildRequires:  xorg-lib-libXfixes-devel
35 BuildRequires:  xorg-lib-libXinerama-devel
36 BuildRequires:  xorg-lib-libXrandr-devel
37 BuildRequires:  xorg-lib-libXtst-devel
38 BuildRequires:  zlib-devel
39 # for noinst client_examples only
40 #BuildRequires: SDL-devel
41 #BuildRequires: gtk+2-devel >= 2.0
42 # for vnc2mpg example
43 #BuildRequires: ffmpeg-devel || lame-libs-devel
44 %{!?with_openssl:Requires:      gnutls >= 2.4.0}
45 Requires:       libgcrypt >= 1.4.0
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 LibVNCServer makes writing a VNC server (or more correctly, a program
50 exporting a framebuffer via the Remote Frame Buffer protocol) easy.
51
52 It is based on OSXvnc, which in turn is based on the original Xvnc by
53 ORL, later AT&T research labs in UK.
54
55 It hides the programmer from the tedious task of managing clients and
56 compression schemata.
57
58 LibVNCServer was put together and is (actively ;-) maintained by
59 Johannes Schindelin <Johannes.Schindelin@gmx.de>.
60
61 %description -l pl.UTF-8
62 LibVNCServer ułatwia pisanie serwera VNC (lub, bardziej poprawnie,
63 programu eksportującego framebuffer poprzez protokół Remote Frame
64 Buffer).
65
66 Jest oparty na OSXvnc, który z kolei bazuje na oryginalnym Xvnc
67 napisanym przez ORL, a później AT&T.
68
69 Biblioteka ukrywa przed programistą nudne zadanie zarządzania
70 klientami i schematami kompresji.
71
72 LibVNCServer została poskładana i jest (aktywnie) utrzymywana przez
73 Johannesa Schindelina <Johannes.Schindelin@gmx.de>.
74
75 %package devel
76 Summary:        LibVNCServer header files
77 Summary(pl.UTF-8):      Pliki nagłówkowe LibVNCServer
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 %{!?with_openssl:Requires:      gnutls-devel >= 2.4.0}
81 Requires:       libgcrypt-devel >= 1.4.0
82 Requires:       libjpeg-devel
83 Requires:       libpng-devel
84 %{?with_openssl:Requires:       openssl-devel}
85 Requires:       zlib-devel
86
87 %description devel
88 LibVNCServer header files.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe LibVNCServer.
92
93 %package static
94 Summary:        Static LibVNCServer libraries
95 Summary(pl.UTF-8):      Statyczne biblioteki LibVNCServer
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 Static LibVNCServer libraries.
101
102 %description static -l pl.UTF-8
103 Statyczne biblioteki LibVNCServer.
104
105 %prep
106 %setup -q -n libvncserver-LibVNCServer-%{version}
107 %patch0 -p1
108 %patch1 -p1
109
110 %build
111 %{__libtoolize}
112 %{__aclocal} -I m4
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 %configure \
117         --disable-silent-rules \
118         %{?with_openssl:--without-gnutls} \
119         %{!?with_openssl:--without-ssl}
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 # obsoleted by pkg-config
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvnc*.la
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog NEWS README TODO
140 %attr(755,root,root) %{_libdir}/libvncclient.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libvncclient.so.1
142 %attr(755,root,root) %{_libdir}/libvncserver.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libvncserver.so.1
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/libvncserver-config
148 %attr(755,root,root) %{_libdir}/libvncclient.so
149 %attr(755,root,root) %{_libdir}/libvncserver.so
150 %{_includedir}/rfb
151 %{_pkgconfigdir}/libvncclient.pc
152 %{_pkgconfigdir}/libvncserver.pc
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libvncclient.a
157 %{_libdir}/libvncserver.a
This page took 0.067157 seconds and 3 git commands to generate.