]> git.pld-linux.org Git - packages/libvisio.git/blob - libvisio.spec
281efcf66df7411bb6ea6312af049c4ee793d85d
[packages/libvisio.git] / libvisio.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        A library providing ability to interpret and import Visio diagrams
6 Summary(pl.UTF-8):      Biblioteka umożliwiająca interpretowanie i importowanie diagramów Visio
7 Name:           libvisio
8 Version:        0.1.5
9 Release:        4
10 License:        MPL v2.0
11 Group:          Libraries
12 Source0:        http://dev-www.libreoffice.org/src/libvisio/%{name}-%{version}.tar.xz
13 # Source0-md5:  691522167fe3b0c94becfe5d957883be
14 URL:            http://www.freedesktop.org/wiki/Software/libvisio
15 BuildRequires:  boost-devel >= 1.36
16 BuildRequires:  doxygen
17 BuildRequires:  gperf >= 3
18 BuildRequires:  libicu-devel
19 BuildRequires:  librevenge-devel >= 0.0
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libxml2-devel >= 2.0
22 BuildRequires:  perl-base
23 BuildRequires:  pkgconfig >= 1:0.20
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Libvisio is library providing ability to interpret and import Visio
31 diagrams into various applications. You can find it being used in
32 libreoffice.
33
34 %description -l pl.UTF-8
35 Libvisio to biblioteka umożliwiająca interpretowanie i importowanie
36 diagramów Visio do wielu aplikacji. Jest wykorzystywana przez
37 libreoffice.
38
39 %package devel
40 Summary:        Development files for libvisio library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libvisio
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       libicu-devel
45 Requires:       librevenge-devel >= 0.0
46 Requires:       libstdc++-devel
47 Requires:       libxml2-devel >= 2.0
48 Requires:       zlib-devel
49
50 %description devel
51 This package contains the header files for developing applications
52 that use libvisio.
53
54 %description devel -l pl.UTF-8
55 Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
56 bibliotece libvisio.
57
58 %package static
59 Summary:        Static libvisio library
60 Summary(pl.UTF-8):      Statyczna biblioteka libvisio
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static libvisio library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka libvisio.
69
70 %package apidocs
71 Summary:        API documentation for libvisio library
72 Summary(pl.UTF-8):      Dokumentacja API biblioteki libvisio
73 Group:          Documentation
74 %if "%{_rpmversion}" >= "5"
75 BuildArch:      noarch
76 %endif
77
78 %description apidocs
79 API and internal documentation for libvisio library.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API biblioteki libvisio.
83
84 %package tools
85 Summary:        Tools to transform Visio diagrams into other formats
86 Summary(pl.UTF-8):      Programy przekształcania diagramów Visio do innych formatów
87 Group:          Applications/Publishing
88 Requires:       %{name} = %{version}-%{release}
89
90 %description tools
91 Tools to transform Visio diagrams into other formats. Currently
92 supported: XHTML, raw.
93
94 %description tools -l pl.UTF-8
95 Narzędzia do przekształcania diagramów Visio do innych formatów.
96 Aktualnie obsługiwane są XHTML i raw.
97
98 %prep
99 %setup -q
100
101 %build
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         --disable-silent-rules \
109         %{?with_static_libs:--enable-static}
110
111 %{__make}
112
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 # obsoleted by pkg-config
120 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS ChangeLog NEWS README
131 %attr(755,root,root) %{_libdir}/libvisio-0.1.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libvisio-0.1.so.1
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libvisio-0.1.so
137 %{_includedir}/libvisio-0.1
138 %{_pkgconfigdir}/libvisio-0.1.pc
139
140 %if %{with static_libs}
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libvisio-0.1.a
144 %endif
145
146 %files apidocs
147 %defattr(644,root,root,755)
148 %{_docdir}/%{name}
149
150 %files tools
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/vsd2raw
153 %attr(755,root,root) %{_bindir}/vsd2text
154 %attr(755,root,root) %{_bindir}/vsd2xhtml
155 %attr(755,root,root) %{_bindir}/vss2raw
156 %attr(755,root,root) %{_bindir}/vss2text
157 %attr(755,root,root) %{_bindir}/vss2xhtml
This page took 0.051896 seconds and 2 git commands to generate.