]> git.pld-linux.org Git - packages/libvirt.git/blob - libvirt.spec
f9e26096d96e9dbadbfbb6e00ede72c919a6dfc7
[packages/libvirt.git] / libvirt.spec
1 #
2 # Conditional build:
3 %bcond_without  esx             # VMware ESX support
4 %bcond_without  hyperv          # Hyper-V support
5 %bcond_without  libxl           # libxenlight support
6 %bcond_without  lxc             # LXC support
7 %bcond_without  netcf           # host interfaces support
8 %bcond_without  openvz          # OpenVZ support
9 %bcond_without  phyp            # PHYP support
10 %bcond_without  polkit          # PolicyKit support
11 %bcond_without  qemu            # Qemu support
12 %bcond_without  sanlock         # sanlock storage lock manager
13 %bcond_without  uml             # UML support
14 %bcond_without  vbox            # VirtualBox support
15 %bcond_without  vmware          # VMware Workstation/Player support
16 %bcond_with     xenapi          # Xen API (Citrix XenServer) support
17 %bcond_without  xen             # Xen support
18
19 # qemu available only on x86 and ppc
20 %ifnarch %{ix86} %{x8664} ppc
21 %undefine       with_qemu
22 %endif
23 # Xen is available only on x86 and ia64
24 %ifnarch %{ix86} %{x8664} ia64
25 %undefine       with_xen
26 %endif
27 Summary:        Toolkit to interact with virtualization capabilities
28 Summary(pl.UTF-8):      Narzędzia współpracujące z funkcjami wirtualizacji
29 Name:           libvirt
30 Version:        0.9.11
31 Release:        1
32 License:        LGPL v2.1+
33 Group:          Libraries
34 Source0:        ftp://ftp.libvirt.org/libvirt/%{name}-%{version}.tar.gz
35 # Source0-md5:  6e9fab115075a8fd21d9bd0d7e558a52
36 Source1:        %{name}.init
37 Source2:        %{name}.tmpfiles
38 Patch0:         %{name}-sasl.patch
39 Patch1:         %{name}-lxc.patch
40 Patch2:         %{name}-qemu-acl.patch
41 Patch3:         %{name}-xend.patch
42 Patch4:         lxc-without-selinux.patch
43 Patch5:         %{name}-driver-modules.patch
44 URL:            http://www.libvirt.org/
45 BuildRequires:  audit-libs-devel
46 BuildRequires:  augeas-devel
47 BuildRequires:  autoconf >= 2.50
48 BuildRequires:  automake
49 BuildRequires:  avahi-devel >= 0.6.0
50 BuildRequires:  curl-devel >= 7.18.0
51 BuildRequires:  cyrus-sasl-devel
52 BuildRequires:  device-mapper-devel >= 1.0.0
53 BuildRequires:  gawk
54 BuildRequires:  gettext-devel >= 0.17
55 BuildRequires:  gnutls-devel >= 1.0.25
56 BuildRequires:  libapparmor-devel
57 BuildRequires:  libblkid-devel >= 2.17
58 BuildRequires:  libcap-ng-devel >= 0.4.0
59 BuildRequires:  libgcrypt-devel
60 BuildRequires:  libnl1-devel >= 1.1
61 BuildRequires:  libpcap-devel >= 1.0.0
62 BuildRequires:  libselinux-devel >= 2.0.82
63 BuildRequires:  libssh2-devel >= 1.0
64 BuildRequires:  libstdc++-devel
65 BuildRequires:  libtool
66 BuildRequires:  libxml2-devel >= 1:2.6.0
67 BuildRequires:  libxslt-devel
68 BuildRequires:  ncurses-devel
69 %{?with_netcf:BuildRequires:    netcf-devel >= 0.1.4}
70 BuildRequires:  numactl-devel
71 BuildRequires:  openldap-devel
72 BuildRequires:  openwsman-devel >= 2.2.3
73 BuildRequires:  parted-devel >= 1.8.0
74 BuildRequires:  perl-tools-pod
75 %{?with_polkit:BuildRequires:   polkit >= 0.90}
76 BuildRequires:  pkgconfig
77 BuildRequires:  python
78 BuildRequires:  python-devel
79 BuildRequires:  readline-devel
80 BuildRequires:  rpm-pythonprov
81 BuildRequires:  rpmbuild(macros) >= 1.627
82 %{?with_sanlock:BuildRequires:  sanlock-devel >= 0.8}
83 BuildRequires:  udev-devel >= 1:145
84 %{?with_xen:BuildRequires:      xen-devel >= 4.1.2}
85 # For disk driver
86 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10.0
87 BuildRequires:  yajl-devel
88 Requires:       curl-libs >= 7.18.0
89 Requires:       device-mapper >= 1.0.0
90 Requires:       libcap-ng >= 0.4.0
91 Requires:       libnl1 >= 1.1
92 Requires:       libpcap >= 1.0.0
93 Requires:       libselinux >= 2.0.82
94 Requires:       libssh2 >= 1.0
95 Requires:       libxml2 >= 1:2.6.0
96 Requires:       openwsman-libs >= 2.2.3
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %description
100 Libvirt is a C toolkit to interact with the virtualization
101 capabilities of recent versions of Linux.
102
103 Virtualization of the Linux Operating System means the ability to run
104 multiple instances of Operating Systems concurently on a single
105 hardware system where the basic resources are driven by a Linux
106 instance. The library aim at providing long term stable C API
107 initially for the Xen paravirtualization but should be able to
108 integrate other virtualization mechanisms if needed.
109
110 This package contains the base libraries and configuration file.
111
112 %description -l pl.UTF-8
113 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
114 obecnych wersji Linuksa.
115
116 Wirtualizacja w systemie operacyjnym Linux oznacza możliwość
117 jednoczesnego uruchamiania wielu instancji systemu operacyjnego na
118 pojedynczym systemie sprzętowym, którego podstawowe zasoby są
119 zarządzane przez instancję Linuksa. Celem biblioteki jest zapewnienie
120 długotrwale stabilnego API C, początkowo do parawirtualizacji Xen, ale
121 dającej się zintegrować w razie potrzeby z innymi mechanizmami
122 wirtualizacji.
123
124 Ten pakiet zawiera podstawowe biblioteki oraz plik konfiguracyjny.
125
126 %package devel
127 Summary:        Development files for programs using libvirt
128 Summary(pl.UTF-8):      Pliki programistyczne do programów wykorzystujących libvirt
129 Group:          Development/Libraries
130 Requires:       %{name} = %{version}-%{release}
131 Requires:       audit-libs-devel
132 Requires:       curl-devel >= 7.18.0
133 Requires:       device-mapper-devel >= 1.0.0
134 Requires:       gnutls-devel >= 1.0.25
135 Requires:       libapparmor-devel
136 Requires:       libcap-ng-devel >= 0.4.0
137 Requires:       libgcrypt-devel
138 Requires:       libnl1-devel >= 1.1
139 Requires:       libpcap-devel >= 1.0.0
140 Requires:       libselinux-devel >= 2.0.82
141 Requires:       libxml2-devel >= 1:2.6.0
142 Requires:       numactl-devel
143 Requires:       openwsman-devel >= 2.2.3
144 %{?with_xen:Requires: xen-devel}
145 Requires:       yajl-devel
146
147 %description devel
148 Libvirt is a C toolkit to interact with the virtualization
149 capabilities of recent versions of Linux.
150
151 This package contains the header files needed for developing programs
152 using the libvirt library.
153
154 %description devel -l pl.UTF-8
155 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
156 obecnych wersji Linuksa.
157
158 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
159 wykorzystujących bibliotekę libvirt.
160
161 %package static
162 Summary:        Development static libraries for programs using libvirt
163 Summary(pl.UTF-8):      Statyczne biblioteki programistyczne do programów wykorzystujących libvirt
164 Group:          Development/Libraries
165 Requires:       %{name}-devel = %{version}-%{release}
166
167 %description static
168 Libvirt is a C toolkit to interact with the virtualization
169 capabilities of recent versions of Linux.
170
171 This package contains the static libraries for developing programs
172 using the libvirt library.
173
174 %description static -l pl.UTF-8
175 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
176 obecnych wersji Linuksa.
177
178 Ten pakiet zawiera biblioteki statyczne do tworzenia programów
179 wykorzystujących bibliotekę libvirt.
180
181 %package -n python-%{name}
182 Summary:        Python bindings to interact with virtualization capabilities
183 Summary(pl.UTF-8):      Wiązania Pythona do współpracy z funkcjami wirtualizacji
184 Group:          Development/Languages/Python
185 Requires:       %{name} = %{version}-%{release}
186
187 %description -n python-%{name}
188 Libvirt is a C toolkit to interact with the virtualization
189 capabilities of recent versions of Linux.
190
191 This package contains the Python bindings for the libvirt library.
192
193 %description -n python-%{name} -l pl.UTF-8
194 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
195 obecnych wersji Linuksa.
196
197 Ten pakiet zawiera wiązania Pythona do biblioteki libvirt.
198
199 %package lock-sanlock
200 Summary:        Sanlock lock manager plugin for libvirt
201 Summary(pl.UTF-8):      Zarządca blokad sanlock dla biblioteki libvirt
202 Group:          Libraries
203 Requires:       %{name} = %{version}-%{release}
204
205 %description lock-sanlock
206 Sanlock lock manager plugin for libvirt.
207
208 %description lock-sanlock -l pl.UTF-8
209 Zarządca blokad sanlock dla biblioteki libvirt.
210
211 %package daemon
212 Summary:        Server side daemon and supporting files for libvirt library
213 Summary(pl.UTF-8):      Demon działający po stronie serwera oraz pliki wspierające dla biblioteki libvirt
214 Group:          Applications/System
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       avahi-libs >= 0.6.0
217 Requires:       iproute2
218 Requires:       libblkid >= 2.17
219 Provides:       libvirt(hypervisor)
220 %{?with_netcf:Requires: netcf >= 0.1.4}
221 Requires:       parted-libs >= 1.8.0
222 # Needed for probing the power management features of the host.
223 Requires:       pm-utils
224 Requires:       systemd-units >= 37-0.10
225 Requires:       udev-libs >= 1:145
226 Requires:       util-linux
227 Requires:       virtual(module-tools)
228 Requires:       xorg-lib-libpciaccess >= 0.10.0
229 Requires(post): systemd-units
230 Requires(preun):        systemd-units
231 Requires(postun):       systemd-units
232 Suggests:       bridge-utils
233 Suggests:       cyrus-sasl
234 Suggests:       cyrus-sasl-digest-md5
235 Suggests:       dmidecode
236 Suggests:       dnsmasq >= 2.41
237 Suggests:       ebtables
238 Suggests:       gawk
239 Suggests:       glusterfs-client >= 2.0.1
240 Suggests:       iptables
241 Suggests:       iptables
242 Suggests:       libcgroup
243 Suggests:       lvm2
244 Suggests:       numad
245 Suggests:       open-iscsi
246 Suggests:       parted
247 Suggests:       polkit >= 0.93
248 Suggests:       radvd
249 Suggests:       scrub
250
251 %description daemon
252 Server side daemon required to manage the virtualization capabilities
253 of recent versions of Linux. Requires a hypervisor specific sub-RPM
254 for specific drivers.
255
256 %description daemon -l pl.UTF-8
257 Demon działający po stronie serwera wymagany do zarządzania funkcjami
258 wirtualizacji nowych wersji Linuksa. Wymaga podpakietu specyficznego
259 dla hipernadzorcy.
260
261 %package daemon-esx
262 Summary:        Server side driver required to run VMware ESX guests
263 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości VMware ESX
264 Group:          Libraries
265 Requires:       %{name}-daemon = %{version}-%{release}
266 Provides:       libvirt(hypervisor)
267
268 %description daemon-esx
269 Server side driver required to manage the virtualization capabilities
270 of the VMware ESX emulators.
271
272 %description daemon-esx -l pl.UTF-8
273 Sterownik wymagany po stronie serwera do zarządzania funkcjami
274 wirtualizacji emulatora VMware ESX.
275
276 %package daemon-hyperv
277 Summary:        Server side driver required to run Microsoft Hyper-V guests
278 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości Microsoft Hyper-V
279 Group:          Libraries
280 Requires:       %{name}-daemon = %{version}-%{release}
281 Provides:       libvirt(hypervisor)
282
283 %description daemon-hyperv
284 Server side driver required to manage the virtualization capabilities
285 of the Microsoft Hyper-V emulators.
286
287 %description daemon-hyperv -l pl.UTF-8
288 Sterownik wymagany po stronie serwera do zarządzania funkcjami
289 wirtualizacji emulatora Microsoft Hyper-V.
290
291 %package daemon-libxl
292 Summary:        Server side driver required to run XEN guests (xenlight)
293 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości XEN (xenlight)
294 Group:          Libraries
295 Requires:       %{name}-daemon = %{version}-%{release}
296 Requires:       /usr/sbin/qcow-create
297 Requires:       xen
298 Provides:       libvirt(hypervisor)
299
300 %description daemon-libxl
301 Server side driver required to manage the virtualization capabilities
302 of XEN via xenlight interface.
303
304 %description daemon-libxl -l pl.UTF-8
305 Sterownik wymagany po stronie serwera do zarządzania funkcjami
306 wirtualizacji XEN poprzez interfejs xenlight.
307
308 %package daemon-lxc
309 Summary:        Server side driver required to run LXC guests
310 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości LXC
311 Group:          Libraries
312 Requires:       %{name}-daemon = %{version}-%{release}
313 Provides:       libvirt(hypervisor)
314
315 %description daemon-lxc
316 Server side driver required to manage the virtualization capabilities
317 of LXC.
318
319 %description daemon-lxc -l pl.UTF-8
320 Sterownik wymagany po stronie serwera do zarządzania funkcjami
321 wirtualizacji LXC.
322
323 %package daemon-openvz
324 Summary:        Server side driver required to run OpenVZ guests
325 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości OpenVZ
326 Group:          Libraries
327 Requires:       %{name}-daemon = %{version}-%{release}
328 Provides:       libvirt(hypervisor)
329
330 %description daemon-openvz
331 Server side driver required to manage the virtualization capabilities
332 of OpenVZ.
333
334 %description daemon-openvz -l pl.UTF-8
335 Sterownik wymagany po stronie serwera do zarządzania funkcjami
336 wirtualizacji OpenVZ.
337
338 %package daemon-phyp
339 Summary:        Server side driver required to run Power Hypervisors guests
340 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości Power Hypervisors
341 Group:          Libraries
342 Requires:       %{name}-daemon = %{version}-%{release}
343 Provides:       libvirt(hypervisor)
344
345 %description daemon-phyp
346 Server side driver required to manage the virtualization capabilities
347 of Power Hypervisors.
348
349 %description daemon-phyp -l pl.UTF-8
350 Sterownik wymagany po stronie serwera do zarządzania funkcjami
351 wirtualizacji Power Hypervisors.
352
353 %package daemon-qemu
354 Summary:        Server side driver required to run QEMU guests
355 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości QEMU
356 Group:          Libraries
357 Requires:       %{name}-daemon = %{version}-%{release}
358 Requires:       /usr/bin/qemu-img
359 Requires:       qemu
360 Requires:       bzip2
361 Requires:       gzip
362 Requires:       lzop
363 Requires:       xz
364 Provides:       libvirt(hypervisor)
365
366 %description daemon-qemu
367 Server side driver required to manage the virtualization capabilities
368 of the QEMU emulators.
369
370 %description daemon-qemu -l pl.UTF-8
371 Sterownik wymagany po stronie serwera do zarządzania funkcjami
372 wirtualizacji emulatora QEMU.
373
374 %package daemon-uml
375 Summary:        Server side driver required to run UML guests
376 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości UML
377 Group:          Libraries
378 Requires:       %{name}-daemon = %{version}-%{release}
379 Provides:       libvirt(hypervisor)
380
381 %description daemon-uml
382 Server side driver required to manage the virtualization capabilities
383 of UML.
384
385 %description daemon-uml -l pl.UTF-8
386 Sterownik wymagany po stronie serwera do zarządzania funkcjami
387 wirtualizacji UML.
388
389 %package daemon-vbox
390 Summary:        Server side driver required to run Oracle VirtualBox guests
391 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości Oracle VirtualBox
392 Group:          Libraries
393 Requires:       %{name}-daemon = %{version}-%{release}
394 Provides:       libvirt(hypervisor)
395
396 %description daemon-vbox
397 Server side driver required to manage the virtualization capabilities
398 of Oracle VirtualBox.
399
400 %description daemon-vbox -l pl.UTF-8
401 Sterownik wymagany po stronie serwera do zarządzania funkcjami
402 wirtualizacji Oracle VirtualBox.
403
404 %package daemon-vmware
405 Summary:        Server side driver required to run VMware Workstation guests
406 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości VMware Workstation
407 Group:          Libraries
408 Requires:       %{name}-daemon = %{version}-%{release}
409 Provides:       libvirt(hypervisor)
410
411 %description daemon-vmware
412 Server side driver required to manage the virtualization capabilities
413 of VMware Workstation.
414
415 %description daemon-vmware -l pl.UTF-8
416 Sterownik wymagany po stronie serwera do zarządzania funkcjami
417 wirtualizacji VMware Workstation.
418
419 %package daemon-xen
420 Summary:        Server side driver required to run XEN guests
421 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości XEN
422 Group:          Libraries
423 Requires:       %{name}-daemon = %{version}-%{release}
424 Requires:       /usr/sbin/qcow-create
425 Requires:       xen
426 Requires:       xen-xend
427 Provides:       libvirt(hypervisor)
428
429 %description daemon-xen
430 Server side driver required to manage the virtualization capabilities
431 of XEN.
432
433 %description daemon-xen -l pl.UTF-8
434 Sterownik wymagany po stronie serwera do zarządzania funkcjami
435 wirtualizacji XEN.
436
437 %package client
438 Summary:        Client side utilities of the libvirt library
439 Summary(pl.UTF-8):      Narzędzia klienckie do biblioteki libvirt
440 Group:          Applications/System
441 Requires:       gettext >= 0.18.1.1-6
442 Requires:       gnutls >= 1.0.25
443 Requires:       netcat-openbsd
444 Requires(post): systemd-units
445 Requires(preun):        systemd-units
446 Requires(postun):       systemd-units
447
448 %description client
449 Client binaries needed to access to the virtualization capabilities of
450 recent versions of Linux (and other OSes).
451
452 %description client -l pl.UTF-8
453 Programy klienckie potrzebne do funkcji wirtualizacji nowych wersji
454 Linuksa (oraz innych systemów operacyjnych).
455
456 %package utils
457 Summary:        Tools to interact with virtualization capabilities (metapackage)
458 Summary(pl.UTF-8):      Narzędzia do współpracy z funkcjami wirtualizacyjnymi (metapakiet)
459 Group:          Applications/System
460 Requires:       %{name}-client = %{version}-%{release}
461 Requires:       %{name}-daemon = %{version}-%{release}
462 Requires:       %{name}-daemon-esx = %{version}-%{release}
463 Requires:       %{name}-daemon-hyperv = %{version}-%{release}
464 Requires:       %{name}-daemon-libxl = %{version}-%{release}
465 Requires:       %{name}-daemon-lxc = %{version}-%{release}
466 Requires:       %{name}-daemon-openvz = %{version}-%{release}
467 Requires:       %{name}-daemon-phyp = %{version}-%{release}
468 Requires:       %{name}-daemon-qemu = %{version}-%{release}
469 Requires:       %{name}-daemon-uml = %{version}-%{release}
470 Requires:       %{name}-daemon-vbox = %{version}-%{release}
471 Requires:       %{name}-daemon-vmware = %{version}-%{release}
472 Requires:       %{name}-daemon-xen = %{version}-%{release}
473
474 %description utils
475 Libvirt is a C toolkit to interact with the virtualization
476 capabilities of recent versions of Linux.
477
478 This is metapackage gathering all tools for the libvirt library.
479
480 %description utils -l pl.UTF-8
481 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
482 obecnych wersji Linuksa.
483
484 To jest metapakiet zbierający wszystkie narzędzia przeznaczone dla
485 biblioteki libvirt.
486
487 %prep
488 %setup -q
489 %patch0 -p1
490 %patch1 -p1
491 %patch2 -p1
492 %patch3 -p1
493 %patch4 -p1
494 %patch5 -p1
495
496 # weird translations
497 %{__rm} po/{my,eu_ES}.{po,gmo}
498
499 mv po/vi_VN.po po/vi.po
500 mv po/vi_VN.gmo po/vi.gmo
501
502 %build
503 %{__libtoolize}
504 %{__aclocal} -I gnulib/m4 -I m4
505 %{__autoconf}
506 %{__autoheader}
507 %{__automake}
508
509 %configure \
510         PVCREATE=/sbin/pvcreate \
511         VGCREATE=/sbin/vgcreate \
512         LVCREATE=/sbin/lvcreate \
513         PVREMOVE=/sbin/pvremove \
514         VGREMOVE=/sbin/vgremove \
515         LVREMOVE=/sbin/lvremove \
516         VGCHANGE=/sbin/vgchange \
517         LVCHANGE=/sbin/lvchange \
518           VGSCAN=/sbin/vgscan   \
519              PVS=/sbin/pvs      \
520              VGS=/sbin/vgs      \
521              LVS=/sbin/lvs      \
522               TC=/sbin/tc \
523            BRCTL=/sbin/brctl    \
524         ISCSIADM=/sbin/iscsiadm \
525         SHOWMOUNT=/usr/sbin/showmount \
526         MOUNT=/bin/mount \
527         UMOUNT=/bin/umount \
528         MKFS=/sbin/mkfs \
529         SHOWMOUNT=/usr/sbin/showmount \
530         IPTABLES_PATH=/usr/sbin/iptables \
531         IP6TABLES_PATH=/usr/sbin/ip6tables \
532         EBTABLES_PATH=/usr/sbin/ebtables \
533         ISCSIADM=/sbin/iscsiadm \
534         DNSMASQ=/usr/sbin/dnsmasq \
535         RADVD=/usr/sbin/radvd \
536         UDEVADM=/sbin/udevadm \
537         MODPROBE=/sbin/modprobe \
538         SCRUB=/usr/bin/scrub \
539         OVSVSCTL=/usr/bin/ovs-vsctl \
540         NUMAD=/usr/bin/numad \
541         --disable-silent-rules \
542         --with-html-dir=%{_gtkdocdir} \
543         --with-html-subdir=%{name} \
544         --with-init-script=redhat \
545         --with-storage-lvm \
546         --with-storage-fs \
547         --with-storage-iscsi \
548         --with-storage-scsi \
549         --with-storage-mpath \
550         --with-storage-disk \
551         --with-macvtap \
552         --with-virtualport \
553         --with-udev \
554         --with-libssh2 \
555         --with-avahi \
556         --with-audit \
557         --with-libblkid \
558         --with-macvtap \
559         --with-virtualport \
560         --with-numad \
561         --with-numactl \
562         --with-sasl \
563         --with-yajl \
564         --with-selinux \
565         --with-apparmor \
566         --with-qemu-user=qemu \
567         --with-qemu-group=qemu \
568         --without-hal \
569         --with-driver-modules \
570         %{__with_without polkit} \
571         %{__with_without esx} \
572         %{__with_without hyperv} \
573         %{__with_without libxl} \
574         %{__with_without lxc} \
575         %{__with_without netcf} \
576         %{__with_without openvz} \
577         %{__with_without phyp} \
578         %{__with_without qemu} \
579         %{__with_without sanlock} \
580         %{__with_without uml} \
581         %{__with_without vbox vbox %{_libdir}/VirtualBox} \
582         %{__with_without vmware} \
583         %{__with_without xen} \
584         %{__with_without xenapi} \
585         --x-libraries=%{_libdir} \
586         --with-init-script=systemd
587
588 %{__make} \
589         AWK=gawk
590
591 %install
592 rm -rf $RPM_BUILD_ROOT
593 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} \
594         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
595
596 %{__make} install \
597         DEVHELP_DIR=%{_gtkdocdir}/%{name}/devhelp \
598         DESTDIR=$RPM_BUILD_ROOT
599
600 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/libvirtd
601 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
602
603 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
604 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
605 %py_postclean
606 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
607
608 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
609 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/connection-driver/*.{a,la}
610
611 %if %{with sanlock}
612 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/lock-driver/*.{a,la}
613 %endif
614
615 %find_lang %{name}
616
617 %clean
618 rm -rf $RPM_BUILD_ROOT
619
620 %post   -p /sbin/ldconfig
621 %postun -p /sbin/ldconfig
622
623 %post daemon
624 %systemd_post libvirtd.service
625
626 %preun daemon
627 %systemd_preun libvirtd.service
628
629 %postun daemon
630 %systemd_reload
631
632 %post client
633 NORESTART=1
634 %systemd_post libvirt-guests.service
635
636 %preun client
637 %systemd_preun libvirt-guests.service
638
639 %postun client
640 %systemd_reload
641
642 %files -f %{name}.lang
643 %defattr(644,root,root,755)
644 %doc ChangeLog README TODO NEWS
645 %dir %{_sysconfdir}/libvirt
646 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirt.conf
647 %attr(755,root,root) %{_libdir}/libvirt.so.*.*.*
648 %attr(755,root,root) %ghost %{_libdir}/libvirt.so.0
649 %if %{with qemu}
650 %attr(755,root,root) %{_libdir}/libvirt-qemu.so.*.*.*
651 %attr(755,root,root) %ghost %{_libdir}/libvirt-qemu.so.0
652 %endif
653 %dir %{_libdir}/libvirt
654
655 %files devel
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/libvirt.so
658 %attr(755,root,root) %{_libdir}/libvirt-qemu.so
659 %{_datadir}/%{name}/api
660 %{_gtkdocdir}/%{name}
661 %{_includedir}/%{name}
662 %{_pkgconfigdir}/%{name}.pc
663
664 %files static
665 %defattr(644,root,root,755)
666 %{_libdir}/libvirt.a
667 %{_libdir}/libvirt-qemu.a
668
669 %files -n python-%{name}
670 %defattr(644,root,root,755)
671 %doc %{_docdir}/%{name}-python-%{version}
672 %attr(755,root,root) %{py_sitedir}/libvirtmod.so
673 %attr(755,root,root) %{py_sitedir}/libvirtmod_qemu.so
674 %{py_sitedir}/libvirt.py[co]
675 %{py_sitedir}/libvirt_qemu.py[co]
676
677 %if %{with sanlock}
678 %files lock-sanlock
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_sbindir}/virt-sanlock-cleanup
681 %dir %{_libdir}/libvirt/lock-driver
682 %attr(755,root,root) %{_libdir}/libvirt/lock-driver/sanlock.so
683 %{_datadir}/augeas/lenses/libvirt_sanlock.aug
684 %{_datadir}/augeas/lenses/tests/test_libvirt_sanlock.aug
685 %dir /var/lib/libvirt/sanlock
686 %{_mandir}/man8/virt-sanlock-cleanup.8*
687 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu-sanlock.conf
688 %endif
689
690 %files daemon
691 %defattr(644,root,root,755)
692 %doc docs/*.xml
693 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/nwfilter
694 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu
695 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks
696 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks/autostart
697 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirtd.conf
698 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/default.xml
699 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/autostart/default.xml
700 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/nwfilter/*.xml
701 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/libvirt.conf
702 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirtd
703 %attr(754,root,root) /etc/rc.d/init.d/libvirtd
704 %{systemdunitdir}/libvirtd.service
705 %config(noreplace) %verify(not md5 mtime size) /etc/sysctl.d/libvirtd
706 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd
707 %attr(755,root,root) %{_libdir}/libvirt_iohelper
708 %attr(755,root,root) %{_libdir}/libvirt_parthelper
709 %attr(755,root,root) %{_libdir}/virt-aa-helper
710 %attr(755,root,root) %{_sbindir}/libvirtd
711 %{_datadir}/augeas/lenses/libvirtd.aug
712 %{_datadir}/augeas/lenses/tests/test_libvirtd.aug
713 %{?with_polkit:%{_datadir}/polkit-1/actions/org.libvirt.unix.policy}
714 %{_mandir}/man8/libvirtd.8*
715 %dir /var/lib/libvirt
716 %dir /var/lib/libvirt/dnsmasq
717 %attr(711,root,root) %dir /var/lib/libvirt/boot
718 %attr(700,root,root) %dir /var/lib/libvirt/network
719 %attr(711,root,root) %dir /var/lib/libvirt/images
720 %attr(711,root,root) %dir /var/lib/libvirt/filesystems
721 %attr(700,root,root) %dir /var/log/libvirt
722 %attr(711,root,root) %dir /var/cache/libvirt
723 %dir /var/run/libvirt
724 %dir /var/run/libvirt/network
725 %{systemdtmpfilesdir}/%{name}.conf
726 %dir %{_libdir}/libvirt/connection-driver
727 %{?with_netcf:%attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_interface.so}
728 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_network.so
729 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_nodedev.so
730 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_nwfilter.so
731 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_secret.so
732 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_storage.so
733 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_test.so
734
735 %if %{with esx}
736 %files daemon-esx
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_esx.so
739 %endif
740
741 %if %{with hyperv}
742 %files daemon-hyperv
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_hyperv.so
745 %endif
746
747 %if %{with libxl}
748 %files daemon-libxl
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_libxl.so
751 %attr(700,root,root) %dir /var/lib/libvirt/libxl
752 %attr(700,root,root) %dir /var/run/libvirt/libxl
753 %attr(700,root,root) %dir /var/log/libvirt/libxl
754 %endif
755
756 %if %{with lxc}
757 %files daemon-lxc
758 %defattr(644,root,root,755)
759 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/lxc.conf
760 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.lxc
761 %attr(700,root,root) %dir /var/lib/libvirt/lxc
762 %attr(700,root,root) %dir /var/run/libvirt/lxc
763 %attr(700,root,root) %dir /var/log/libvirt/lxc
764 %{_datadir}/augeas/lenses/libvirtd_lxc.aug
765 %{_datadir}/augeas/lenses/tests/test_libvirtd_lxc.aug
766 %attr(755,root,root) %{_libdir}/libvirt_lxc
767 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_lxc.so
768 %endif
769
770 %if %{with openvz}
771 %files daemon-openvz
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_openvz.so
774 %endif
775
776 %if %{with phyp}
777 %files daemon-phyp
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_phyp.so
780 %endif
781
782 %if %{with qemu}
783 %files daemon-qemu
784 %defattr(644,root,root,755)
785 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu.conf
786 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.qemu
787 %attr(750,qemu,qemu) %dir /var/cache/libvirt/qemu
788 %attr(750,qemu,qemu) %dir /var/lib/libvirt/qemu
789 %attr(700,root,root) %dir /var/log/libvirt/qemu
790 %attr(700,root,root) %dir /var/run/libvirt/qemu
791 %{_datadir}/augeas/lenses/libvirtd_qemu.aug
792 %{_datadir}/augeas/lenses/tests/test_libvirtd_qemu.aug
793 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_qemu.so
794 %endif
795
796 %if %{with uml}
797 %files daemon-uml
798 %defattr(644,root,root,755)
799 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_uml.so
800 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.uml
801 %attr(700,root,root) %dir /var/lib/libvirt/uml
802 %attr(700,root,root) %dir /var/run/libvirt/uml
803 %attr(700,root,root) %dir /var/log/libvirt/uml
804 %endif
805
806 %if %{with vbox}
807 %files daemon-vbox
808 %defattr(644,root,root,755)
809 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_vbox.so
810 %endif
811
812 %if %{with vmware}
813 %files daemon-vmware
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_vmware.so
816 %endif
817
818 %if %{with xen}
819 %files daemon-xen
820 %defattr(644,root,root,755)
821 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_xen.so
822 %endif
823
824 %files client
825 %defattr(644,root,root,755)
826 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirt-guests
827 %attr(754,root,root) /etc/rc.d/init.d/libvirt-guests
828 %{systemdunitdir}/libvirt-guests.service
829 %attr(755,root,root) %{_bindir}/virsh
830 %attr(755,root,root) %{_bindir}/virt-host-validate
831 %attr(755,root,root) %{_bindir}/virt-xml-validate
832 %attr(755,root,root) %{_bindir}/virt-pki-validate
833 %{_mandir}/man1/virsh.1*
834 %{_mandir}/man1/virt-host-validate.1*
835 %{_mandir}/man1/virt-xml-validate.1*
836 %{_mandir}/man1/virt-pki-validate.1*
837 %dir %{_datadir}/libvirt
838 %{_datadir}/libvirt/cpu_map.xml
839 %dir %{_datadir}/libvirt/schemas
840 %{_datadir}/libvirt/schemas/basictypes.rng
841 %{_datadir}/libvirt/schemas/capability.rng
842 %{_datadir}/libvirt/schemas/domain.rng
843 %{_datadir}/libvirt/schemas/domaincommon.rng
844 %{_datadir}/libvirt/schemas/domainsnapshot.rng
845 %{_datadir}/libvirt/schemas/interface.rng
846 %{_datadir}/libvirt/schemas/network.rng
847 %{_datadir}/libvirt/schemas/networkcommon.rng
848 %{_datadir}/libvirt/schemas/nodedev.rng
849 %{_datadir}/libvirt/schemas/nwfilter.rng
850 %{_datadir}/libvirt/schemas/secret.rng
851 %{_datadir}/libvirt/schemas/storageencryption.rng
852 %{_datadir}/libvirt/schemas/storagepool.rng
853 %{_datadir}/libvirt/schemas/storagevol.rng
854
855 %files utils
856 %defattr(644,root,root,755)
This page took 0.080396 seconds and 2 git commands to generate.