]> git.pld-linux.org Git - packages/libvirt-sandbox.git/blob - libvirt-sandbox.spec
- fix python shebang
[packages/libvirt-sandbox.git] / libvirt-sandbox.spec
1 Summary:        API for building application sandboxes using libvirt
2 Summary(pl.UTF-8):      API do tworzenia sandboksów aplikacyjnych przy użyciu libvirt
3 Name:           libvirt-sandbox
4 Version:        0.6.0
5 Release:        2
6 License:        LGPL v2.1+
7 Group:          Libraries
8 Source0:        ftp://libvirt.org/libvirt/sandbox/%{name}-%{version}.tar.gz
9 # Source0-md5:  546eb0caaa79d50a723adf58f32da87f
10 URL:            http://libvirt.org/
11 BuildRequires:  gettext-tools
12 BuildRequires:  glib2-devel >= 1:2.32.0
13 # ldd
14 BuildRequires:  glibc-misc
15 BuildRequires:  glibc-static
16 BuildRequires:  gobject-introspection-devel >= 0.10.8
17 BuildRequires:  gtk-doc >= 1.10
18 BuildRequires:  intltool >= 0.35.0
19 BuildRequires:  libcap-ng-devel >= 0.4.0
20 BuildRequires:  libselinux-devel
21 BuildRequires:  libvirt-devel >= 1.0.2
22 BuildRequires:  libvirt-glib-devel >= 0.2.1
23 BuildRequires:  pkgconfig
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  xz-devel >= 1:5.0.0
26 BuildRequires:  xz-static >= 1:5.0.0
27 BuildRequires:  zlib-devel >= 1.2.0
28 BuildRequires:  zlib-static >= 1.2.0
29 Requires:       glib2 >= 1:2.32.0
30 Requires:       libcap-ng >= 0.4.0
31 Requires:       libvirt >= 1.0.2
32 Requires:       libvirt-glib >= 0.2.1
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 The libvirt-sandbox package provides an API for building application
37 sandboxes using libvirt. Sandboxes can be based on either container or
38 machine based virtualization technology. Also included is a simple
39 command line tool for launching sandboxes for arbitrary commands.
40
41 %description -l pl.UTF-8
42 Libvirt-sandbox udostępnia API do tworzenia sandboksów ("piaskownic")
43 aplikacyjnych przy użyciu libvirt. Sandboksy mogą być oparte na
44 wirtualizacji kontenera lub maszyny. Dołączone są także proste
45 narzędzia uruchamiane z linii poleceń do uruchamiania sandboksów
46 dowolnych poleceń.
47
48 %package devel
49 Summary:        Header files for libvirt-sandbox library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libvirt-sandbox
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       glib2-devel >= 1:2.32.0
54 Requires:       libvirt-devel >= 1.0.2
55 Requires:       libvirt-glib-devel >= 0.2.1
56
57 %description devel
58 Header files for libvirt-sandbox library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki libvirt-sandbox.
62
63 %package static
64 Summary:        Static libvirt-sandbox library
65 Summary(pl.UTF-8):      Statyczna biblioteka libvirt-sandbox
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static libvirt-sandbox library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka libvirt-sandbox.
74
75 %package -n bash-completion-libvirt-sandbox
76 Summary:        Bash completion rules for libvirt-sandbox
77 Summary(pl.UTF-8):      Bashowe uzupełnianie poleceń dla pakietu libvirt-sandbox
78 Group:          Applications/Shells
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       bash-completion >= 2.0
81 %if "%{_rpmversion}" >= "5"
82 BuildArch:      noarch
83 %endif
84
85 %description -n bash-completion-libvirt-sandbox
86 Bash completion rules for virt-sandbox-service command.
87
88 %description -n bash-completion-libvirt-sandbox -l pl.UTF-8
89 Bashowe uzupełnianie parametrów dla polecenia virt-sandbox-service.
90
91 %prep
92 %setup -q
93
94 # what is it? seems not required
95 %{__sed} -i -e '/Requires: sandbox-2.0/d' libvirt-sandbox-1.0.pc.in
96
97 %{__sed} -E -i -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
98       bin/virt-sandbox-service
99
100 %build
101 %configure \
102         --disable-silent-rules \
103         --with-html-dir=%{_gtkdocdir}
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 # obsoleted by pkg-config
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt-sandbox-1.0.la
114 # just placeholder, useless in RPM
115 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/libvirt-sandbox/scratch/README
116
117 %find_lang %{name}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files -f %{name}.lang
123 %defattr(644,root,root,755)
124 %doc AUTHORS ChangeLog NEWS README TODO
125 %attr(755,root,root) %{_bindir}/virt-sandbox
126 %attr(755,root,root) %{_bindir}/virt-sandbox-service
127 %attr(755,root,root) %{_libdir}/libvirt-sandbox-1.0.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libvirt-sandbox-1.0.so.5
129 %{_libdir}/girepository-1.0/LibvirtSandbox-1.0.typelib
130 %attr(755,root,root) %{_libexecdir}/libvirt-sandbox-init-common
131 %attr(755,root,root) %{_libexecdir}/libvirt-sandbox-init-lxc
132 %attr(755,root,root) %{_libexecdir}/libvirt-sandbox-init-qemu
133 %attr(755,root,root) %{_libexecdir}/virt-sandbox-service-util
134 %dir %{_sysconfdir}/libvirt-sandbox
135 %dir %{_sysconfdir}/libvirt-sandbox/scratch
136 %dir %{_sysconfdir}/libvirt-sandbox/services
137 %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/virt-sandbox-service.logrotate
138 %{_mandir}/man1/virt-sandbox.1*
139 %{_mandir}/man1/virt-sandbox-service.1*
140 %{_mandir}/man1/virt-sandbox-service-*.1*
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libvirt-sandbox-1.0.so
145 %{_includedir}/libvirt-sandbox-1.0
146 %{_pkgconfigdir}/libvirt-sandbox-1.0.pc
147 %{_datadir}/gir-1.0/LibvirtSandbox-1.0.gir
148 %{_gtkdocdir}/Libvirt-sandbox
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libvirt-sandbox-1.0.a
153
154 %files -n bash-completion-libvirt-sandbox
155 %defattr(644,root,root,755)
156 %{_datadir}/bash-completion/completions/virt-sandbox-service
This page took 0.059541 seconds and 3 git commands to generate.