]> git.pld-linux.org Git - packages/libvdpau.git/blob - libvdpau.spec
rel 3
[packages/libvdpau.git] / libvdpau.spec
1 #
2 # Conditional build:
3 %if "%{pld_release}" == "ac"
4 %bcond_with             apidocs         # build and package API docs
5 %else
6 %bcond_without  apidocs         # do not build and package API docs
7 %endif
8
9 Summary:        Wrapper library for the Video Decode and Presentation API
10 Summary(pl.UTF-8):      Biblioteka pośrednia do API dekodowania i prezentacji video (Video Decode and Presentation API)
11 Name:           libvdpau
12 Version:        0.6
13 Release:        3
14 License:        MIT
15 Group:          Libraries
16 Source0:        http://people.freedesktop.org/~aplattner/vdpau/%{name}-%{version}.tar.gz
17 # Source0-md5:  78a3a992b8187182463d3998e5d17916
18 URL:            http://freedesktop.org/wiki/Software/VDPAU
19 BuildRequires:  autoconf >= 2.60
20 BuildRequires:  automake
21 %if %{with apidocs}
22 BuildRequires:  doxygen
23 BuildRequires:  graphviz
24 %endif
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpm >= 4.4.9-56
29 %if "%{pld_release}" == "ac"
30 BuildRequires:  XFree86-devel
31 %else
32 %{?with_apidocs:BuildRequires:  texlive-pdftex}
33 BuildRequires:  xorg-lib-libX11-devel >= 1.5
34 BuildRequires:  xorg-lib-libXext-devel
35 BuildRequires:  xorg-proto-dri2proto-devel >= 2.2
36 %endif
37 Requires:       xorg-lib-libX11 >= 1.5
38 # libvdpau isn't arch-specific, but currently only nvidia driver is available
39 # (xorg-driver-video-nvidia.spec)
40 Conflicts:      xorg-driver-video-nvidia-libs < 1:190.42-2
41 ExclusiveArch:  %{ix86} %{x8664}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 VDPAU is the Video Decode and Presentation API for UNIX. It provides
46 an interface to video decode acceleration and presentation hardware
47 present in modern GPUs.
48
49 %description -l pl.UTF-8
50 VDPAU to skrót od Video Decode and Presentation API for UNIX.
51 Biblioteka ta dostarcza interfejs do akceleracji dekodowania oraz
52 prezentacji video obecnej we współczesnych procesorach graficznych.
53
54 %package devel
55 Summary:        Header files for vdpau library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki vdpau
57 Group:          Development/Libraries
58 %if "%{pld_release}" == "ac"
59 Requires:       XFree86-devel
60 %else
61 Requires:       xorg-lib-libX11-devel
62 %endif
63 Requires:       %{name} = %{version}-%{release}
64
65 %description devel
66 Header files for vdpau library.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe biblioteki vdpau.
70
71 %package static
72 Summary:        Static vdpau library
73 Summary(pl.UTF-8):      Statyczna biblioteka vdpau
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static vdpau library.
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka vdpau.
82
83 %package apidocs
84 Summary:        vdpau API documentation
85 Summary(pl.UTF-8):      Dokumentacja API biblioteki vdpau
86 Group:          Documentation
87
88 %description apidocs
89 API and internal documentation for vdpau library.
90
91 %description apidocs -l pl.UTF-8
92 Dokumentacja API biblioteki vdpau.
93
94 %prep
95 %setup -q
96
97 %build
98 %{__libtoolize}
99 %{__aclocal}
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %if "%{pld_release}" == "ac"
104 X11_CFLAGS=" " X11_LIBS="-L%{_prefix}/X11R6/%{_lib} -lX11" \
105 %endif
106 %configure \
107         --enable-documentation%{!?with_apidocs:=no} \
108         --enable-static
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %{__rm} $RPM_BUILD_ROOT%{_libdir}/vdpau/libvdpau_trace.{la,a}
118 %{__rm} $RPM_BUILD_ROOT%{_libdir}/vdpau/libvdpau_trace.so
119
120 %if %{with apidocs}
121 mv $RPM_BUILD_ROOT%{_docdir}/{%{name}/html,%{name}-apidocs}
122 %endif
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS COPYING ChangeLog
133 %attr(755,root,root) %{_libdir}/libvdpau.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libvdpau.so.1
135 %dir %{_libdir}/vdpau
136 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_trace.so.*.*.*
137 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_trace.so.1
138 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vdpau_wrapper.cfg
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libvdpau.so
143 %{_libdir}/libvdpau.la
144 %{_includedir}/vdpau
145 %{_pkgconfigdir}/vdpau.pc
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libvdpau.a
150
151 %if %{with apidocs}
152 %files apidocs
153 %defattr(644,root,root,755)
154 %{_docdir}/%{name}-apidocs
155 %endif
This page took 0.081851 seconds and 3 git commands to generate.