]> git.pld-linux.org Git - packages/libvdpau.git/blob - libvdpau.spec
5fd0219d06ec3b348f009fd059f8638857c22006
[packages/libvdpau.git] / libvdpau.spec
1 #
2 # Conditional build:
3 %if "%{pld_release}" == "ac"
4 %bcond_with     apidocs         # build and package API docs
5 %else
6 %bcond_without  apidocs         # do not build and package API docs
7 %endif
8
9 Summary:        Wrapper library for the Video Decode and Presentation API
10 Summary(pl.UTF-8):      Biblioteka pośrednia do API dekodowania i prezentacji video (Video Decode and Presentation API)
11 Name:           libvdpau
12 Version:        1.3
13 Release:        1
14 License:        MIT
15 Group:          Libraries
16 #Source0Download: https://gitlab.freedesktop.org/vdpau/libvdpau/tags
17 Source0:        https://gitlab.freedesktop.org/vdpau/libvdpau/-/archive/%{version}/libvdpau-%{version}.tar.bz2
18 # Source0-md5:  817e44068cbf92bfa93308daaeef2280
19 URL:            https://freedesktop.org/wiki/Software/VDPAU
20 %if %{with apidocs}
21 BuildRequires:  doxygen
22 BuildRequires:  graphviz
23 %endif
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  meson >= 0.41
26 BuildRequires:  ninja >= 1.5
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpm >= 4.4.9-56
29 BuildRequires:  rpmbuild(macros) >= 1.736
30 %if "%{pld_release}" == "ac"
31 BuildRequires:  XFree86-devel
32 %else
33 %{?with_apidocs:BuildRequires:  texlive-pdftex}
34 BuildRequires:  xorg-lib-libX11-devel >= 1.5
35 BuildRequires:  xorg-lib-libXext-devel
36 BuildRequires:  xorg-proto-dri2proto-devel >= 2.2
37 %endif
38 Requires:       xorg-lib-libX11 >= 1.5
39 # withdrawn (and never useful) Mesa drivers
40 Obsoletes:      libvdpau-driver-mesa-r300 < 10
41 Obsoletes:      libvdpau-driver-mesa-softpipe < 10
42 Conflicts:      xorg-driver-video-nvidia-libs < 1:190.42-2
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 VDPAU is the Video Decode and Presentation API for UNIX. It provides
47 an interface to video decode acceleration and presentation hardware
48 present in modern GPUs.
49
50 %description -l pl.UTF-8
51 VDPAU to skrót od Video Decode and Presentation API for UNIX.
52 Biblioteka ta dostarcza interfejs do akceleracji dekodowania oraz
53 prezentacji video obecnej we współczesnych procesorach graficznych.
54
55 %package devel
56 Summary:        Header files for vdpau library
57 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki vdpau
58 Group:          Development/Libraries
59 %if "%{pld_release}" == "ac"
60 Requires:       XFree86-devel
61 %else
62 Requires:       xorg-lib-libX11-devel
63 %endif
64 Requires:       %{name} = %{version}-%{release}
65 Obsoletes:      libvdpau-static
66
67 %description devel
68 Header files for vdpau library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe biblioteki vdpau.
72
73 %package apidocs
74 Summary:        vdpau API documentation
75 Summary(pl.UTF-8):      Dokumentacja API biblioteki vdpau
76 Group:          Documentation
77 %if "%{_rpmversion}" >= "5"
78 BuildArch:      noarch
79 %endif
80
81 %description apidocs
82 API and internal documentation for vdpau library.
83
84 %description apidocs -l pl.UTF-8
85 Dokumentacja API biblioteki vdpau.
86
87 %prep
88 %setup -q
89
90 %build
91 %meson build \
92         -Ddocumentation=%{__true_false apidocs}
93 %ninja_build -C build
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %ninja_install -C build
99
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/vdpau/libvdpau_trace.so
101
102 %if %{with apidocs}
103 mv $RPM_BUILD_ROOT%{_docdir}/{%{name}/html,%{name}-apidocs}
104 %endif
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS COPYING
115 %attr(755,root,root) %{_libdir}/libvdpau.so.*.*.*
116 %attr(755,root,root) %ghost %{_libdir}/libvdpau.so.1
117 %dir %{_libdir}/vdpau
118 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_trace.so.*.*.*
119 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_trace.so.1
120 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vdpau_wrapper.cfg
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/libvdpau.so
125 %{_includedir}/vdpau
126 %{_pkgconfigdir}/vdpau.pc
127
128 %if %{with apidocs}
129 %files apidocs
130 %defattr(644,root,root,755)
131 %{_docdir}/%{name}-apidocs
132 %endif
This page took 0.129374 seconds and 2 git commands to generate.