]> git.pld-linux.org Git - packages/libva-driver-intel-hybrid.git/blob - libva-driver-intel-hybrid.spec
9274bf1b316664daae575995e505a0f0607ea71e
[packages/libva-driver-intel-hybrid.git] / libva-driver-intel-hybrid.spec
1 #
2 # Conditional build:
3 %bcond_with     drm     # DRM backend, not used as of 1.0.2 (grep for HAVE_VA_DRM, USE_DRM)
4 %bcond_with     wayland # Wayland backend, not used as of 1.0.2 (grep for HAVE_VA_WAYLAND, USE_WAYLAND)
5
6 %define libva_ver       1.6.1
7 Summary:        Codecs for VA Intel Driver
8 Summary(pl.UTF-8):      Kodeki dla sterownika VA Intel
9 Name:           libva-driver-intel-hybrid
10 Version:        1.0.2
11 Release:        1
12 License:        MIT
13 Group:          Libraries
14 #Source0Download: https://github.com/01org/intel-hybrid-driver/releases
15 Source0:        https://github.com/01org/intel-hybrid-driver/archive/%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  05e97e6948963f08eb14a4a8f68bcf69
17 URL:            https://github.com/01org/intel-hybrid-driver
18 %{?with_wayland:BuildRequires:  EGL-devel}
19 BuildRequires:  autoconf >= 2.57
20 BuildRequires:  automake >= 1:1.9
21 # pkgconfig(libcmrt) >= 0.10.0, but cmrt <= 1.0.5 provided cmrt.pc instead of libcmrt.pc
22 BuildRequires:  libcmrt-devel >= 1.0.6
23 %{?with_drm:BuildRequires:      libdrm-devel >= 2.4.45}
24 BuildRequires:  libtool
25 BuildRequires:  libva-devel >= %{libva_ver}
26 %{?with_drm:BuildRequires:      libva-drm-devel >= %{libva_ver}}
27 %{?with_wayland:BuildRequires:  libva-wayland-devel >= %{libva_ver}}
28 BuildRequires:  libva-x11-devel >= %{libva_ver}
29 BuildRequires:  pkgconfig
30 # API version, not just package version
31 BuildRequires:  pkgconfig(libva) >= 0.38
32 %{?with_wayland:BuildRequires:  wayland-devel}
33 %{?with_drm:Requires:   libdrm >= 2.4.45}
34 Requires:       libva >= %{libva_ver}
35 Requires:       libva-driver-intel >= 1.6.1
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Codecs for VA Intel Driver:
40 - Hybrid VP8 Encoder
41 - Hybrid VP9 Decoder
42
43 %description -l pl.UTF-8
44 Kodeki dla sterownika VA Intel:
45 - Hybrydowy koder VP8
46 - Hybrydowy dekoder VP9
47
48 %prep
49 %setup -q -n intel-hybrid-driver-%{version}
50
51 %build
52 %{__libtoolize}
53 %{__aclocal}
54 %{__autoconf}
55 %{__autoheader}
56 %{__automake}
57 %configure \
58         --disable-silent-rules
59
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libva/dri/*.la
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc AUTHORS COPYING NEWS README
76 %attr(755,root,root) %{_libdir}/libva/dri/hybrid_drv_video.so
This page took 0.107673 seconds and 2 git commands to generate.