]> git.pld-linux.org Git - packages/libuv.git/blob - libuv.spec
97dc50d27c5e7941933d5a6a0b5061dbdd3d6932
[packages/libuv.git] / libuv.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_with     tests           # build with tests (require network access)
5
6 Summary:        Platform layer for node.js
7 Summary(pl.UTF-8):      Zależna od platformy warstwa node.js
8 Name:           libuv
9 Version:        1.8.0
10 Release:        1
11 # the licensing breakdown is described in detail in the LICENSE file
12 License:        MIT and BSD and ISC
13 Group:          Libraries
14 Source0:        http://dist.libuv.org/dist/v%{version}/%{name}-v%{version}.tar.gz
15 # Source0-md5:  f4229c4360625e973ae933cb92e1faf7
16 URL:            http://libuv.org/
17 BuildRequires:  autoconf >= 2.57
18 BuildRequires:  automake >= 1:1.12
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 libuv is a new platform layer for Node. Its purpose is to abstract
25 IOCP on Windows and libev on Unix systems. We intend to eventually
26 contain all platform differences in this library.
27
28 %description -l pl.UTF-8
29 libuv to nowa, zależna od platformy warstwa Node. Celem jest
30 abstrakcja dla IOCP na Windows i libev na systemach uniksowych. W
31 przyszłości ta biblioteka może zawierać wszystkie różnice
32 międzyplatformowe.
33
34 %package devel
35 Summary:        Header files for libuv library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libuv
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Development libraries for libuv.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki libuv.
45
46 %package static
47 Summary:        Static libuv library
48 Summary(pl.UTF-8):      Statyczna biblioteka libuv
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static libuv library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka libuv.
57
58 %prep
59 %setup -q -n %{name}-v%{version}
60
61 # serial-tests is available in v1.12 and newer.
62 echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" > m4/libuv-extra-automake-flags.m4
63
64 %build
65 %{__libtoolize}
66 %{__aclocal} -I m4
67 %{__autoconf}
68 %{__automake}
69 %configure \
70         ac_cv_lib_nsl_gethostbyname=no \
71         --disable-silent-rules \
72         %{!?with_static_libs:--disable-static}
73 %{__make}
74
75 %if %{with tests}
76 ./run-tests
77 ./run-benchmarks
78 %endif
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 # obsoleted by .pc file
86 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libuv.la
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc AUTHORS ChangeLog LICENSE README.md
97 %attr(755,root,root) %{_libdir}/libuv.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libuv.so.1
99
100 %files devel
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/libuv.so
103 %{_pkgconfigdir}/libuv.pc
104 %{_includedir}/uv.h
105 %{_includedir}/uv-errno.h
106 %{_includedir}/uv-linux.h
107 %{_includedir}/uv-threadpool.h
108 %{_includedir}/uv-unix.h
109 %{_includedir}/uv-version.h
110
111 %if %{with static_libs}
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libuv.a
115 %endif
This page took 0.088645 seconds and 2 git commands to generate.