]> git.pld-linux.org Git - packages/libusrp.git/blob - libusrp.spec
1e9c9e8117b4513b51791fe28086d0cadcdfd035
[packages/libusrp.git] / libusrp.spec
1 #
2 # Conditional build:
3 %bcond_with     static_libs     # static library
4 #
5 Summary:        USRP client side C++ interface
6 Summary(pl.UTF-8):      Interfejs C++ strony klienckiej USRP
7 Name:           libusrp
8 Version:        3.4.5
9 Release:        2
10 License:        GPL v3+
11 Group:          Libraries
12 #Source0Download: https://github.com/osmocom/libusrp/releases
13 Source0:        https://github.com/osmocom/libusrp/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  a3b389b83712a9d7b47772674ac8e761
15 URL:            http://git.osmocom.org/libusrp/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  boost-devel >= 1.37
19 BuildRequires:  doxygen
20 BuildRequires:  guile-devel
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:2
23 BuildRequires:  libusb-devel >= 1.0
24 BuildRequires:  pkgconfig
25 BuildRequires:  python-devel
26 BuildRequires:  sdcc >= 3.2.0
27 BuildRequires:  swig-python
28 BuildRequires:  xmlto
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 USRP client side C++ interface.
33
34 %description -l pl.UTF-8
35 Interfejs C++ strony klienckiej USRP.
36
37 %package devel
38 Summary:        Header files for USRP library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki USRP
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       boost-devel >= 1.37
43 Requires:       libstdc++-devel
44 Requires:       libusb-devel >= 1.0
45
46 %description devel
47 Header files for USRP library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki USRP.
51
52 %package static
53 Summary:        Static USRP library
54 Summary(pl.UTF-8):      Statyczna biblioteka USRP
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static USRP library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka USRP.
63
64 %package apidocs
65 Summary:        API documentation for USRP library
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki USRP
67 Group:          Documentation
68 %if "%{_rpmversion}" >= "4.6"
69 BuildArch:      noarch
70 %endif
71
72 %description apidocs
73 API documentation for USRP library.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API biblioteki USRP.
77
78 %prep
79 %setup -q
80
81 echo '%{version}' > .tarball-version
82
83 %build
84 %{__libtoolize}
85 %{__aclocal} -I m4
86 %{__autoconf}
87 %{__automake}
88 %configure \
89         --disable-silent-rules \
90         %{?with_static_libs:--enable-static}
91 # swig based --enable-guile and --enable-python are broken
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 # obsoleted by pkg-config
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libusrp.la
103 # swig build is broken here, packaging is useless
104 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/gnuradio/swig
105 # packaged as %doc
106 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/usrp-
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc README
117 %attr(755,root,root) %{_bindir}/usrp_cal_dc_offset
118 %attr(755,root,root) %{_bindir}/usrper
119 %attr(755,root,root) %{_libdir}/libusrp.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libusrp.so.1
121 %{_datadir}/usrp
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libusrp.so
126 %{_includedir}/usrp
127 %{_pkgconfigdir}/usrp.pc
128
129 %if %{with static_libs}
130 %files static
131 %defattr(644,root,root,755)
132 %{_libdir}/libusrp.a
133 %endif
134
135 %files apidocs
136 %defattr(644,root,root,755)
137 %doc doc/html/*
This page took 0.062371 seconds and 2 git commands to generate.