]> git.pld-linux.org Git - packages/libtorrent.git/blob - libtorrent.spec
- updated to 0.7.0 (added support for UDP trackers)
[packages/libtorrent.git] / libtorrent.spec
1 Summary:        LibTorrent - a BitTorrent library written in C++ for Unix
2 Summary(pl):    LibTorrent - biblioteka BitTorrenta napisana w C++ dla Uniksa
3 Name:           libtorrent
4 Version:        0.7.0
5 Release:        1
6 License:        GPL v2
7 Group:          Libraries
8 Source0:        http://libtorrent.rakshasa.no/downloads/%{name}-%{version}.tar.gz
9 # Source0-md5:  705da68d2163a90e5f73a38417638ef1
10 URL:            http://libtorrent.rakshasa.no/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libsigc++-devel >= 2.0
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool
16 BuildRequires:  openssl-devel >= 0.9.7d
17 BuildRequires:  pkgconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 LibTorrent is a BitTorrent library written in C++ for Unix. It is
22 designed to avoid the redundant buffers and data copying that most
23 (all?) other BitTorrent implementations suffer from. The library is
24 single-threaded and the client handles the select loop.
25
26 %description -l pl
27 LibTorrent to biblioteka BitTorrenta napisana w C++ dla Uniksa. Jest
28 zaprojektowana aby unikn±æ nadmiarowego kopiowania buforów i danych,
29 bêd±cego wad± wiêkszo¶ci (wszystkich?) innych implementacji
30 BitTorrenta. Biblioteka jest jednow±tkowa, klient obs³uguje pêtlê
31 select.
32
33 %package devel
34 Summary:        Development files for libtorrent
35 Summary(pl):    Pliki programistyczne libtorrent
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       libsigc++-devel >= 2.0
39 Requires:       openssl-devel >= 0.9.7d
40
41 %description devel
42 Development files for libtorrent.
43
44 %description devel -l pl
45 Pliki programistyczne libtorrent.
46
47 %package static
48 Summary:        Static libtorrent library
49 Summary(pl):    Statyczna biblioteka libtorrent
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static libtorrent library.
55
56 %description static -l pl
57 Statyczna biblioteka libtorrent.
58
59 %prep
60 %setup -q
61
62 %build
63 %{__libtoolize}
64 %{__aclocal}
65 %{__autoconf}
66 %{__automake}
67 %configure \
68         --%{?debug:en}%{!?debug:dis}able-debug \
69         --enable-static
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS ChangeLog README TODO
87 %attr(755,root,root) %{_libdir}/libtorrent.so.*.*.*
88
89 %files devel
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/libtorrent.so
92 %{_libdir}/libtorrent.la
93 %{_includedir}/torrent
94 %{_pkgconfigdir}/libtorrent.pc
95
96 %files static
97 %defattr(644,root,root,755)
98 %{_libdir}/libtorrent.a
This page took 0.042554 seconds and 4 git commands to generate.