]> git.pld-linux.org Git - packages/libtorrent.git/blob - libtorrent.spec
- updated to 0.13.8
[packages/libtorrent.git] / libtorrent.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  ipv6            # disable IPv6 support
5 #
6 Summary:        LibTorrent - a BitTorrent library written in C++ for Unix
7 Summary(pl.UTF-8):      LibTorrent - biblioteka BitTorrenta napisana w C++ dla Uniksa
8 Name:           libtorrent
9 # keep stable line, see URL below
10 Version:        0.13.8
11 Release:        1
12 Epoch:          1
13 License:        GPL v2+
14 Group:          Libraries
15 Source0:        http://rtorrent.net/downloads/%{name}-%{version}.tar.gz
16 # Source0-md5:  ca02e624fde0d704780085987010f99a
17 Patch0:         %{name}-client_list.patch
18 Patch1:         %{name}-build.patch
19 URL:            https://github.com/rakshasa/rtorrent/wiki
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  cppunit-devel >= 1.9.6
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool >= 2:2
25 BuildRequires:  openssl-devel >= 0.9.7d
26 BuildRequires:  pkgconfig
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 LibTorrent is a BitTorrent library written in C++ for *nix, with a
32 focus on high performance and good code. The library differentiates
33 itself from other implementations by transfering directly from file
34 pages to the network stack. On high-bandwidth connections it is able
35 to seed at 3 times the speed of the official client.
36
37 %description -l pl.UTF-8
38 LibTorrent to biblioteka BitTorrenta napisana w C++ dla Uniksa. Jest
39 zaprojektowana aby uniknąć nadmiarowego kopiowania buforów i danych,
40 będącego wadą większości (wszystkich?) innych implementacji
41 BitTorrenta. Biblioteka jest jednowątkowa, klient obsługuje pętlę
42 select.
43
44 %package devel
45 Summary:        Development files for libtorrent
46 Summary(pl.UTF-8):      Pliki programistyczne libtorrent
47 Group:          Development/Libraries
48 Requires:       %{name} = %{epoch}:%{version}-%{release}
49 Requires:       libstdc++-devel
50 Requires:       openssl-devel >= 0.9.7d
51 Requires:       zlib-devel
52
53 %description devel
54 Development files for libtorrent.
55
56 %description devel -l pl.UTF-8
57 Pliki programistyczne libtorrent.
58
59 %package static
60 Summary:        Static libtorrent library
61 Summary(pl.UTF-8):      Statyczna biblioteka libtorrent
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
64
65 %description static
66 Static libtorrent library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka libtorrent.
70
71 %prep
72 v=%{version}; IFS=.; set -- $v
73 if [ $(($2 % 2)) = 0 ]; then
74         echo "WARNING Version %{version} is probably unstable, check it first!"
75         exit 1
76 fi
77 %setup -q
78 %patch0 -p1
79 %patch1 -p1
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I scripts
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87
88 %configure \
89         --%{?with_ipv6:en}%{!?with_ipv6:dis}able-ipv6 \
90         --%{?debug:en}%{!?debug:dis}able-debug \
91         %{?with_static_libs:--enable-static} \
92 %ifarch i386 i486
93         --disable-instrumentation
94 %endif
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS README
113 %attr(755,root,root) %{_libdir}/libtorrent.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libtorrent.so.21
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libtorrent.so
119 %{_libdir}/libtorrent.la
120 %{_includedir}/torrent
121 %{_pkgconfigdir}/libtorrent.pc
122
123 %if %{with static_libs}
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libtorrent.a
127 %endif
This page took 0.119258 seconds and 3 git commands to generate.