]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blob - libtorrent-rasterbar.spec
- TODO
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
1 #
2 # TODO: make it builds on 64 bits
3 #
4 Summary:        A C++ BitTorrent library
5 Summary(hu.UTF-8):      C++ BitTorrent könyvtár
6 Summary(pl.UTF-8):      Biblioteka BitTorrenta napisana w C++
7 Name:           libtorrent-rasterbar
8 Version:        0.14.8
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://libtorrent.googlecode.com/files/%{name}-%{version}.tar.gz
13 # Source0-md5:  3fae9934b74e2ddf2c50c1f0ec320d75
14 URL:            http://www.rasterbar.com/products/libtorrent/
15 Patch0:         bashizm.patch
16 BuildRequires:  GeoIP-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  boost-devel >= 1.35.0
20 BuildRequires:  boost-python-devel
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool
23 BuildRequires:  openssl-devel
24 BuildRequires:  pkgconfig >= 1:0.20
25 BuildRequires:  python-devel
26 BuildRequires:  python-modules
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  util-linux-ng
30 BuildRequires:  which
31 BuildRequires:  zlib-devel
32 Obsoletes:      rb_libtorrent
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 libtorrent-rasterbar is a C++ library that aims to be a good
37 alternative to all the other BitTorrent implementations around. It is
38 a library and not a full featured client, although it comes with a
39 working example client.
40
41 Its main goals are to be very efficient (in terms of CPU and memory
42 usage) as well as being very easy to use both as a user and developer.
43
44 %description -l hu.UTF-8
45 libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
46 kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
47 egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
48 működő példa-klienst.
49
50 A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
51 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
52
53 %description -l pl.UTF-8
54 libtorrent-rasterbar jest napisaną w C++ biblioteką, która aspiruje do
55 bycia dobrą alternatywą dla wszystkich innych implementacji
56 BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, aczkolwiek
57 pakiet zawiera działającego przykładowego klienta.
58
59 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
60 wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
61 dla użytkownika, jak i programisty.
62
63 %package devel
64 Summary:        Header files for %{name} library
65 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
66 License:        BSD, zlib/libpng License, Boost Software License
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       boost-devel
70 Requires:       openssl-devel
71 Obsoletes:      rb_libtorrent-devel
72
73 %description    devel
74 The libtorrent-rasterbar-devel package contains libraries and header
75 files for developing applications that use libtorrent-rasterbar.
76
77 The various source and header files included in this package are
78 licensed under the revised BSD, zlib/libpng, and Boost Public
79 licenses.
80
81 %description devel -l hu.UTF-8
82 A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
83 fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
84 alkalmazásokat fejleszthetsz.
85
86 %description devel -l pl.UTF-8
87 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
88 rozwijania aplikacji używających libtorrent-rasterbar.
89
90 Różne pliki źródłowe i nagłówki dostarczone z tym pakietem są
91 licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public
92 License.
93
94 %package static
95 Summary:        Static %{name} library
96 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99 Obsoletes:      rb_libtorrent-static
100
101 %description static
102 Static libtorrent-rasterbar library.
103
104 %description static -l hu.UTF-8
105 Statikus libtorrent-rasterbar könyvtár.
106
107 %description static -l pl.UTF-8
108 Statyczna biblioteka libtorrent-rasterbar.
109
110 %package -n python-libtorrent-rasterbar
111 Summary:        Python bindings for libtorrent-rasterbar
112 Group:          Libraries/Python
113 Requires:       %{name} = %{version}-%{release}
114
115 %description -n python-libtorrent-rasterbar
116 Python bindings for libtorrent-rasterbar.
117
118 %prep
119 %setup -q
120 %patch0 -p1
121 %{__sed} -i 's/ACLOCAL_AMFLAGS = -I m4/#ACLOCAL_AMFLAGS = -I m4/' Makefile.am
122
123 ## Some of the sources and docs are executable, which makes rpmlint against
124 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
125 find src docs -type f | xargs chmod a-x
126 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
127 ## The RST files are the sources used to create the final HTML files; and are
128 ## not needed.
129 rm -f docs/*.rst
130
131 %build
132 %{__libtoolize}
133 %{__aclocal} -I m4
134 %{__autoconf}
135 %{__automake}
136 %configure \
137         LIBS="-lpthread -lrt" \
138         --enable-python-binding \
139         --with-boost-system=boost_system \
140         --with-boost-filesystem=boost_filesystem \
141         --with-boost-thread=boost_thread \
142         --with-boost-regex=boost_regex \
143         --with-boost-program-options=boost_program_options \
144         --with-asio=system \
145         --with-zlib=system \
146         --with-libgeoip=system \
147         --with-ssl
148
149 %{__make}
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153 ## Ensure that we preserve our timestamps properly.
154 #export CPPROG="%{__cp} -p"
155 #make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
156 %{__make} install \
157         DESTDIR=$RPM_BUILD_ROOT
158
159 ## Do the renaming due to the somewhat limited %{_bindir} namespace.
160 rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %post   -p /sbin/ldconfig
166 %postun -p /sbin/ldconfig
167
168 %files
169 %defattr(644,root,root,755)
170 %doc AUTHORS ChangeLog COPYING README
171 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
172
173 %files devel
174 %defattr(644,root,root,755)
175 %doc docs/
176 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
177 %{_libdir}/libtorrent-rasterbar.la
178 %{_pkgconfigdir}/libtorrent-rasterbar.pc
179 %{_includedir}/libtorrent
180
181 %files static
182 %defattr(644,root,root,755)
183 %{_libdir}/libtorrent-rasterbar.a
184
185 %files -n python-libtorrent-rasterbar
186 %defattr(644,root,root,755)
187 %{py_sitedir}/libtorrent.so
188 %{py_sitedir}/python_libtorrent-*.egg-info
This page took 0.413198 seconds and 3 git commands to generate.