]> git.pld-linux.org Git - packages/libtiger.git/blob - libtiger.spec
- fix linking with libm
[packages/libtiger.git] / libtiger.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 #
5 Summary:        Rendering library for Kate text streams using Pango and Cairo
6 Summary(pl.UTF-8):      Biblioteka renderująca strumienie tekstowe Kate przy użyciu Pango i Cairo
7 Name:           libtiger
8 Version:        0.3.4
9 Release:        13
10 License:        LGPL v2.1+
11 Group:          Libraries
12 #Source0Download: http://code.google.com/p/libtiger/downloads/list
13 Source0:        http://libtiger.googlecode.com/files/%{name}-%{version}.tar.gz
14 # Source0-md5:  dc1dbeb658c95485ba10b9b2897b4ae2
15 Patch0:         libm.patch
16 URL:            http://code.google.com/p/libtiger/
17 BuildRequires:  doxygen
18 BuildRequires:  libkate-devel >= 0.2.0
19 BuildRequires:  pango-devel >= 1:1.16
20 BuildRequires:  pkgconfig
21 Requires:       libkate >= 0.2.0
22 Requires:       pango >= 1:1.16
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This is libtiger, a rendering library for Kate streams using Pango and
27 Cairo.
28
29 %description -l pl.UTF-8
30 libtiger to biblioteka renderująca dla strumieni Kate, korzystająca z
31 bibliotek Pango i Cairo.
32
33 %package devel
34 Summary:        Header files for libtiger library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libtiger
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       libkate-devel >= 0.2.0
39 Requires:       pango-devel >= 1:1.16
40
41 %description devel
42 This package contains the header files for developing applications
43 that use libtiger library.
44
45 %description devel -l pl.UTF-8
46 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
47 wykorzystujących bibliotekę libtiger.
48
49 %package static
50 Summary:        Static libtiger library
51 Summary(pl.UTF-8):      Statyczna biblioteka libtiger
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static libtiger library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka libtiger.
60
61 %prep
62 %setup -q
63 %patch0 -p1
64
65 %build
66 %{__libtoolize}
67 %{__aclocal}
68 %{__autoconf}
69 %{__autoheader}
70 %{__automake}
71 %configure
72
73 %{__make}
74
75 %{?with_tests:%{__make} check}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
84 cp -a examples/src/*.[ch] $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
85
86 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libtiger
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc AUTHORS ChangeLog README THANKS
97 %attr(755,root,root) %{_libdir}/libtiger.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libtiger.so.5
99
100 %files devel
101 %defattr(644,root,root,755)
102 %doc doc/html/*
103 %attr(755,root,root) %{_libdir}/libtiger.so
104 %{_libdir}/libtiger.la
105 %{_includedir}/tiger
106 %{_pkgconfigdir}/tiger.pc
107 %{_examplesdir}/%{name}-%{version}
108
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libtiger.a
This page took 0.082502 seconds and 3 git commands to generate.