]> git.pld-linux.org Git - packages/libtiff.git/blob - libtiff.spec
- updated to 4.3.0, adds support for LERC compression
[packages/libtiff.git] / libtiff.spec
1 #
2 # Conditional build:
3 %bcond_without  opengl          # OpenGL viewer
4 %bcond_without  libdeflate      # libdeflate for faster Deflate support
5 %bcond_with     jpeg12          # dual 8/12-bit libjpeg mode
6 #
7 Summary:        Library for handling TIFF files
8 Summary(de.UTF-8):      Library zum Verwalten von TIFF-Dateien
9 Summary(fr.UTF-8):      Bibliothèque de gestion des fichiers TIFF
10 Summary(pl.UTF-8):      Biblioteka do manipulacji plikami w formacie TIFF
11 Summary(tr.UTF-8):      TIFF dosyalarını işleme kitaplığı
12 Name:           libtiff
13 Version:        4.3.0
14 Release:        1
15 License:        BSD-like
16 Group:          Libraries
17 Source0:        http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
18 # Source0-md5:  0a2e4744d1426a8fc8211c0cdbc3a1b3
19 Patch0:         %{name}-glut.patch
20 URL:            http://www.simplesystems.org/libtiff/
21 %{?with_opengl:BuildRequires:  OpenGL-glut-devel}
22 BuildRequires:  autoconf >= 2.64
23 BuildRequires:  automake >= 1:1.11
24 BuildRequires:  jbigkit-devel
25 BuildRequires:  lerc-devel
26 %{?with_libdeflate:BuildRequires:       libdeflate-devel}
27 BuildRequires:  libjpeg-devel
28 %{?with_jpeg12:BuildRequires:   libjpeg12-devel}
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtool >= 2:2.2
31 BuildRequires:  libwebp-devel
32 BuildRequires:  rpm-build >= 4.6
33 %{?with_opengl:BuildRequires:   xorg-lib-libX11-devel}
34 BuildRequires:  xz-devel
35 BuildRequires:  zlib-devel
36 BuildRequires:  zstd-devel >= 1.0.0
37 Requires:       zstd >= 1.0.0
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 This package is a library of functions that manipulate TIFF images.
42
43 %description -l de.UTF-8
44 Eine Library von Funktionen zur Manipulation von TIFFs.
45
46 %description -l fr.UTF-8
47 Bibliothèque de fonctions pour manipuler des images TIFF.
48
49 %description -l pl.UTF-8
50 Ten pakiet zawiera bibliotekę pozwalającą manipulować plikami w
51 formacie TIFF.
52
53 %description -l tr.UTF-8
54 Bu paket TIFF resimlerini işleyen fonksiyonlardan oluşan bir
55 kitaplıktır.
56
57 %package devel
58 Summary:        Header files for developing programs using libtiff
59 Summary(de.UTF-8):      Header zur Entwicklung von Programmen unter Verwendung von libtiff
60 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki libtiff
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       jbigkit-devel
64 Requires:       lerc-devel
65 %{?with_libdeflate:Requires:    libdeflate-devel}
66 Requires:       libjpeg-devel
67 %{?with_jpeg12:Requires:        libjpeg12-devel}
68 Requires:       libwebp-devel
69 Requires:       xz-devel
70 Requires:       zlib-devel
71 Requires:       zstd-devel >= 1.0.0
72
73 %description devel
74 This package is all you need to develop programs that manipulate tiff
75 images.
76
77 %description devel -l de.UTF-8
78 Dieses Paket enthält alles, was Sie zum Entwickeln von Programmen zum
79 Bearbeiten von tiff-Bildern benötigen.
80
81 %description devel -l fr.UTF-8
82 Ce package contient tout le nécessaire pour réaliser des programmes
83 manipulant des images au format tiff.
84
85 %description devel -l pl.UTF-8
86 Pakiet ten zawiera wszystko co potrzebujesz przy pisaniu programów
87 operujących na formacie tiff.
88
89 %description devel -l tr.UTF-8
90 tiff resimlerini işleyen programlar yazmak için gerekli dosyalar bu
91 pakette yer alır.
92
93 %package static
94 Summary:        Static version libtiff library
95 Summary(pl.UTF-8):      Biblioteka statyczna libtiff
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 Static libtiff library.
101
102 %description static -l pl.UTF-8
103 Statyczna biblioteka libtiff.
104
105 %package cxx
106 Summary:        libtiff C++ streams library
107 Summary(pl.UTF-8):      Biblioteka strumieni C++ dla libtiff
108 Group:          Libraries
109 Requires:       %{name} = %{version}-%{release}
110
111 %description cxx
112 libtiff C++ streams library.
113
114 %description cxx -l pl.UTF-8
115 Biblioteka strumieni C++ dla libtiff.
116
117 %package cxx-devel
118 Summary:        libtiff C++ streams API
119 Summary(pl.UTF-8):      API strumieni C++ dla libtiff
120 Group:          Development/Libraries
121 Requires:       %{name}-cxx = %{version}-%{release}
122 Requires:       %{name}-devel = %{version}-%{release}
123 Requires:       libstdc++-devel
124
125 %description cxx-devel
126 libtiff C++ streams API.
127
128 %description cxx-devel -l pl.UTF-8
129 API strumieni C++ dla libtiff.
130
131 %package cxx-static
132 Summary:        libtiff C++ streams static library
133 Summary(pl.UTF-8):      Statyczna biblioteka strumieni C++ dla libtiff
134 Group:          Development/Libraries
135 Requires:       %{name}-cxx-devel = %{version}-%{release}
136
137 %description cxx-static
138 libtiff C++ streams static library.
139
140 %description cxx-static -l pl.UTF-8
141 Statyczna biblioteka strumieni C++ dla libtiff.
142
143 %package progs
144 Summary:        Simple clients for manipulating tiff images
145 Summary(de.UTF-8):      Einfachen Clients zur Manipulation von tiff
146 Summary(fr.UTF-8):      Clients simples pour manipuler de telles images
147 Summary(pl.UTF-8):      Kilka prostych programów do manipulowania na plikach tiff
148 Group:          Applications/Graphics
149 Requires:       %{name} = %{version}-%{release}
150
151 %description progs
152 Simple clients for manipulating tiff images.
153
154 %description progs -l de.UTF-8
155 Einfachen Clients zur Manipulation von tiff.
156
157 %description progs -l fr.UTF-8
158 Clients simples pour manipuler de telles images.
159
160 %description progs -l pl.UTF-8
161 Kilka prostych programów do manipulowania na plikach tiff.
162
163 %package progs-gl
164 Summary:        tiffgt - OpenGL-based tiff viewer
165 Summary(pl.UTF-8):      tiffgt - program do oglądania plików tiff oparty o OpenGL
166 Group:          Applications/Graphics
167 Requires:       %{name} = %{version}-%{release}
168
169 %description progs-gl
170 tiffgt - OpenGL-based tiff viewer.
171
172 %description progs-gl -l pl.UTF-8
173 tiffgt - program do oglądania plików tiff oparty o OpenGL.
174
175 %package doc
176 Summary:        HTML documentation for tiff library and tools
177 Summary(pl.UTF-8):      Dokumentacja w formacie HTML do biblioteki i narzędzi tiff
178 Group:          Documentation
179 BuildArch:      noarch
180
181 %description doc
182 HTML documentation for tiff library and tools.
183
184 %description doc -l pl.UTF-8
185 Dokumentacja w formacie HTML do biblioteki i narzędzi tiff.
186
187 %prep
188 %setup -q -n tiff-%{version}
189 %patch0 -p1
190
191 %build
192 %{__libtoolize}
193 %{__aclocal} -I m4
194 %{__autoconf}
195 %{__autoheader}
196 %{__automake}
197 %configure \
198         %{?with_jpeg12:--enable-jpeg12 --with-jpeg12-include-dir=%{_includedir}/libjpeg12 --with-jpeg12-lib=-ljpeg12} \
199         %{!?with_libdeflate:--disable-libdeflate} \
200         --with-docdir=%{_docdir}/tiff \
201         %{!?with_opengl:--without-x}
202
203 %{__make}
204
205 %install
206 rm -rf $RPM_BUILD_ROOT
207
208 %{__make} install \
209         DESTDIR=$RPM_BUILD_ROOT
210
211 # libtiff*.la kept - no .pc file for libtiffxx
212
213 %clean
214 rm -rf $RPM_BUILD_ROOT
215
216 %post   -p /sbin/ldconfig
217 %postun -p /sbin/ldconfig
218
219 %files
220 %defattr(644,root,root,755)
221 %doc COPYRIGHT ChangeLog README.md TODO
222 %attr(755,root,root) %{_libdir}/libtiff.so.*.*.*
223 %attr(755,root,root) %ghost %{_libdir}/libtiff.so.5
224
225 %files devel
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_libdir}/libtiff.so
228 %{_libdir}/libtiff.la
229 %{_includedir}/tiff*.h
230 %{_pkgconfigdir}/libtiff-4.pc
231 %{_mandir}/man3/TIFF*.3tiff*
232 %{_mandir}/man3/libtiff.3tiff*
233
234 %files static
235 %defattr(644,root,root,755)
236 %{_libdir}/libtiff.a
237
238 %files cxx
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{_libdir}/libtiffxx.so.*.*.*
241 %attr(755,root,root) %ghost %{_libdir}/libtiffxx.so.5
242
243 %files cxx-devel
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_libdir}/libtiffxx.so
246 %{_libdir}/libtiffxx.la
247 %{_includedir}/tiffio.hxx
248
249 %files cxx-static
250 %defattr(644,root,root,755)
251 %{_libdir}/libtiffxx.a
252
253 %files progs
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{_bindir}/fax2ps
256 %attr(755,root,root) %{_bindir}/fax2tiff
257 %attr(755,root,root) %{_bindir}/pal2rgb
258 %attr(755,root,root) %{_bindir}/ppm2tiff
259 %attr(755,root,root) %{_bindir}/raw2tiff
260 %attr(755,root,root) %{_bindir}/tiff[!g]*
261 %{_mandir}/man1/fax2ps.1*
262 %{_mandir}/man1/fax2tiff.1*
263 %{_mandir}/man1/pal2rgb.1*
264 %{_mandir}/man1/ppm2tiff.1*
265 %{_mandir}/man1/raw2tiff.1*
266 %{_mandir}/man1/tiff[!g]*.1*
267
268 %if %{with opengl}
269 %files progs-gl
270 %defattr(644,root,root,755)
271 %attr(755,root,root) %{_bindir}/tiffgt
272 %{_mandir}/man1/tiffgt.1*
273 %endif
274
275 %files doc
276 %defattr(644,root,root,755)
277 %{_docdir}/tiff
This page took 0.052293 seconds and 3 git commands to generate.