]> git.pld-linux.org Git - packages/libteam.git/blob - libteam.spec
2535ea8055fa127e6fe513a49e82ff5c0e8a6f17
[packages/libteam.git] / libteam.spec
1 Summary:        Library for controlling team network device
2 Summary(pl.UTF-8):      Biblioteka do sterowania grupowymi urządzeniami sieciowymi
3 Name:           libteam
4 #%define     _snap   20160809
5 Version:        1.26
6 Release:        1
7 License:        LGPL v2.1+
8 Group:          Libraries
9 Source0:        http://libteam.org/files/%{name}-%{version}.tar.gz
10 # Source0-md5:  f8529a3bfee28500bef5faff6aeb0063
11 #Source0:       %{name}-%{_snap}.zip
12 Source1:    teamd.sysconfig
13 Source2:    teamd-lvl1-service-generator
14 Source3:    teamd-lvl2-service-generator
15 Source4:    teamd@.service
16 Source5:    teamd-lvl1.target
17 Source6:    teamd-lvl2.target
18 # You might not be able to shut down your system without this:
19 # https://lists.fedorahosted.org/archives/list/libteam@lists.fedorahosted.org/thread/QYCLFVANHB47URKOST5HFT5EVWPRHGVQ/
20 Source7:    teamd-shutdown-workaround.service
21 Patch0:         %{name}-link.patch
22 URL:            http://libteam.org/
23 BuildRequires:  autoconf >= 2.50
24 BuildRequires:  automake
25 BuildRequires:  dbus-devel
26 BuildRequires:  jansson-devel
27 # if non-root --with-group or --with-user
28 #BuildRequires: libcap-devel
29 BuildRequires:  libdaemon-devel
30 BuildRequires:  libnl-devel >= 3.2
31 BuildRequires:  libtool >= 2:2
32 BuildRequires:  pkgconfig
33 BuildRequires:  zeromq-devel >= 3.2.0
34 Requires:       libnl >= 3.2
35 Requires:       zeromq >= 3.2.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 The purpose of the Team driver is to provide a mechanism to team
40 multiple NICs (ports) into one logical one (teamdev) at L2 layer. The
41 process is called "channel bonding", "Ethernet bonding", "channel
42 teaming", "link aggregation", etc. This is already implemented in the
43 Linux kernel by the bonding driver.
44
45 One thing to note is that Team driver project does try to provide the
46 similar functionality as the bonding driver, however architecturally
47 it is quite different from bonding driver. Team driver is modular,
48 userspace driven, very lean and efficient, and it does have some
49 distinct advantages over bonding. The way Team is configured differs
50 dramatically from the way bonding is.
51
52 %description -l pl.UTF-8
53 Celem sterownika Team jest dostarczenie mechanizmu do grupowania
54 (team) wielu interfejsów (portów) sieciowych (czyli NIC) w jeden
55 logiczny (teamdev) w warstwie L2. Proces ten jest nazywany
56 "channel bonding", "Ethernet bonding", "channel teaming", "link
57 aggregation" itp. Jest to już zaimplementowane w jądrze Linuksa
58 poprzez sterownik bonding.
59
60 Należy zauważyć, że projekt sterownika Team próbuje zapewnić
61 podobną funkcjonalność co sterownik bonding, ale architektonicznie
62 różni się od niego. Jest modularny, działa w przestrzeni użytkownika,
63 jest bardzo lekki i wydajny, ma też kilka zalet, których nie ma
64 bonding. Sposób konfiguracji sterownika Team znacząco różni się od
65 konfiguracji sterownika bonding.
66
67 %package devel
68 Summary:        Header files for libteam library
69 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libteam
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       libnl-devel >= 3.2
73
74 %description devel
75 Header files for libteam library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki libteam.
79
80 %package static
81 Summary:        Static libteam library
82 Summary(pl.UTF-8):      Statyczna biblioteka libteam
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static libteam library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka libteam.
91
92 %package -n teamd
93 Group:      Networking/Admin
94 Summary:    Team network device control daemon
95 Requires:   libteam = %{version}-%{release}
96
97 %description -n teamd
98 The teamd package contains team network device control daemon.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103
104 %build
105 %{__libtoolize}
106 %{__aclocal} -I m4
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         --disable-silent-rules
112
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT/etc/dbus-1/system.d \
118            $RPM_BUILD_ROOT/etc/sysconfig \
119            $RPM_BUILD_ROOT/lib/systemd/{system-generators,system}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 install teamd/dbus/teamd.conf $RPM_BUILD_ROOT/etc/dbus-1/system.d
125 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/teamd
126 install %{SOURCE2} $RPM_BUILD_ROOT/lib/systemd/system-generators
127 install %{SOURCE3} $RPM_BUILD_ROOT/lib/systemd/system-generators
128 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}
129 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}
130 install %{SOURCE6} $RPM_BUILD_ROOT%{systemdunitdir}
131 install %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}
132
133 # obsoleted by pkg-config
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post -p /sbin/ldconfig
140
141 %postun -p /sbin/ldconfig
142
143 %post -n teamd
144 export NORESTART="yes"
145 %systemd_post teamd-lvl1.target teamd-lvl2.target
146
147 %preun -n teamd
148 %systemd_preun teamd-lvl1.target teamd-lvl2.target
149
150 %postun -n teamd
151 %systemd_reload
152
153 %files -n teamd
154 %defattr(644,root,root,755)
155 %doc README teamd/example_configs
156 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/teamd
157 /etc/dbus-1/system.d/teamd.conf
158 %{systemdunitdir}/teamd@.service
159 %{systemdunitdir}/teamd-lvl?.target
160 %{systemdunitdir}/teamd-shutdown-workaround.service
161 %attr(755,root,root) %{_bindir}/bond2team
162 %attr(755,root,root) %{_bindir}/teamd
163 %attr(755,root,root) %{_bindir}/teamdctl
164 %attr(755,root,root) %{_libdir}/libteamdctl.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libteamdctl.so.0
166 %attr(755,root,root) /lib/systemd/system-generators/teamd-lvl?-service-generator
167 %{_mandir}/man1/bond2team.1*
168 %{_mandir}/man5/teamd.conf.5*
169 %{_mandir}/man8/teamd.8*
170 %{_mandir}/man8/teamdctl.8*
171
172 %files
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/teamnl
175 %attr(755,root,root) %{_libdir}/libteam.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libteam.so.5
177 %{_mandir}/man8/teamnl.8*
178
179 %files devel
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libteam.so
182 %attr(755,root,root) %{_libdir}/libteamdctl.so
183 %{_includedir}/team.h
184 %{_includedir}/teamdctl.h
185 %{_pkgconfigdir}/libteam.pc
186 %{_pkgconfigdir}/libteamdctl.pc
187
188 %files static
189 %defattr(644,root,root,755)
190 %{_libdir}/libteam.a
191 %{_libdir}/libteamdctl.a
This page took 0.055558 seconds and 2 git commands to generate.