]> git.pld-linux.org Git - packages/libteam.git/blob - libteam.spec
cleanups
[packages/libteam.git] / libteam.spec
1 Summary:        Library for controlling team network device
2 Summary(pl.UTF-8):      Biblioteka do sterowania grupowymi urządzeniami sieciowymi
3 Name:           libteam
4 Version:        1.26
5 Release:        2
6 License:        LGPL v2.1+
7 Group:          Libraries
8 Source0:        http://libteam.org/files/%{name}-%{version}.tar.gz
9 # Source0-md5:  f8529a3bfee28500bef5faff6aeb0063
10 Source1:    teamd.sysconfig
11 Source2:    teamd-lvl1-service-generator
12 Source3:    teamd-lvl2-service-generator
13 Source4:    teamd@.service
14 Source5:    teamd-lvl1.target
15 Source6:    teamd-lvl2.target
16 # You might not be able to shut down your system without this:
17 # https://lists.fedorahosted.org/archives/list/libteam@lists.fedorahosted.org/thread/QYCLFVANHB47URKOST5HFT5EVWPRHGVQ/
18 Source7:    teamd-shutdown-workaround.service
19 Patch0:         %{name}-link.patch
20 URL:            http://libteam.org/
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  dbus-devel
24 BuildRequires:  jansson-devel
25 # if non-root --with-group or --with-user
26 #BuildRequires: libcap-devel
27 BuildRequires:  libdaemon-devel
28 BuildRequires:  libnl-devel >= 3.2
29 BuildRequires:  libtool >= 2:2
30 BuildRequires:  pkgconfig
31 BuildRequires:  zeromq-devel >= 3.2.0
32 Requires:       libnl >= 3.2
33 Requires:       zeromq >= 3.2.0
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 The purpose of the Team driver is to provide a mechanism to team
38 multiple NICs (ports) into one logical one (teamdev) at L2 layer. The
39 process is called "channel bonding", "Ethernet bonding", "channel
40 teaming", "link aggregation", etc. This is already implemented in the
41 Linux kernel by the bonding driver.
42
43 One thing to note is that Team driver project does try to provide the
44 similar functionality as the bonding driver, however architecturally
45 it is quite different from bonding driver. Team driver is modular,
46 userspace driven, very lean and efficient, and it does have some
47 distinct advantages over bonding. The way Team is configured differs
48 dramatically from the way bonding is.
49
50 %description -l pl.UTF-8
51 Celem sterownika Team jest dostarczenie mechanizmu do grupowania
52 (team) wielu interfejsów (portów) sieciowych (czyli NIC) w jeden
53 logiczny (teamdev) w warstwie L2. Proces ten jest nazywany
54 "channel bonding", "Ethernet bonding", "channel teaming", "link
55 aggregation" itp. Jest to już zaimplementowane w jądrze Linuksa
56 poprzez sterownik bonding.
57
58 Należy zauważyć, że projekt sterownika Team próbuje zapewnić
59 podobną funkcjonalność co sterownik bonding, ale architektonicznie
60 różni się od niego. Jest modularny, działa w przestrzeni użytkownika,
61 jest bardzo lekki i wydajny, ma też kilka zalet, których nie ma
62 bonding. Sposób konfiguracji sterownika Team znacząco różni się od
63 konfiguracji sterownika bonding.
64
65 %package devel
66 Summary:        Header files for libteam library
67 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libteam
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       libnl-devel >= 3.2
71
72 %description devel
73 Header files for libteam library.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe biblioteki libteam.
77
78 %package static
79 Summary:        Static libteam library
80 Summary(pl.UTF-8):      Statyczna biblioteka libteam
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description static
85 Static libteam library.
86
87 %description static -l pl.UTF-8
88 Statyczna biblioteka libteam.
89
90 %package -n teamd
91 Group:      Networking/Admin
92 Summary:    Team network device control daemon
93 Requires:   %{name} = %{version}-%{release}
94
95 %description -n teamd
96 The teamd package contains team network device control daemon.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101
102 %build
103 %{__libtoolize}
104 %{__aclocal} -I m4
105 %{__autoconf}
106 %{__autoheader}
107 %{__automake}
108 %configure \
109         --disable-silent-rules
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT/etc/dbus-1/system.d \
116            $RPM_BUILD_ROOT/etc/sysconfig \
117            $RPM_BUILD_ROOT/lib/systemd/{system-generators,system}
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 install teamd/dbus/teamd.conf $RPM_BUILD_ROOT/etc/dbus-1/system.d
123 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/teamd
124 install %{SOURCE2} $RPM_BUILD_ROOT/lib/systemd/system-generators
125 install %{SOURCE3} $RPM_BUILD_ROOT/lib/systemd/system-generators
126 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}
127 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}
128 install %{SOURCE6} $RPM_BUILD_ROOT%{systemdunitdir}
129 install %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}
130
131 # obsoleted by pkg-config
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %post -n teamd
141 /sbin/ldconfig
142 export NORESTART="yes"
143 %systemd_post teamd-lvl1.target teamd-lvl2.target
144
145 %preun -n teamd
146 %systemd_preun teamd-lvl1.target teamd-lvl2.target
147
148 %postun -n teamd
149 /sbin/ldconfig
150 %systemd_reload
151
152 %files
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/teamnl
155 %attr(755,root,root) %{_libdir}/libteam.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libteam.so.5
157 %{_mandir}/man8/teamnl.8*
158
159 %files -n teamd
160 %defattr(644,root,root,755)
161 %doc README teamd/example_configs
162 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/teamd
163 /etc/dbus-1/system.d/teamd.conf
164 %{systemdunitdir}/teamd@.service
165 %{systemdunitdir}/teamd-lvl?.target
166 %{systemdunitdir}/teamd-shutdown-workaround.service
167 %attr(755,root,root) %{_bindir}/bond2team
168 %attr(755,root,root) %{_bindir}/teamd
169 %attr(755,root,root) %{_bindir}/teamdctl
170 %attr(755,root,root) %{_libdir}/libteamdctl.so.*.*.*
171 %attr(755,root,root) %ghost %{_libdir}/libteamdctl.so.0
172 %attr(755,root,root) /lib/systemd/system-generators/teamd-lvl?-service-generator
173 %{_mandir}/man1/bond2team.1*
174 %{_mandir}/man5/teamd.conf.5*
175 %{_mandir}/man8/teamd.8*
176 %{_mandir}/man8/teamdctl.8*
177
178 %files devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/libteam.so
181 %attr(755,root,root) %{_libdir}/libteamdctl.so
182 %{_includedir}/team.h
183 %{_includedir}/teamdctl.h
184 %{_pkgconfigdir}/libteam.pc
185 %{_pkgconfigdir}/libteamdctl.pc
186
187 %files static
188 %defattr(644,root,root,755)
189 %{_libdir}/libteam.a
190 %{_libdir}/libteamdctl.a
This page took 0.10367 seconds and 3 git commands to generate.