]> git.pld-linux.org Git - packages/libteam.git/blob - libteam.spec
Up to 1.26, rel 0.1
[packages/libteam.git] / libteam.spec
1 Summary:        Library for controlling team network device
2 Summary(pl.UTF-8):      Biblioteka do sterowania grupowymi urządzeniami sieciowymi
3 Name:           libteam
4 #%define     _snap   20160809
5 Version:        1.26
6 Release:        0.1
7 License:        LGPL v2.1+
8 Group:          Libraries
9 Source0:        http://libteam.org/files/%{name}-%{version}.tar.gz
10 # Source0-md5:  f8529a3bfee28500bef5faff6aeb0063
11 #Source0:       %{name}-%{_snap}.zip
12 Source1:    teamd.sysconfig
13 Source2:    teamd-lvl1-service-generator
14 Source3:    teamd-lvl2-service-generator
15 Source4:    teamd@.service
16 Source5:    teamd-lvl1.target
17 Source6:    teamd-lvl2.target
18 # You might not be able to shut down your system without this:
19 # https://lists.fedorahosted.org/archives/list/libteam@lists.fedorahosted.org/thread/QYCLFVANHB47URKOST5HFT5EVWPRHGVQ/
20 Source7:    teamd-shutdown-workaround.service
21 Patch0:         %{name}-link.patch
22 URL:            http://libteam.org/
23 BuildRequires:  autoconf >= 2.50
24 BuildRequires:  automake
25 BuildRequires:  dbus-devel
26 BuildRequires:  jansson-devel
27 # if non-root --with-group or --with-user
28 #BuildRequires: libcap-devel
29 BuildRequires:  libdaemon-devel
30 BuildRequires:  libnl-devel >= 3.2
31 BuildRequires:  libtool >= 2:2
32 BuildRequires:  pkgconfig
33 BuildRequires:  zeromq-devel >= 3.2.0
34 Requires:       libnl >= 3.2
35 Requires:       zeromq >= 3.2.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 The purpose of the Team driver is to provide a mechanism to team
40 multiple NICs (ports) into one logical one (teamdev) at L2 layer. The
41 process is called "channel bonding", "Ethernet bonding", "channel
42 teaming", "link aggregation", etc. This is already implemented in the
43 Linux kernel by the bonding driver.
44
45 One thing to note is that Team driver project does try to provide the
46 similar functionality as the bonding driver, however architecturally
47 it is quite different from bonding driver. Team driver is modular,
48 userspace driven, very lean and efficient, and it does have some
49 distinct advantages over bonding. The way Team is configured differs
50 dramatically from the way bonding is.
51
52 %description -l pl.UTF-8
53 Celem sterownika Team jest dostarczenie mechanizmu do grupowania
54 (team) wielu interfejsów (portów) sieciowych (czyli NIC) w jeden
55 logiczny (teamdev) w warstwie L2. Proces ten jest nazywany
56 "channel bonding", "Ethernet bonding", "channel teaming", "link
57 aggregation" itp. Jest to już zaimplementowane w jądrze Linuksa
58 poprzez sterownik bonding.
59
60 Należy zauważyć, że projekt sterownika Team próbuje zapewnić
61 podobną funkcjonalność co sterownik bonding, ale architektonicznie
62 różni się od niego. Jest modularny, działa w przestrzeni użytkownika,
63 jest bardzo lekki i wydajny, ma też kilka zalet, których nie ma
64 bonding. Sposób konfiguracji sterownika Team znacząco różni się od
65 konfiguracji sterownika bonding.
66
67 %package devel
68 Summary:        Header files for libteam library
69 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libteam
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       libnl-devel >= 3.2
73
74 %description devel
75 Header files for libteam library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki libteam.
79
80 %package static
81 Summary:        Static libteam library
82 Summary(pl.UTF-8):      Statyczna biblioteka libteam
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static libteam library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka libteam.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95
96 %build
97 %{__libtoolize}
98 %{__aclocal} -I m4
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure \
103         --disable-silent-rules
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT/etc/dbus-1/system.d \
110            $RPM_BUILD_ROOT/etc/sysconfig \
111            $RPM_BUILD_ROOT/lib/systemd/{system-generators,system}
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 install teamd/dbus/teamd.conf $RPM_BUILD_ROOT/etc/dbus-1/system.d
117 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/teamd
118 install %{SOURCE2} $RPM_BUILD_ROOT/lib/systemd/system-generators
119 install %{SOURCE3} $RPM_BUILD_ROOT/lib/systemd/system-generators
120 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}
121 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}
122 install %{SOURCE6} $RPM_BUILD_ROOT%{systemdunitdir}
123 install %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}
124
125 # obsoleted by pkg-config
126 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post
132 /sbin/ldconfig
133 export NORESTART="yes"
134 %systemd_post teamd-lvl1.target teamd-lvl2.target
135
136 %preun
137 %systemd_preun teamd-lvl1.target teamd-lvl2.target
138
139 %postun
140 /sbin/ldconfig
141 %systemd_reload
142
143 %files
144 %defattr(644,root,root,755)
145 %doc README teamd/example_configs
146 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/teamd
147 /etc/dbus-1/system.d/teamd.conf
148 %{systemdunitdir}/teamd@.service
149 %{systemdunitdir}/teamd-lvl?.target
150 %{systemdunitdir}/teamd-shutdown-workaround.service
151 %attr(755,root,root) %{_bindir}/bond2team
152 %attr(755,root,root) %{_bindir}/teamd
153 %attr(755,root,root) %{_bindir}/teamdctl
154 %attr(755,root,root) %{_bindir}/teamnl
155 %attr(755,root,root) %{_libdir}/libteam.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libteam.so.5
157 %attr(755,root,root) %{_libdir}/libteamdctl.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libteamdctl.so.0
159 %attr(755,root,root) /lib/systemd/system-generators/teamd-lvl?-service-generator
160 %{_mandir}/man1/bond2team.1*
161 %{_mandir}/man5/teamd.conf.5*
162 %{_mandir}/man8/teamd.8*
163 %{_mandir}/man8/teamdctl.8*
164 %{_mandir}/man8/teamnl.8*
165
166 %files devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libteam.so
169 %attr(755,root,root) %{_libdir}/libteamdctl.so
170 %{_includedir}/team.h
171 %{_includedir}/teamdctl.h
172 %{_pkgconfigdir}/libteam.pc
173 %{_pkgconfigdir}/libteamdctl.pc
174
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/libteam.a
178 %{_libdir}/libteamdctl.a
This page took 0.094746 seconds and 3 git commands to generate.