]> git.pld-linux.org Git - packages/libstorj.git/blob - libstorj.spec
76da0b1ee966357d09e41c86f38defd7f41c02e5
[packages/libstorj.git] / libstorj.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Library and CLI for the Storj protocol
6 Summary(pl.UTF-8):      Biblioteka i narzędzie linii poleceń do protokołu Storj
7 Name:           libstorj
8 Version:        1.0.3
9 Release:        3
10 License:        LGPL v2.1
11 Group:          Libraries
12 #Source0Download: https://github.com/storj/libstorj/releases
13 Source0:        https://github.com/storj/libstorj/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  e00b4938b375e935b19161ece3d10d56
15 URL:            https://github.com/storj/libstorj
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake
18 BuildRequires:  curl-devel >= 7.35.0
19 BuildRequires:  json-c-devel >= 0.11
20 BuildRequires:  libtool >= 2:2
21 # only checked, finally not used
22 BuildRequires:  libmicrohttpd-devel >= 0.9
23 BuildRequires:  libuv-devel >= 1.8.0
24 BuildRequires:  nettle-devel >= 3.1
25 BuildRequires:  pkgconfig
26 # hexdump for tests
27 BuildRequires:  util-linux
28 Requires:       curl-libs >= 7.35.0
29 Requires:       json-c >= 0.11
30 Requires:       libuv >= 1.8.0
31 Requires:       nettle >= 3.1
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Asynchronous multi-platform C library and CLI for encrypted file
36 transfer on the Storj network.
37
38 %description -l pl.UTF-8
39 Asynchroniczna, wieloplatformowa biblioteka C oraz interfejs linii
40 poleceń do przesyłania zaszyfrowanych plików po sieci Storj.
41
42 %package devel
43 Summary:        Header files for Storj library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Storj
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       curl-devel >= 7.35.0
48 Requires:       json-c-devel >= 0.11
49 Requires:       libuv-devel >= 1.8.0
50 Requires:       nettle-devel >= 3.1
51
52 %description devel
53 Header files for Storj library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki Storj.
57
58 %package static
59 Summary:        Static Storj library
60 Summary(pl.UTF-8):      Statyczna biblioteka Storj
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static Storj library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka Storj.
69
70 %prep
71 %setup -q
72
73 %build
74 %{__libtoolize}
75 %{__aclocal} -I build-aux/m4
76 %{__autoconf}
77 %{__automake}
78 %configure \
79         %{!?with_static_libs:--disable-static}
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 # obsoleted by pkg-config
89 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libstorj.la
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc README.md
100 %attr(755,root,root) %{_bindir}/storj
101 %attr(755,root,root) %{_libdir}/libstorj.so.*.*.*
102 %attr(755,root,root) %ghost %{_libdir}/libstorj.so.0
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libstorj.so
107 %{_includedir}/storj.h
108 %{_pkgconfigdir}/libstorj.pc
109
110 %if %{with static_libs}
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/libstorj.a
114 %endif
This page took 0.045566 seconds and 2 git commands to generate.