]> git.pld-linux.org Git - packages/libstk.git/blob - libstk.spec
- release 3 (by relup.sh)
[packages/libstk.git] / libstk.spec
1 #
2 # TODO: global fonts installation
3 #
4 # Workaround for xine-lib.spec - libstk.spec updating:
5 #       1. make-request -r --without stk xine-lib
6 #       2. make-request -r libstk
7 #       3. bump release of xine-lib
8 #       4. make-request -r xine-lib
9 #
10 # Conditional build:
11 %bcond_without  static_libs     # static library
12 %bcond_without  xine            # XINE support
13 %bcond_without  apidocs         # API/internal docs in HTML format
14 #
15 %define         snap    20070719
16 %define         rel     3
17 Summary:        LibSTK - graphical widget set written in C++
18 Summary(pl.UTF-8):      LibSTK - zbiór graficznych widgetów napisany w C++
19 Name:           libstk
20 Version:        0.2.0
21 Release:        0.%{snap}.%{rel}
22 License:        Libstk Library License (relaxed LGPL)
23 Group:          Libraries
24 # https://github.com/dvhart/libstk/tarball/master snapshotted after last commit on %{snap}
25 #Source0:       http://www.libstk.net/sites/www.libstk.net/files/%{name}-%{snap}.tar.gz
26 Source0:        %{name}-%{snap}.tar.gz
27 # Source0-md5:  59ecdb5f78298896a415abe05855b62e
28 Patch0:         %{name}-fixes.patch
29 Patch1:         %{name}-am.patch
30 Patch2:         %{name}-xine.patch
31 Patch3:         %{name}-xsl.patch
32 Patch4:         %{name}-boost.patch
33 URL:            http://www.libstk.net/
34 BuildRequires:  DirectFB-devel
35 BuildRequires:  SDL-devel >= 1.2.0
36 BuildRequires:  autoconf >= 2.54
37 BuildRequires:  automake >= 1:1.7
38 BuildRequires:  boost-devel >= 1.35.0
39 BuildRequires:  freetype-devel >= 2.0
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libpng-devel
42 BuildRequires:  libtool >= 2:1.5
43 BuildRequires:  pkgconfig
44 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.2}
45 %if %{with apidocs}
46 BuildRequires:  docbook-dtd42-xml
47 BuildRequires:  docbook-style-xsl
48 BuildRequires:  graphviz
49 BuildRequires:  libxml2-progs
50 BuildRequires:  libxslt-progs
51 %endif
52 Requires:       fonts-TTF-bitstream-vera
53 %{?with_xine:Provides:  %{name}(xine) = %{version}-%{release}}
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 LibSTK is graphical widget set designed to meet the needs of today's
58 emerging class of embedded media platforms, such as set-top boxes, and
59 vehicular media systems. LibSTK abstracts the graphic and event
60 systems, allowing it to be used on any platform with a C++-compliant
61 compiler.
62
63 %description -l pl.UTF-8
64 LibSTK to zestaw widgetów graficznych zaprojektowany aby sprostać
65 dzisiejszym potrzebom pojawiającej się klasy platform z osadzonymi
66 mediami. LibSTK tworzy abstrakcję systemów grafiki i zdarzeń,
67 pozwalając na używanie ich na każdej platformie z kompilatorem zgodnym
68 z C++.
69
70 %package devel
71 Summary:        Header files for LibSTK library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LibSTK
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       DirectFB-devel
76 Requires:       SDL-devel >= 1.2.0
77 Requires:       boost-devel >= 1.35.0
78 Requires:       freetype-devel >= 2.0
79 Requires:       libjpeg-devel
80 Requires:       libpng-devel
81 %{?with_xine:Requires:  xine-lib-devel >= 2:1.2}
82
83 %description devel
84 Header files for LibSTK library.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki LibSTK.
88
89 %package static
90 Summary:        Static LibSTK library
91 Summary(pl.UTF-8):      Statyczna biblioteka LibSTK
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94
95 %description static
96 Static LibSTK library.
97
98 %description static -l pl.UTF-8
99 Statyczna biblioteka LibSTK.
100
101 %prep
102 %setup -q -n dvhart-libstk-6186fff
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106 %patch3 -p1
107 %patch4 -p1
108
109 %{__rm} doc/images/doc_images_go_here
110
111 %build
112 %{__libtoolize}
113 %{__aclocal}
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 # workaround for xine headers
118 CPPFLAGS="-DHAVE_BASENAME"
119 %configure \
120         --enable-directfb \
121         --enable-fbdev \
122         --enable-sdl \
123         %{!?with_static_libs:--enable-static=no} \
124         %{?with_xine:--enable-xine}
125
126 %{__make}
127
128 %if %{with apidocs}
129 cd doc
130 ./process_xml.sh
131 mv -f output html
132 mv -f images html
133 %endif
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 cd $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
142 for FONT in Vera*.ttf; do
143         %{__rm} "$FONT"
144         ln -s %{_datadir}/fonts/TTF/"$FONT" "$FONT"
145 done
146 %{__rm} copyright
147
148 # just tests, don't package them
149 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{hello_world,hydra,test_app,test_area,timer_test,xine_test}
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %files
158 %defattr(644,root,root,755)
159 %doc AUTHORS ChangeLog README TODO doc/license.txt
160 %attr(755,root,root) %{_libdir}/libstk.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libstk.so.0
162 %{_datadir}/%{name}
163
164 %files devel
165 %defattr(644,root,root,755)
166 %doc doc/{dvhart_carter_architecture.txt,irc_*.txt,uml.jpg,widget_tree.txt} %{?with_apidocs:doc/html}
167 %attr(755,root,root) %{_libdir}/libstk.so
168 %{_libdir}/libstk.la
169 %{_includedir}/libstk-0.2.0
170 %{_pkgconfigdir}/libstk.pc
171
172 %if %{with static_libs}
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/libstk.a
176 %endif
This page took 0.101513 seconds and 3 git commands to generate.