]> git.pld-linux.org Git - packages/libsodium.git/blob - libsodium.spec
- updated to 0.5.0
[packages/libsodium.git] / libsodium.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform "make check"
4 #
5 Summary:        Portable NaCl-based crypto library
6 Summary(pl.UTF-8):      Przenośna biblioteka kryptograficzna oparta na NaCl
7 Name:           libsodium
8 Version:        0.5.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://download.libsodium.org/libsodium/releases/%{name}-%{version}.tar.gz
13 # Source0-md5:  6e61dbde3a6b06b898a0e18ca27ab161
14 URL:            https://github.com/jedisct1/libsodium
15 BuildRequires:  pkgconfig >= 1:0.25
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 NaCl (<http://nacl.cr.yp.to/>, pronounced "salt") is a new
20 easy-to-use high-speed software library for network communication,
21 encryption, decryption, signatures, etc.
22
23 NaCl's goal is to provide all of the core operations needed to build
24 higher-level cryptographic tools.
25
26 Sodium is a portable, cross-compilable, installable, packageable fork
27 of NaCl, with a compatible API.
28
29 %description -l pl.UTF-8
30 NaCl (<http://nacl.cr.yp.to/>, wymawiane jako "sól") to nowa szybka,
31 łatwa w użyciu biblioteka do komunikacji sieciowej, szyfrowania,
32 odszyfrowywania, podpisów itp.
33
34 Celem NaCl jest zapewnienie wszystkich głównych operacji niezbędnych
35 do tworzenia narzędzi kryptograficznych wyższego poziomu.
36
37 Sodium to przenośne, instalowalne i pakietowalne odgałęzienie NaCl ze
38 zgodnym API.
39
40 %package devel
41 Summary:        Header files for libsodium library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsodium
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for libsodium library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki libsodium.
51
52 %package static
53 Summary:        Static libsodium library
54 Summary(pl.UTF-8):      Statyczna biblioteka libsodium
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static libsodium library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka libsodium.
63
64 %prep
65 %setup -q
66
67 %build
68 # because of bug in ld.bfd (crashes with double free)
69 CFLAGS="%{rpmcflags} -fuse-ld=gold"
70 %configure \
71         --disable-silent-rules
72
73 %{__make}
74
75 %{?with_tests:%{__make} check}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 # obsoleted by pkg-config
84 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsodium.la
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %files
93 %defattr(644,root,root,755)
94 %doc AUTHORS ChangeLog LICENSE README.markdown THANKS
95 %attr(755,root,root) %{_libdir}/libsodium.so.*.*.*
96 %attr(755,root,root) %ghost %{_libdir}/libsodium.so.10
97
98 %files devel
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_libdir}/libsodium.so
101 %{_includedir}/sodium.h
102 %{_includedir}/sodium
103 %{_pkgconfigdir}/libsodium.pc
104
105 %files static
106 %defattr(644,root,root,755)
107 %{_libdir}/libsodium.a
This page took 0.068155 seconds and 3 git commands to generate.