]> git.pld-linux.org Git - packages/libsndfile.git/blob - libsndfile.spec
- -progs R: base now
[packages/libsndfile.git] / libsndfile.spec
1 # TODO:
2 #       - compare flac.patch with Fedora/Gentoo equivalent
3 #       - who needs sndfile-regtest?
4 #
5 # Conditional build:
6 %bcond_with     regtest         # build sndfile-regtest program
7 %bcond_without  static_libs     # don't build static library
8 %bcond_without  tests           # don't build tests
9 #
10 Summary:        C library for reading and writing files containing sampled sound
11 Summary(pl.UTF-8):      Biblioteka obsługi plików dźwiękowych
12 Name:           libsndfile
13 Version:        1.0.17
14 Release:        4
15 License:        LGPL v2.1+
16 Vendor:         Erik de Castro Lopo <erikd@zip.com.au>
17 Group:          Development/Libraries
18 Source0:        http://www.mega-nerd.com/libsndfile/%{name}-%{version}.tar.gz
19 # Source0-md5:  2d126c35448503f6dbe33934d9581f6b
20 Patch0:         %{name}-flac.patch
21 Patch1:         %{name}-flac_buffer_overflow.patch
22 URL:            http://www.mega-nerd.com/libsndfile/
23 BuildRequires:  alsa-lib-devel
24 BuildRequires:  autoconf >= 2.54
25 BuildRequires:  automake
26 BuildRequires:  flac-devel >= 1.1.3
27 %{?with_tests:BuildRequires:    libstdc++-devel}
28 BuildRequires:  libtool
29 BuildRequires:  pkgconfig
30 BuildRequires:  sed >= 4.0
31 %{?with_regtest:BuildRequires:  sqlite3-devel}
32 Obsoletes:      libsndfile1
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Libsndfile is a C library for reading and writing files containing
37 sampled sound (such as MS Windows WAV and the Apple/SGI AIFF format)
38 through one standard library interface.
39
40 %description -l pl.UTF-8
41 Libsndfile to biblioteką napisaną w C, służąca do czytania i
42 zapisywania plików zawierających zsamplowany dźwięk (np. w formacie MS
43 Windows WAV czy Apple/SGI AIFF) poprzez jednolity, standardowy
44 interfejs.
45
46 %package devel
47 Summary:        libsndfile header files and development documentation
48 Summary(pl.UTF-8):      Pliki nagłówkowe oraz dokumentacja do libsndfile
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       flac-devel >= 1.1.1
52 Obsoletes:      libsndfile1-devel
53
54 %description devel
55 Header files and development documentation for libsndfile.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe oraz dokumentacja do biblioteki libsndfile.
59
60 %package static
61 Summary:        libsndfile static libraries
62 Summary(pl.UTF-8):      Biblioteki statyczne libsndfile
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 libsndfile static libraries.
68
69 %description static -l pl.UTF-8
70 Biblioteki statyczne libsndfile.
71
72 %package octave
73 Summary:        libsndfile modules for octave
74 Summary(pl.UTF-8):      Moduły libsndfile dla octave
75 Group:          Applications/Math
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       octave
78
79 %description octave
80 A couple of script files for loading, saving, and playing sound files
81 from within Octave.
82
83 %description octave -l pl.UTF-8
84 Kilka skryptów Octave do ładowania, zapisywania i odtwarzania plików
85 dźwiękowych.
86
87 %package progs
88 Summary:        libsndfile utility programs
89 Summary(pl.UTF-8):      Narzędzia korzystające z biblioteki libsndfile
90 Group:          Applications/Sound
91 Requires:       %{name} = %{version}-%{release}
92
93 %description progs
94 libsndfile utility programs:
95 - sndfile-convert − convert a sound files from one format to another
96 - sndfile-info − display information about a sound file
97 - sndfile-play − play a sound file
98
99 %description progs -l pl.UTF-8
100 Narzędzia z biblioteki libsndfile:
101 - sndfile-convert - kowertertuje pliki dźwiękowe
102 - sndfile-info - wyświetla informacje o pliku dźwiękowym
103 - sndfile-play - odtwarza pliki dźwiękowe
104
105 %prep
106 %setup -q
107 %patch0 -p1
108 %patch1 -p1
109
110 %if %{without tests}
111 %{__sed} -i 's, tests$,,' Makefile.am
112 %endif
113
114 %build
115 %{__libtoolize}
116 %{__aclocal}
117 %{__autoconf}
118 %{__automake}
119 %configure \
120         %{!?with_static_libs:--disable-static} \
121         %{!?with_regtest:--disable-sqlite}
122
123 %{__make}
124 %{?with_tests: %{__make} test}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 rm -rf $RPM_BUILD_ROOT%{_docdir}/libsndfile1-dev
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog NEWS README TODO
143 %attr(755,root,root) %{_libdir}/libsndfile.so.*.*
144
145 %files devel
146 %defattr(644,root,root,755)
147 %doc doc/*.html doc/*.jpg doc/new_file_type.HOWTO
148 %attr(755,root,root) %{_libdir}/libsndfile.so
149 %{_libdir}/libsndfile.la
150 %{_includedir}/sndfile.h*
151 %{_pkgconfigdir}/sndfile.pc
152
153 %if %{with static_libs}
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libsndfile.a
157 %endif
158
159 %files octave
160 %defattr(644,root,root,755)
161 %{_datadir}/octave/site/m/*
162
163 %files progs
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_bindir}/sndfile-convert
166 %attr(755,root,root) %{_bindir}/sndfile-info
167 %attr(755,root,root) %{_bindir}/sndfile-play
168 %{_mandir}/man1/sndfile-*.1*
This page took 0.075151 seconds and 4 git commands to generate.