]> git.pld-linux.org Git - packages/libsndfile.git/blob - libsndfile.spec
9159405926d749553923e57cc4095a7a2019996c
[packages/libsndfile.git] / libsndfile.spec
1 # TODO:
2 #       - who needs sndfile-regtest?
3 #
4 # Conditional build:
5 %bcond_with     regtest         # build sndfile-regtest program
6 %bcond_without  octave          # don't build octave binding
7 %bcond_without  static_libs     # don't build static library
8 %bcond_without  tests           # don't build tests
9 #
10 Summary:        C library for reading and writing files containing sampled sound
11 Summary(pl.UTF-8):      Biblioteka obsługi plików dźwiękowych
12 Name:           libsndfile
13 Version:        1.0.28
14 Release:        2
15 License:        LGPL v2.1+
16 Group:          Libraries
17 Source0:        http://www.mega-nerd.com/libsndfile/files/%{name}-%{version}.tar.gz
18 # Source0-md5:  646b5f98ce89ac60cdb060fcd398247c
19 Patch0:         octave32.patch
20 URL:            http://www.mega-nerd.com/libsndfile/
21 BuildRequires:  alsa-lib-devel
22 BuildRequires:  autoconf >= 2.57
23 BuildRequires:  automake
24 BuildRequires:  flac-devel >= 1.3.1
25 BuildRequires:  gcc-fortran
26 BuildRequires:  libogg-devel >= 2:1.1.3
27 %{?with_tests:BuildRequires:    libstdc++-devel}
28 BuildRequires:  libtool >= 2:2
29 BuildRequires:  libvorbis-devel >= 1:1.2.3
30 %{?with_octave:BuildRequires:   octave-devel >= 2:3}
31 BuildRequires:  pkgconfig
32 BuildRequires:  sed >= 4.0
33 %{?with_regtest:BuildRequires:  sqlite3-devel >= 3.2}
34 Requires:       flac >= 1.3.1
35 Requires:       libogg >= 2:1.1.3
36 Requires:       libvorbis >= 1:1.2.3
37 Obsoletes:      libsndfile1
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Libsndfile is a C library for reading and writing files containing
42 sampled sound (such as MS Windows WAV and the Apple/SGI AIFF format)
43 through one standard library interface.
44
45 %description -l pl.UTF-8
46 Libsndfile to biblioteką napisaną w C, służąca do czytania i
47 zapisywania plików zawierających zsamplowany dźwięk (np. w formacie MS
48 Windows WAV czy Apple/SGI AIFF) poprzez jednolity, standardowy
49 interfejs.
50
51 %package devel
52 Summary:        libsndfile header files and development documentation
53 Summary(pl.UTF-8):      Pliki nagłówkowe oraz dokumentacja do libsndfile
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       flac-devel >= 1.3.1
57 Requires:       libogg-devel >= 2:1.1.3
58 Requires:       libvorbis-devel >= 1:1.2.3
59 Obsoletes:      libsndfile1-devel
60
61 %description devel
62 Header files and development documentation for libsndfile.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe oraz dokumentacja do biblioteki libsndfile.
66
67 %package static
68 Summary:        libsndfile static libraries
69 Summary(pl.UTF-8):      Biblioteki statyczne libsndfile
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 libsndfile static libraries.
75
76 %description static -l pl.UTF-8
77 Biblioteki statyczne libsndfile.
78
79 %package progs
80 Summary:        libsndfile utility programs
81 Summary(pl.UTF-8):      Narzędzia korzystające z biblioteki libsndfile
82 Group:          Applications/Sound
83 Requires:       %{name} = %{version}-%{release}
84
85 %description progs
86 libsndfile utility programs:
87 - sndfile-convert - convert a sound files from one format to another
88 - sndfile-info - display information about a sound file
89 - sndfile-play - play a sound file
90
91 %description progs -l pl.UTF-8
92 Narzędzia z biblioteki libsndfile:
93 - sndfile-convert - kowertertuje pliki dźwiękowe
94 - sndfile-info - wyświetla informacje o pliku dźwiękowym
95 - sndfile-play - odtwarza pliki dźwiękowe
96
97 %package -n octave-sndfile
98 Summary:        sndfile module for Octave
99 Summary(pl.UTF-8):      Moduł sndfile dla Octave
100 Group:          Applications/Math
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       octave >= 2:3
103 Obsoletes:      libsndfile-octave
104
105 %description -n octave-sndfile
106 A couple of script files for loading, saving, and playing sound files
107 from within Octave.
108
109 %description -n octave-sndfile -l pl.UTF-8
110 Kilka skryptów Octave do ładowania, zapisywania i odtwarzania plików
111 dźwiękowych.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116
117 %if %{without tests}
118 %{__sed} -i 's, tests$,,' Makefile.am
119 %endif
120
121 %build
122 %{__libtoolize}
123 %{__aclocal} -I M4
124 %{__autoconf}
125 %{__automake}
126 %configure \
127         %{!?with_octave:--disable-octave} \
128         --disable-silent-rules \
129         %{!?with_regtest:--disable-sqlite} \
130         %{!?with_static_libs:--disable-static}
131
132 %{__make}
133
134 %{?with_tests:%{__make} test}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 # packaged as %doc
143 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libsndfile
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -p /sbin/ldconfig
149 %postun -p /sbin/ldconfig
150
151 %files
152 %defattr(644,root,root,755)
153 %doc AUTHORS ChangeLog NEWS README
154 %attr(755,root,root) %{_libdir}/libsndfile.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libsndfile.so.1
156
157 %files devel
158 %defattr(644,root,root,755)
159 %doc doc/*.html doc/*.jpg doc/new_file_type.HOWTO
160 %attr(755,root,root) %{_libdir}/libsndfile.so
161 %{_libdir}/libsndfile.la
162 %{_includedir}/sndfile.h*
163 %{_pkgconfigdir}/sndfile.pc
164
165 %if %{with static_libs}
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/libsndfile.a
169 %endif
170
171 %files progs
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_bindir}/sndfile-*
174 %{_mandir}/man1/sndfile-*.1*
175
176 %if %{with octave}
177 %files -n octave-sndfile
178 %defattr(644,root,root,755)
179 %{_datadir}/octave/site/m/sndfile_*.m
180 %dir %{_libdir}/octave/*/site/oct/*/sndfile
181 %{_libdir}/octave/*/site/oct/*/sndfile/PKG_ADD
182 %attr(755,root,root) %{_libdir}/octave/*/site/oct/*/sndfile/sndfile.oct
183 %endif
This page took 0.049633 seconds and 2 git commands to generate.