]> git.pld-linux.org Git - packages/libsecret.git/blob - libsecret.spec
- updated to 0.18
[packages/libsecret.git] / libsecret.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 %bcond_without  vala            # do not build Vala API
6 #
7 Summary:        Library for storing and retrieving passwords and other secrets
8 Summary(pl.UTF-8):      Biblioteka do przechowywania i odczytu haseł oraz innych tajnych informacji
9 Name:           libsecret
10 Version:        0.18
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsecret/0.18/%{name}-%{version}.tar.xz
15 # Source0-md5:  279d723cd005e80d1d304f74a3488acc
16 URL:            https://live.gnome.org/Libsecret
17 BuildRequires:  glib2-devel >= 1:2.38.0
18 BuildRequires:  gobject-introspection-devel >= 1.29
19 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
20 BuildRequires:  intltool >= 0.35.0
21 BuildRequires:  libgcrypt-devel >= 1.2.2
22 BuildRequires:  libxslt-progs
23 BuildRequires:  pkgconfig
24 %{?with_vala:BuildRequires:     vala >= 2:0.17.2.12}
25 Requires:       glib2 >= 1:2.38.0
26 Requires:       libgcrypt >= 1.2.2
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 libsecret is a library for storing and retrieving passwords and other
31 secrets. It communicates with the "Secret Service" using DBus.
32 gnome-keyring and KSecretService are both implementations of a Secret
33 Service.
34
35 %description -l pl.UTF-8
36 libsecret to biblioteka do przechowywania i odczytu haseł oraz innych
37 tajnych informacji. Komunikuje się z usługą informacji tajnych
38 ("Secret Service") poprzez DBus. Zarówno gnome-keyring, jak i
39 KSecretService są implementacjami tej usługi.
40
41 %package devel
42 Summary:        Header files for libsecret library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsecret
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       glib2-devel >= 1:2.38.0
47 Requires:       libgcrypt-devel >= 1.2.2
48
49 %description devel
50 Header files for libsecret library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki libsecret.
54
55 %package static
56 Summary:        Static libsecret library
57 Summary(pl.UTF-8):      Statyczna biblioteka libsecret
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static libsecret library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka libsecret.
66
67 %package apidocs
68 Summary:        libsecret API documentation
69 Summary(pl.UTF-8):      Dokumentacja API biblioteki libsecret
70 Group:          Documentation
71
72 %description apidocs
73 libsecret API documentation.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API biblioteki libsecret.
77
78 %package -n vala-libsecret
79 Summary:        libsecret API for Vala language
80 Summary(pl.UTF-8):      API libsecret dla języka Vala
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83 Requires:       vala >= 2:0.17.2.12
84
85 %description -n vala-libsecret
86 libsecret API for Vala language.
87
88 %description -n vala-libsecret -l pl.UTF-8
89 API libsecret dla języka Vala.
90
91 %prep
92 %setup -q
93
94 %build
95 %configure \
96         --disable-silent-rules \
97         %{__enable_disable static_libs static} \
98         %{__enable_disable apidocs gtk-doc} \
99         %{__enable_disable vala vala} \
100         --with-html-dir=%{_gtkdocdir}/%{name}
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %find_lang libsecret
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files -f libsecret.lang
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog NEWS README
120 %attr(755,root,root) %{_bindir}/secret-tool
121 %attr(755,root,root) %{_libdir}/libsecret-1.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libsecret-1.so.0
123 %{_libdir}/girepository-1.0/Secret-1.typelib
124 %{_mandir}/man1/secret-tool.1*
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/libsecret-1.so
129 %{_libdir}/libsecret-1.la
130 %{_includedir}/libsecret-1
131 %{_pkgconfigdir}/libsecret-1.pc
132 %{_pkgconfigdir}/libsecret-unstable.pc
133 %{_datadir}/gir-1.0/Secret-1.gir
134
135 %if %{with static_libs}
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libsecret-1.a
139 %endif
140
141 %if %{with apidocs}
142 %files apidocs
143 %defattr(644,root,root,755)
144 %{_gtkdocdir}/%{name}
145 %endif
146
147 %if %{with vala}
148 %files -n vala-libsecret
149 %defattr(644,root,root,755)
150 %{_datadir}/vala/vapi/libsecret-1.deps
151 %{_datadir}/vala/vapi/libsecret-1.vapi
152 %endif
This page took 0.068697 seconds and 4 git commands to generate.