]> git.pld-linux.org Git - packages/libseccomp.git/blob - libseccomp.spec
BR pkgconfig
[packages/libseccomp.git] / libseccomp.spec
1 #
2 # Conditional build:
3 %bcond_without  tests
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_with     python          # build Python bindings
6
7 Summary:        Enhanced Seccomp (mode 2) Helper library
8 Summary(pl.UTF-8):      Rozszerzona biblioteka pomocnicza Seccomp (trybu 2)
9 Name:           libseccomp
10 Version:        2.2.3
11 Release:        1
12 License:        LGPL v2.1
13 Group:          Libraries
14 Source0:        https://github.com/seccomp/libseccomp/releases/download/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  7db418d35d7a6168400bf6b05502f8bf
16 URL:            https://github.com/seccomp/libseccomp
17 BuildRequires:  bash
18 BuildRequires:  pkgconfig
19 %if %{with python}
20 BuildRequires:  python-Cython >= 0.16
21 %endif
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The libseccomp library provides and easy to use, platform independent,
26 interface to the Linux Kernel's syscall filtering mechanism: seccomp.
27 The libseccomp API is designed to abstract away the underlying BPF
28 based syscall filter language and present a more conventional
29 function-call based filtering interface that should be familiar to,
30 and easily adopted by application developers.
31
32 %description -l pl.UTF-8
33 Biblioteka libseccomp udostępnia łatwy w użyciu, niezależny od
34 platformy interfejs do mechanizmu filtrowania wywołań systemowych
35 jądra Linuksa - seccomp. API libseccomp jest zaprojektowane tak, żeby
36 wyabstrahować język filtrowania wywołań BPF niższego poziomu i
37 zaprezentować bardziej konwencjonalny interfejs filtrowania w oparciu
38 o wywołania funkcji, który powinien być bardziej przyjazny i łatwiej
39 adaptowalny dla programistów aplikacji.
40
41 %package devel
42 Summary:        Header files for Seccomp library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Seccomp
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files for Seccomp library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki Seccomp.
52
53 %package static
54 Summary:        Static Seccomp library
55 Summary(pl.UTF-8):      Statyczna biblioteka Seccomp
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static Seccomp library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka Seccomp.
64
65 %prep
66 %setup -q
67
68 %build
69 %configure \
70         --disable-silent-rules \
71         %{?with_python:--enable-python} \
72         %{!?with_static_libs:--disable-static}
73 %{__make}
74
75 %{?with_tests:%{__make} check}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 # obsoleted by pkg-config file
83 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libseccomp.la
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc CHANGELOG CREDITS README
94 %attr(755,root,root) %{_bindir}/scmp_sys_resolver
95 %attr(755,root,root) %{_libdir}/libseccomp.so.*.*.*
96 %attr(755,root,root) %ghost %{_libdir}/libseccomp.so.2
97 %{_mandir}/man1/scmp_sys_resolver.1*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libseccomp.so
102 %{_includedir}/seccomp.h
103 %{_pkgconfigdir}/libseccomp.pc
104 %{_mandir}/man3/seccomp_*.3*
105
106 %if %{with static_libs}
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/libseccomp.a
110 %endif
This page took 0.043566 seconds and 3 git commands to generate.