]> git.pld-linux.org Git - packages/libs3.git/blob - libs3.spec
f3415b2e99817d177d762198a980ebeb2f325fbb
[packages/libs3.git] / libs3.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        C library and tools for Amazon S3 access
6 Summary(pl.UTF-8):      Biblioteka C i narzędzia do dostępu do Amazon S3
7 Name:           libs3
8 Version:        2.0
9 Release:        4
10 License:        GPL v3 with OpenSSL exception
11 Group:          Libraries
12 Source0:        http://libs3.ischo.com.s3.amazonaws.com/%{name}-%{version}.tar.gz
13 # Source0-md5:  e52da69ddc11019e98cf8246fc55b4e1
14 Patch0:         %{name}-make.patch
15 URL:            https://github.com/bji/libs3
16 BuildRequires:  curl-devel
17 %{?with_apidocs:BuildRequires:  doxygen}
18 BuildRequires:  libxml2-devel
19 BuildRequires:  openssl-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This package includes the libs3 shared library needed to run
24 applications using libs3 and additionally contains the s3 utility for
25 accessing Amazon S3.
26
27 %description -l pl.UTF-8
28 Ten pakiet zawiera bibliotekę współdzieloną libs3 niezbędną do
29 uruchamiania aplikacji wykorzystujących libs3 oraz dodatkowo narzędzie
30 s3 pozwalające na dostęp do Amazon S3.
31
32 %package devel
33 Summary:        Header files for libs3 library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libs3
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       curl-devel
38 Requires:       libxml2-devel
39 Requires:       openssl-devel
40
41 %description devel
42 Header files for libs3 library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki libs3.
46
47 %package static
48 Summary:        Static libs3 library
49 Summary(pl.UTF-8):      Statyczna biblioteka libs3
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static libs3 library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka libs3.
58
59 %package apidocs
60 Summary:        libs3 API documentation
61 Summary(pl.UTF-8):      Dokumentacja API biblioteki libs3
62 Group:          Documentation
63 %if "%{_rpmversion}" >= "5"
64 BuildArch:      noarch
65 %endif
66
67 %description apidocs
68 API and internal documentation for libs3 library.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API biblioteki libs3.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76
77 %build
78 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
79 %{__make} exported \
80         CC="%{__cc}" \
81         LDOPTS="%{rpmldflags}" \
82         VERBOSE=1
83
84 %{?with_apidocs:doxygen}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT%{_prefix}
91
92 %if "%{_lib}" != "lib"
93 %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}
94 %endif
95
96 # let rpm generate dependencies
97 chmod 755 $RPM_BUILD_ROOT%{_libdir}/libs3.so*
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc ChangeLog LICENSE README TODO
108 %attr(755,root,root) %{_bindir}/s3
109 %attr(755,root,root) %{_libdir}/libs3.so.*.*
110 %attr(755,root,root) %ghost %{_libdir}/libs3.so.2
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/libs3.so
115 %{_includedir}/libs3.h
116
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/libs3.a
120
121 %if %{with apidocs}
122 %files apidocs
123 %defattr(644,root,root,755)
124 %doc dox/html/*
125 %endif
This page took 0.049844 seconds and 2 git commands to generate.