]> git.pld-linux.org Git - packages/librsvg.git/blob - librsvg.spec
- updated to 2.40.6
[packages/librsvg.git] / librsvg.spec
1 #
2 # Conditional build
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  gtk2            # legacy gtk+2 support
5 %bcond_without  static_libs     # don't build static library
6
7 %define         mver    2.40
8 %define         pver    6
9 Summary:        A Raph's Library for Rendering SVG Data
10 Summary(pl.UTF-8):      Biblioteka Raph's SVG do renderowania danych SVG
11 Summary(pt_BR.UTF-8):   Biblioteca SVG
12 Summary(ru.UTF-8):      SVG библиотека
13 Summary(uk.UTF-8):      SVG бібліотека
14 Name:           librsvg
15 Version:        %{mver}.%{pver}
16 Release:        1
17 Epoch:          1
18 License:        LGPL v2+
19 Group:          X11/Libraries
20 Source0:        http://ftp.gnome.org/pub/GNOME/sources/librsvg/%{mver}/%{name}-%{version}.tar.xz
21 # Source0-md5:  259fd160b47ec11f3c27d7e18e507c99
22 Source1:        rsvg
23 URL:            http://librsvg.sourceforge.net/
24 BuildRequires:  autoconf
25 BuildRequires:  automake >= 1:1.9
26 BuildRequires:  cairo-devel >= 1.2.0
27 BuildRequires:  docbook-dtd412-xml
28 BuildRequires:  gdk-pixbuf2-devel >= 2.20
29 BuildRequires:  glib2-devel >= 1:2.24.0
30 BuildRequires:  gobject-introspection-devel >= 0.10.8
31 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.16.0}
32 BuildRequires:  gtk+3-devel >= 3.2.0
33 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.13}
34 %{?with_apidocs:BuildRequires:  gtk-doc-automake >= 1.13}
35 BuildRequires:  libcroco-devel >= 0.6.1
36 BuildRequires:  libtool >= 2:2.0
37 BuildRequires:  libxml2-devel >= 1:2.7.0
38 BuildRequires:  pango-devel >= 1:1.32.6
39 BuildRequires:  pkgconfig
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  sed >= 4.0
42 BuildRequires:  tar >= 1:1.22
43 BuildRequires:  xz
44 Requires(post,postun):  /sbin/ldconfig
45 Requires:       cairo >= 1.2.0
46 Requires:       gdk-pixbuf2 >= 2.20
47 Requires:       glib2 >= 1:2.24.0
48 Requires:       libcroco >= 0.6.1
49 Requires:       libxml2 >= 1:2.7.0
50 Requires:       pango >= 1:1.32.6
51 Obsoletes:      browser-plugin-librsvg
52 Obsoletes:      librsvg-gtk+2
53 Obsoletes:      librsvg0
54 Obsoletes:      mozilla-plugin-rsvg
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 # see gdk-pixbuf2.spec for source of these ifdefs
58 %if "%{_lib}" != "lib"
59 %define         libext          %(lib="%{_lib}"; echo ${lib#lib})
60 %define         pqext           -%{libext}
61 %else
62 %define         pqext           %{nil}
63 %endif
64
65 %description
66 An library to render SVG (scalable vector graphics), databased upon
67 libart.
68
69 %description -l pl.UTF-8
70 Biblioteka do renderowania SVG (skalowalnej grafiki wektorowej) oparta
71 na kodzie libart.
72
73 %description -l ru.UTF-8
74 Библиотека SVG, базирующаяся на libart.
75
76 %description -l uk.UTF-8
77 Бібліотека SVG, базована на libart.
78
79 %package devel
80 Summary:        Include files for developing with librsvg
81 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia oprogramowania z użyciem librsvg
82 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento com a librsvg
83 Summary(ru.UTF-8):      Библиотечные линки и файлы заголовков для разработки с librsvg
84 Summary(uk.UTF-8):      Бібліотечні лінки та файли заголовків для розробки з librsvg
85 Group:          X11/Development/Libraries
86 Requires:       %{name} = %{epoch}:%{version}-%{release}
87 Requires:       cairo-devel >= 1.2.0
88 Requires:       gdk-pixbuf2-devel >= 2.20
89 Requires:       glib2-devel >= 1:2.24.0
90 Requires:       gtk+3-devel >= 3.2.0
91 Requires:       libcroco-devel >= 0.6.1
92 Requires:       libxml2-devel >= 1:2.7.0
93 Requires:       pango-devel >= 1:1.32.6
94 Obsoletes:      librsvg0-devel
95
96 %description devel
97 This package provides the necessary development libraries and include
98 files to allow you to develop with librsvg.
99
100 %description devel -l pl.UTF-8
101 Pakiet zawiera pliki nagłówkowe potrzebne do tworzenia oprogramowania
102 z wykorzystaniem librsvg.
103
104 %description devel -l pt_BR.UTF-8
105 Este pacote contém os arquivos necessários para desenvolver com base
106 na biblioteca librsvg.
107
108 %description devel -l ru.UTF-8
109 Этот пакет содержит необходимые файлы для разработки программ с
110 использованием librsvg.
111
112 %description devel -l uk.UTF-8
113 Цей пакет містить необхідні файли для розробки програм з використанням
114 librsvg.
115
116 %package static
117 Summary:        Static libraries for developing with librsvg
118 Summary(es.UTF-8):      Archivos estáticos necesarios para el desarrollo de aplicaciones con librsvg
119 Summary(pl.UTF-8):      Statyczne biblioteki librsvg
120 Summary(pt_BR.UTF-8):   Arquivos estáticos necessários para o desenvolvimento de aplicações com librsvg
121 Group:          X11/Development/Libraries
122 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
123
124 %description static
125 This package contains static version of librsvg libraries.
126
127 %description static -l pl.UTF-8
128 Statyczna wersja bibliotek librsvg.
129
130 %description static -l pt_BR.UTF-8
131 Bibliotecas estáticas para o desenvolvimento de aplicações com
132 librsvg.
133
134 %package apidocs
135 Summary:        librsvg API documentation
136 Summary(pl.UTF-8):      Dokumentacja API biblioteki librsvg
137 Group:          Documentation
138 Requires:       gtk-doc-common
139
140 %description apidocs
141 librsvg API documentation.
142
143 %description apidocs -l pl.UTF-8
144 Dokumentacja API biblioteki librsvg.
145
146 %package gtk+3
147 Summary:        librsvg/GTK+3 based SVG viewer
148 Summary(pl.UTF-8):      Przeglądarka plików SVG oparta na bibliotekach librsvg/GTK+3
149 Group:          X11/Applications/Graphics
150 Requires:       %{name} = %{epoch}:%{version}-%{release}
151 Requires:       gtk+3 >= 3.2.0
152
153 %description gtk+3
154 librsvg/GTK+3 based SVG viewer.
155
156 %description gtk+3 -l pl.UTF-8
157 Przeglądarka plików SVG oparta na bibliotekach librsvg/GTK+3.
158
159 %prep
160 %setup -q
161
162 %if %{without apidocs}
163 echo 'CLEANFILES=' > gtk-doc.make
164 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
165 %endif
166
167 %build
168 %{?with_apidocs:%{__gtkdocize}}
169 %{__libtoolize}
170 %{__aclocal}
171 %{__autoconf}
172 %{__autoheader}
173 %{__automake}
174 %configure \
175         --disable-silent-rules \
176         %{__enable_disable static_libs static} \
177         %{__enable_disable apidocs gtk-doc} \
178         --enable-introspection \
179         --with-html-dir=%{_gtkdocdir}/%{name}
180 %{__make}
181
182 %install
183 rm -rf $RPM_BUILD_ROOT
184
185 %{__make} install \
186         DESTDIR=$RPM_BUILD_ROOT \
187         pkgconfigdir=%{_pkgconfigdir}
188
189 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/*.{la,a}
190 %{__rm} $RPM_BUILD_ROOT%{_libdir}/librsvg-2.la
191
192 %{__ln_s} rsvg-view-3 $RPM_BUILD_ROOT%{_bindir}/rsvg-view
193
194 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %post
200 /sbin/ldconfig
201 umask 022
202 %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache || :
203
204 %postun
205 /sbin/ldconfig
206 umask 022
207 if [ -x %{_bindir}/gdk-pixbuf-query-loaders%{pqext} ]; then
208         %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache
209 fi
210
211 %files
212 %defattr(644,root,root,755)
213 %doc ChangeLog AUTHORS NEWS
214 %attr(755,root,root) %{_bindir}/rsvg
215 %attr(755,root,root) %{_bindir}/rsvg-convert
216 %attr(755,root,root) %{_libdir}/librsvg-2.so.*.*.*
217 %attr(755,root,root) %ghost %{_libdir}/librsvg-2.so.2
218 %{_libdir}/girepository-1.0/Rsvg-2.0.typelib
219 %attr(755,root,root) %{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/libpixbufloader-svg.so
220 %{_mandir}/man1/rsvg-convert.1*
221
222 %files devel
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_libdir}/librsvg-2.so
225 %{_includedir}/librsvg-2.0
226 %{_datadir}/gir-1.0/Rsvg-2.0.gir
227 %{_pkgconfigdir}/librsvg-2.0.pc
228
229 %if %{with static_libs}
230 %files static
231 %defattr(644,root,root,755)
232 %{_libdir}/librsvg-2.a
233 %endif
234
235 %if %{with apidocs}
236 %files apidocs
237 %defattr(644,root,root,755)
238 %{_gtkdocdir}/%{name}
239 %endif
240
241 %files gtk+3
242 %defattr(644,root,root,755)
243 %attr(755,root,root) %{_bindir}/rsvg-view
244 %attr(755,root,root) %{_bindir}/rsvg-view-3
This page took 0.085608 seconds and 3 git commands to generate.