]> git.pld-linux.org Git - packages/librhtv.git/blob - librhtv.spec
- converted to UTF-8
[packages/librhtv.git] / librhtv.spec
1 Summary:        Unix port of Borland TurboVision library
2 Summary(pl.UTF-8):   Uniksowa wersja biblioteki TurboVision Borlanda
3 Name:           librhtv
4 Version:        2.0.3
5 Release:        2
6 License:        Borland, some modifications are BSD-like licensed (generally free)
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/tvision/rhtvision-%{version}.src.tar.gz
9 # Source0-md5:  b6129f5c510ba9d28d21c9575b7e1c75
10 Patch0:         %{name}-nolowlevelgarbage.patch
11 Patch1:         %{name}-gcc4.patch
12 URL:            http://tvision.sourceforge.net/
13 BuildRequires:  XFree86-devel
14 BuildRequires:  gpm-devel
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  ncurses-devel
17 BuildRequires:  perl-base
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Turbo Vision (or TV, for short) is a library that provides an
22 application framework. With TV you can write a beautiful
23 object-oriented character-mode user interface in a short time.
24
25 TV is available in C++ and Pascal and is a product of Borland
26 International. It was developed to run on MS-DOS systems, but today it
27 is available for many other platforms (ported by independent
28 programmers).
29
30 This port is based on the Borland 2.0 version with fixes.
31
32 %description -l pl.UTF-8
33 Uniksowa wersja biblioteki TurboVision 2.0 Borlanda. TurboVision jest
34 obiektową biblioteką do okienkowych interfejsów użytkownika w trybie
35 tekstowym.
36
37 %package devel
38 Summary:        %{name} header files
39 Summary(pl.UTF-8):   Pliki nagłówkowe %{name}
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 rhtvision header files.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe rhtvision.
48
49 %package static
50 Summary:        Static %{name} libraries
51 Summary(pl.UTF-8):   Biblioteki statyczne %{name}
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static rhtvision libraries.
57
58 %description static -l pl.UTF-8
59 Biblioteki statyczne rhtvision.
60
61 %prep
62 %setup -q -n tvision
63 %patch0 -p1
64 %patch1 -p1
65
66 %build
67 %{__perl} config.pl \
68         --prefix=%{_prefix} \
69         --cflags="%{rpmcflags} -I/usr/include/ncurses" \
70         --cxxflags="%{rpmcflags} -fno-exceptions -I/usr/include/ncurses" \
71         %{?debug:--with-debug}
72
73 %{__make} \
74         RHIDE_GCC="%{__cc}" \
75         RHIDE_GXX="%{__cxx}" \
76         libdir=%{_libdir}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
81
82 %{__make} install \
83         prefix=$RPM_BUILD_ROOT%{_prefix} \
84         libdir=$RPM_BUILD_ROOT%{_libdir}
85
86 # let's create new rhide.env
87 cat > examples/rhide.env  <<EOF
88 RHIDE_GCC=gcc
89 RHIDE_GXX=g++
90 RHIDE_LD=gcc
91 RHIDE_AR=ar
92 RHIDE_ARFLAGS=rcs
93 RHIDE_OS_CFLAGS=%{rpmcflags} -Wall
94 RHIDE_OS_CXXFLAGS=%{rpmcflags} -Wall
95 RHIDE_STDINC=/usr/include /usr/X11R6/include /usr/include/ncurses
96 TVSRC=%{_includedir}/rhtvision
97 RHIDE_OS_LIBS=stdc++
98 TVOBJ=
99 STDCPP_LIB=-lstdc++
100 SHARED_CODE_OPTION=-fPIC
101 EOF
102
103 cd examples
104 %{__perl} patchenv.pl
105 cd ..
106
107 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
108
109 %find_lang tvision%{version}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files -f tvision%{version}.lang
118 %defattr(644,root,root,755)
119 %doc readme.txt TODO borland.txt
120 %attr(755,root,root) %{_libdir}/lib*.so.*.*
121
122 %files devel
123 %defattr(644,root,root,755)
124 %doc doc/*.txt doc/*.html
125 %attr(755,root,root) %{_bindir}/rhtv-config
126 %attr(755,root,root) %{_libdir}/lib*.so
127 %{_includedir}/*
128 %{_examplesdir}/%{name}-%{version}
129
130 %files static
131 %defattr(644,root,root,755)
132 %{_libdir}/lib*.a
This page took 0.033543 seconds and 3 git commands to generate.