]> git.pld-linux.org Git - packages/librevenge.git/blob - librevenge.spec
1aa60a38d04bb79ac673c7320a8f4bd2979ed7af
[packages/librevenge.git] / librevenge.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  gdb             # GDB pretty printers
5
6 Summary:        Library for generic document converters
7 Summary(pl.UTF-8):      Biblioteka dla ogólnych konwerterów dokumentów
8 Name:           librevenge
9 Version:        0.0.5
10 Release:        1
11 License:        MPL v2.0 or LGPL v2.1+
12 Group:          Libraries
13 Source0:        https://downloads.sourceforge.net/libwpd/%{name}-%{version}.tar.xz
14 # Source0-md5:  c6e629dfb9557a6a2cd4309b31eddfa8
15 URL:            https://sourceforge.net/p/libwpd/wiki/librevenge/
16 BuildRequires:  autoconf >= 2.65
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  boost-devel >= 1.20
19 BuildRequires:  cppunit-devel
20 BuildRequires:  doxygen
21 BuildRequires:  libstdc++-devel >= 6:4.7
22 BuildRequires:  libtool >= 2:2
23 BuildRequires:  pkgconfig
24 %{?with_gdb:BuildRequires:      python}
25 %{?with_gdb:BuildRequires:      python-modules}
26 BuildRequires:  rpmbuild(macros) >= 1.234
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 BuildRequires:  zlib-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 librevenge is a base library for writing document import filters. It
34 has interfaces for text documents, vector graphics, spreadsheets and
35 presentations.
36
37 %description -l pl.UTF-8
38 librevenge to biblioteka podstawowa do pisania filtrów importujących
39 dokumenty. Zawiera interfejsy dla dokumentów tekstowych, grafiki
40 wektorowej, arkuszy kalkulacyjnych oraz prezentacji.
41
42 %package devel
43 Summary:        Header files for librevenge library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki librevenge
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       libstdc++-devel >= 6:4.7
48
49 %description devel
50 Header files for librevenge library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki librevenge.
54
55 %package static
56 Summary:        Static librevenge library
57 Summary(pl.UTF-8):      Statyczna biblioteka librevenge
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static librevenge library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka librevenge.
66
67 %package apidocs
68 Summary:        API documentation for librevenge library
69 Summary(pl.UTF-8):      Dokumentacja API biblioteki librevenge
70 Group:          Documentation
71 BuildArch:      noarch
72
73 %description apidocs
74 API documentation for librevenge library.
75
76 %description apidocs -l pl.UTF-8
77 Dokumentacja API biblioteki librevenge.
78
79 %package gdb
80 Summary:        GDB Python pretty printers for librevenge types
81 Summary(pl.UTF-8):      Skrypty Pythona dla GDB do ładnego wypisywania typów librevenge
82 Group:          Development/Debuggers
83 Requires:       gdb
84
85 %description gdb
86 GDB Python pretty printers for librevenge types.
87
88 %description gdb -l pl.UTF-8
89 Skrypty Pythona dla GDB do ładnego wypisywania typów librevenge.
90
91 %prep
92 %setup -q
93
94 %build
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         %{?with_gdb:--enable-pretty-printers} \
102         %{?with_static_libs:--enable-static} \
103         --disable-werror \
104         --disable-silent-rules
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
114 %{__rm} $RPM_BUILD_ROOT%{_libdir}/librevenge-*.la
115
116 %if %{with gdb}
117 %py_comp $RPM_BUILD_ROOT%{_datadir}/librevenge/python/librevenge
118 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/librevenge/python/librevenge
119 %py_postclean %{_datadir}/librevenge/python/librevenge
120 %endif
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS ChangeLog NEWS README
131 %attr(755,root,root) %{_libdir}/librevenge-0.0.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/librevenge-0.0.so.0
133 %attr(755,root,root) %{_libdir}/librevenge-generators-0.0.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/librevenge-generators-0.0.so.0
135 %attr(755,root,root) %{_libdir}/librevenge-stream-0.0.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/librevenge-stream-0.0.so.0
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/librevenge-0.0.so
141 %attr(755,root,root) %{_libdir}/librevenge-generators-0.0.so
142 %attr(755,root,root) %{_libdir}/librevenge-stream-0.0.so
143 %{_includedir}/librevenge-0.0
144 %{_pkgconfigdir}/librevenge-0.0.pc
145 %{_pkgconfigdir}/librevenge-generators-0.0.pc
146 %{_pkgconfigdir}/librevenge-stream-0.0.pc
147
148 %if %{with static_libs}
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/librevenge-0.0.a
152 %{_libdir}/librevenge-generators-0.0.a
153 %{_libdir}/librevenge-stream-0.0.a
154 %endif
155
156 %files apidocs
157 %defattr(644,root,root,755)
158 %doc docs/doxygen/html/*
159
160 %if %{with gdb}
161 %files gdb
162 %defattr(644,root,root,755)
163 %{_datadir}/gdb/auto-load/%{_libdir}/librevenge-0.0-gdb.py
164 %{_datadir}/gdb/auto-load/%{_libdir}/librevenge-stream-0.0-gdb.py
165 %dir %{_datadir}/librevenge
166 %{_datadir}/librevenge/python
167 %endif
This page took 0.041268 seconds and 2 git commands to generate.