]> git.pld-linux.org Git - packages/libredwg.git/blob - libredwg.spec
- updated to 0.12.4
[packages/libredwg.git] / libredwg.spec
1 Summary:        LibreDWG - free implementation of the DWG file format
2 Summary(pl.UTF-8):      LibreDWG - wolnodostępna implementacja formatu plików DWG
3 Name:           libredwg
4 Version:        0.12.4
5 Release:        1
6 License:        GPL v3+
7 Group:          Libraries
8 Source0:        https://ftp.gnu.org/gnu/libredwg/%{name}-%{version}.tar.xz
9 # Source0-md5:  9aba1400b02db931f4ee8a1155fd2376
10 Patch0:         %{name}-info.patch
11 Patch1:         %{name}-python.patch
12 Patch2:         %{name}-sh.patch
13 URL:            http://www.gnu.org/software/libredwg/
14 BuildRequires:  autoconf >= 2.61
15 BuildRequires:  automake >= 1:1.14
16 BuildRequires:  bash
17 BuildRequires:  doxygen
18 BuildRequires:  libtool >= 2:2
19 BuildRequires:  libxml2-devel >= 2.0
20 BuildRequires:  pcre2-8-devel
21 BuildRequires:  pcre2-16-devel
22 BuildRequires:  perl-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  pslib-devel
25 BuildRequires:  python-devel >= 1:2.7
26 BuildRequires:  rpm-perlprov
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  swig-python >= 1.3.17
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  texinfo
32 BuildRequires:  xz
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 LibreDWG is a free C library to read DWG files. DWG is a file format
37 created in the 70's for the emerging CAD applications. Currently it
38 is the native file format of AutoCAD, a proprietary CAD program
39 developed by AutoDesk.
40
41 %description -l pl.UTF-8
42 LibreDWG to wolnodostępna biblioteka C do odczytu plików DWG. DWG to
43 format plików powstały w latach 70. dla powstających aplikacji CAD.
44 Obecnie jest to natywny format AutoCAD-a - własnościowego programu
45 CAD rozwijanego przez firmę AutoDesk.
46
47 %package devel
48 Summary:        Header files for LibreDWG library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LibreDWG
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 # dwg.h file
53 Conflicts:      libdwg-devel
54
55 %description devel
56 Header files for LibreDWG library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki LibreDWG.
60
61 %package static
62 Summary:        Static LibreDWG library
63 Summary(pl.UTF-8):      Statyczna biblioteka LibreDWG
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static LibreDWG library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka LibreDWG.
72
73 %package -n perl-libredwg
74 Summary:        Perl interface for LibreDWG library
75 Summary(pl.UTF-8):      Interfejs Perla do biblioteki LibreDWG
76 Group:          Development/Languages/Perl
77 Requires:       %{name} = %{version}-%{release}
78
79 %description -n perl-libredwg
80 Perl interface for LibreDWG library.
81
82 %description -n perl-libredwg -l pl.UTF-8
83 Interfejs Perla do biblioteki LibreDWG.
84
85 %package -n python-libredwg
86 Summary:        Python interface for LibreDWG library
87 Summary(pl.UTF-8):      Interfejs Pythona do biblioteki LibreDWG
88 Group:          Development/Languages/Perl
89 Requires:       %{name} = %{version}-%{release}
90
91 %description -n python-libredwg
92 Python interface for LibreDWG library.
93
94 %description -n python-libredwg -l pl.UTF-8
95 Interfejs Pythona do biblioteki LibreDWG.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102
103 # no git-version-gen in release tarball
104 %{__sed} -i -e 's/m4_esyscmd.*git-version-gen.*/[%{version}],/' configure.ac
105
106 %build
107 %{__libtoolize}
108 %{__aclocal} -I m4
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         --disable-silent-rules \
114         --with-perl-install=vendor
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 # obsoleted by pkg-config
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libredwg.la
126
127 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_LibreDWG.la
128 %py_postclean
129
130 # just example, nothing really useful
131 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-libredwg-%{version}
132 %{__mv} $RPM_BUILD_ROOT%{_datadir}/load_dwg.py $RPM_BUILD_ROOT%{_examplesdir}/python-libredwg-%{version}
133 # packaged as %doc
134 %{__rm} $RPM_BUILD_ROOT%{_datadir}/dwgadd.example
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %post   devel -p /sbin/postshell
143 -/usr/sbin/fix-info-dir -c %{_infodir}
144
145 %postun devel -p /sbin/postshell
146 -/usr/sbin/fix-info-dir -c %{_infodir}
147
148 %files
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog NEWS README TODO examples/dwgadd.example
151 %attr(755,root,root) %{_bindir}/dwg2SVG
152 %attr(755,root,root) %{_bindir}/dwg2dxf
153 %attr(755,root,root) %{_bindir}/dwg2ps
154 %attr(755,root,root) %{_bindir}/dwgadd
155 %attr(755,root,root) %{_bindir}/dwgbmp
156 %attr(755,root,root) %{_bindir}/dwgfilter
157 %attr(755,root,root) %{_bindir}/dwggrep
158 %attr(755,root,root) %{_bindir}/dwglayers
159 %attr(755,root,root) %{_bindir}/dwgread
160 %attr(755,root,root) %{_bindir}/dwgrewrite
161 %attr(755,root,root) %{_bindir}/dwgwrite
162 %attr(755,root,root) %{_bindir}/dxf2dwg
163 %attr(755,root,root) %{_bindir}/dxfwrite
164 %attr(755,root,root) %{_libdir}/libredwg.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libredwg.so.0
166 %{_mandir}/man1/dwg2SVG.1*
167 %{_mandir}/man1/dwg2dxf.1*
168 %{_mandir}/man1/dwg2ps.1*
169 %{_mandir}/man1/dwgadd.1*
170 %{_mandir}/man1/dwgbmp.1*
171 %{_mandir}/man1/dwgfilter.1*
172 %{_mandir}/man1/dwggrep.1*
173 %{_mandir}/man1/dwglayers.1*
174 %{_mandir}/man1/dwgread.1*
175 %{_mandir}/man1/dwgrewrite.1*
176 %{_mandir}/man1/dwgwrite.1*
177 %{_mandir}/man1/dxf2dwg.1*
178 %{_mandir}/man1/dxfwrite.1*
179 %{_mandir}/man5/dwgadd.5*
180
181 %files devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/libredwg.so
184 %{_includedir}/dwg.h
185 %{_includedir}/dwg_api.h
186 %{_pkgconfigdir}/libredwg.pc
187 %{_infodir}/LibreDWG.info*
188
189 %files static
190 %defattr(644,root,root,755)
191 %{_libdir}/libredwg.a
192
193 %files -n perl-libredwg
194 %defattr(644,root,root,755)
195 %{perl_vendorarch}/LibreDWG.pm
196 %dir %{perl_vendorarch}/auto
197 %dir %{perl_vendorarch}/auto/LibreDWG
198 %attr(755,root,root) %{perl_vendorarch}/auto/LibreDWG/LibreDWG.so
199
200 %files -n python-libredwg
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{py_sitedir}/_LibreDWG.so
203 %{py_sitescriptdir}/LibreDWG.py[co]
204 %{_examplesdir}/python-libredwg-%{version}
This page took 0.053573 seconds and 3 git commands to generate.