]> git.pld-linux.org Git - packages/libredwg.git/blob - libredwg.spec
d3a234c4225c9b37e80d65e04dbac24f931daca5
[packages/libredwg.git] / libredwg.spec
1 Summary:        LibreDWG - free implementation of the DWG file format
2 Summary(pl.UTF-8):      LibreDWG - wolnodostępna implementacja formatu plików DWG
3 Name:           libredwg
4 Version:        0.12.5
5 Release:        1
6 License:        GPL v3+
7 Group:          Libraries
8 Source0:        https://ftp.gnu.org/gnu/libredwg/%{name}-%{version}.tar.xz
9 # Source0-md5:  3cb1ec853a665b74924ac417698589d7
10 Patch0:         %{name}-info.patch
11 Patch1:         %{name}-python.patch
12 URL:            http://www.gnu.org/software/libredwg/
13 BuildRequires:  autoconf >= 2.61
14 BuildRequires:  automake >= 1:1.14
15 BuildRequires:  bash
16 BuildRequires:  doxygen
17 BuildRequires:  libtool >= 2:2
18 BuildRequires:  libxml2-devel >= 2.0
19 BuildRequires:  pcre2-8-devel
20 BuildRequires:  pcre2-16-devel
21 BuildRequires:  perl-devel
22 BuildRequires:  pkgconfig
23 BuildRequires:  pslib-devel
24 BuildRequires:  python-devel >= 1:2.7
25 BuildRequires:  rpm-perlprov
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  sed >= 4.0
28 BuildRequires:  swig-python >= 1.3.17
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  texinfo
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 LibreDWG is a free C library to read DWG files. DWG is a file format
36 created in the 70's for the emerging CAD applications. Currently it
37 is the native file format of AutoCAD, a proprietary CAD program
38 developed by AutoDesk.
39
40 %description -l pl.UTF-8
41 LibreDWG to wolnodostępna biblioteka C do odczytu plików DWG. DWG to
42 format plików powstały w latach 70. dla powstających aplikacji CAD.
43 Obecnie jest to natywny format AutoCAD-a - własnościowego programu
44 CAD rozwijanego przez firmę AutoDesk.
45
46 %package devel
47 Summary:        Header files for LibreDWG library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LibreDWG
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 # dwg.h file
52 Conflicts:      libdwg-devel
53
54 %description devel
55 Header files for LibreDWG library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki LibreDWG.
59
60 %package static
61 Summary:        Static LibreDWG library
62 Summary(pl.UTF-8):      Statyczna biblioteka LibreDWG
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static LibreDWG library.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka LibreDWG.
71
72 %package -n perl-libredwg
73 Summary:        Perl interface for LibreDWG library
74 Summary(pl.UTF-8):      Interfejs Perla do biblioteki LibreDWG
75 Group:          Development/Languages/Perl
76 Requires:       %{name} = %{version}-%{release}
77
78 %description -n perl-libredwg
79 Perl interface for LibreDWG library.
80
81 %description -n perl-libredwg -l pl.UTF-8
82 Interfejs Perla do biblioteki LibreDWG.
83
84 %package -n python-libredwg
85 Summary:        Python interface for LibreDWG library
86 Summary(pl.UTF-8):      Interfejs Pythona do biblioteki LibreDWG
87 Group:          Development/Languages/Perl
88 Requires:       %{name} = %{version}-%{release}
89
90 %description -n python-libredwg
91 Python interface for LibreDWG library.
92
93 %description -n python-libredwg -l pl.UTF-8
94 Interfejs Pythona do biblioteki LibreDWG.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100
101 # no git-version-gen in release tarball
102 %{__sed} -i -e 's/m4_esyscmd.*git-version-gen.*/[%{version}],/' configure.ac
103
104 # disable when not running tests
105 %{__sed} -i -e '/^check_PROGRAMS/ s/ llvmfuzz_standalone//' examples/Makefile.am
106
107 %build
108 %{__libtoolize}
109 %{__aclocal} -I m4
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         --disable-silent-rules \
115         --with-perl-install=vendor
116
117 # programs/dwg2ps.1 is missing in dist as of 0.12.5
118 %{__make} -C src
119 %{__make} -C programs regen-man
120
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 # obsoleted by pkg-config
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libredwg.la
131
132 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_LibreDWG.la
133 %py_postclean
134
135 # just example, nothing really useful
136 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-libredwg-%{version}
137 %{__mv} $RPM_BUILD_ROOT%{_datadir}/load_dwg.py $RPM_BUILD_ROOT%{_examplesdir}/python-libredwg-%{version}
138 # packaged as %doc
139 %{__rm} $RPM_BUILD_ROOT%{_datadir}/dwgadd.example
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %post   devel -p /sbin/postshell
148 -/usr/sbin/fix-info-dir -c %{_infodir}
149
150 %postun devel -p /sbin/postshell
151 -/usr/sbin/fix-info-dir -c %{_infodir}
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog NEWS README TODO examples/dwgadd.example
156 %attr(755,root,root) %{_bindir}/dwg2SVG
157 %attr(755,root,root) %{_bindir}/dwg2dxf
158 %attr(755,root,root) %{_bindir}/dwg2ps
159 %attr(755,root,root) %{_bindir}/dwgadd
160 %attr(755,root,root) %{_bindir}/dwgbmp
161 %attr(755,root,root) %{_bindir}/dwgfilter
162 %attr(755,root,root) %{_bindir}/dwggrep
163 %attr(755,root,root) %{_bindir}/dwglayers
164 %attr(755,root,root) %{_bindir}/dwgread
165 %attr(755,root,root) %{_bindir}/dwgrewrite
166 %attr(755,root,root) %{_bindir}/dwgwrite
167 %attr(755,root,root) %{_bindir}/dxf2dwg
168 %attr(755,root,root) %{_bindir}/dxfwrite
169 %attr(755,root,root) %{_libdir}/libredwg.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libredwg.so.0
171 %{_mandir}/man1/dwg2SVG.1*
172 %{_mandir}/man1/dwg2dxf.1*
173 %{_mandir}/man1/dwg2ps.1*
174 %{_mandir}/man1/dwgadd.1*
175 %{_mandir}/man1/dwgbmp.1*
176 %{_mandir}/man1/dwgfilter.1*
177 %{_mandir}/man1/dwggrep.1*
178 %{_mandir}/man1/dwglayers.1*
179 %{_mandir}/man1/dwgread.1*
180 %{_mandir}/man1/dwgrewrite.1*
181 %{_mandir}/man1/dwgwrite.1*
182 %{_mandir}/man1/dxf2dwg.1*
183 %{_mandir}/man1/dxfwrite.1*
184 %{_mandir}/man5/dwgadd.5*
185
186 %files devel
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/libredwg.so
189 %{_includedir}/dwg.h
190 %{_includedir}/dwg_api.h
191 %{_pkgconfigdir}/libredwg.pc
192 %{_infodir}/LibreDWG.info*
193
194 %files static
195 %defattr(644,root,root,755)
196 %{_libdir}/libredwg.a
197
198 %files -n perl-libredwg
199 %defattr(644,root,root,755)
200 %{perl_vendorarch}/LibreDWG.pm
201 %dir %{perl_vendorarch}/auto
202 %dir %{perl_vendorarch}/auto/LibreDWG
203 %attr(755,root,root) %{perl_vendorarch}/auto/LibreDWG/LibreDWG.so
204
205 %files -n python-libredwg
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{py_sitedir}/_LibreDWG.so
208 %{py_sitescriptdir}/LibreDWG.py[co]
209 %{_examplesdir}/python-libredwg-%{version}
This page took 0.056393 seconds and 2 git commands to generate.