]> git.pld-linux.org Git - packages/libraqm.git/blob - libraqm.spec
e42104092c42d8bd12ad9fa83ecc744d2182e20f
[packages/libraqm.git] / libraqm.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5 %bcond_without  tests           # unit tests
6 #
7 Summary:        Library for complex text layout
8 Summary(pl.UTF-8):      Biblioteka do skomplikowanego układu tekstu
9 Name:           libraqm
10 Version:        0.2.0
11 Release:        1
12 License:        MIT
13 Group:          Libraries
14 #Source0Download: https://github.com/HOST-Oman/libraqm/releases
15 Source0:        https://github.com/HOST-Oman/libraqm/releases/download/v%{version}/raqm-%{version}.tar.gz
16 # Source0-md5:  0a693640ac3aa5c25b533de7dce2cce3
17 Patch0:         %{name}-format.patch
18 URL:            https://github.com/HOST-Oman/libraqm
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake >= 1:1.11
21 # pkgconfig(freetype2) >= 12.0.6
22 BuildRequires:  freetype-devel >= 1:2.4.2
23 BuildRequires:  fribidi-devel
24 %{?with_tests:BuildRequires:    glib2-devel >= 2.0}
25 %if %{with tests} && %(locale -a | grep -q '^C\.UTF-8$'; echo $?)
26 BuildRequires:  glibc-localedb-all
27 %endif
28 BuildRequires:  gtk-doc >= 1.14
29 BuildRequires:  harfbuzz-devel
30 BuildRequires:  libtool >= 2:2
31 BuildRequires:  pkgconfig >= 1:0.20
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Raqm is a small library that encapsulates the logic for complex text
36 layout and provide a convenient API.
37
38 It currently provides bidirectional text support (using FriBiDi),
39 shaping (using HarfBuzz), and proper script itemization. As a result,
40 Raqm can support most writing systems covered by Unicode.
41
42 %description -l pl.UTF-8
43 Raqm to mała biblioteka opakowująca logikę złożonego układu tekstu i
44 udostępniająca wygodne API.
45
46 Obecnie zapewnia obsługę tekstu dwukierunkowego (przy użyciu FriBiDi),
47 formowanie (przy użyciu HarfBuzz) i właściwe wyszczególnienie pisma.
48 W efekcie Raqm potrafi obsłużyć większość systemów pisma pokrytych
49 przez Unikod.
50
51 %package devel
52 Summary:        Header files for Raqm library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Raqm
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       freetype-devel >= 1:2.4.2
57 Requires:       fribidi-devel
58 Requires:       harfbuzz-devel
59
60 %description devel
61 Header files for Raqm library.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe biblioteki Raqm.
65
66 %package static
67 Summary:        Static Raqm library
68 Summary(pl.UTF-8):      Statyczna biblioteka Raqm
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static Raqm library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka Raqm.
77
78 %package apidocs
79 Summary:        API documentation for Raqm library
80 Summary(pl.UTF-8):      Dokumentacja API biblioteki Raqm
81 Group:          Documentation
82 %if "%{_rpmversion}" >= "5"
83 BuildArch:      noarch
84 %endif
85
86 %description apidocs
87 API documentation for Raqm library.
88
89 %description apidocs -l pl.UTF-8
90 Dokumentacja API biblioteki Raqm.
91
92 %prep
93 %setup -q -n raqm-%{version}
94 %patch0 -p1
95
96 %build
97 # rebuild ac/am for as-needed to work
98 %{__libtoolize}
99 %{__aclocal} -I m4
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         --disable-silent-rules \
105         %{!?with_static_libs:--disable-static} \
106         --with-html-dir=%{_gtkdocdir}
107 %{__make}
108
109 %if %{with tests}
110 LC_ALL=C.UTF-8 \
111 %{__make} check
112 %endif
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 # obsoleted by pkg-config
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libraqm.la
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc AUTHORS COPYING NEWS README
132 %attr(755,root,root) %{_libdir}/libraqm.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libraqm.so.0
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libraqm.so
138 %{_includedir}/raqm.h
139 %{_pkgconfigdir}/raqm.pc
140
141 %if %{with static_libs}
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libraqm.a
145 %endif
146
147 %if %{with apidocs}
148 %files apidocs
149 %defattr(644,root,root,755)
150 %{_gtkdocdir}/raqm
151 %endif
This page took 0.072643 seconds and 2 git commands to generate.