]> git.pld-linux.org Git - packages/libqb.git/blob - libqb.spec
- updated to 2.0.4 (new soname)
[packages/libqb.git] / libqb.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_with     tests           # "make check" call
5 #
6 Summary:        libqb - high performance client server reusable features
7 Summary(pl.UTF-8):      libqb - wysoko wydajne funkcje architektury klient-serwer
8 Name:           libqb
9 Version:        2.0.4
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 #Source0Download: https://github.com/ClusterLabs/libqb/releases
14 Source0:        https://github.com/ClusterLabs/libqb/releases/download/v%{version}/%{name}-%{version}.tar.xz
15 # Source0-md5:  9186cbf26645607d3ac48911ca214b6b
16 URL:            https://github.com/ClusterLabs/libqb
17 %{?with_tests:BuildRequires:    check-devel >= 0.9.4}
18 BuildRequires:  doxygen
19 BuildRequires:  glib2-devel >= 2.0
20 BuildRequires:  libxml2-devel >= 2.0
21 BuildRequires:  pkgconfig
22 BuildRequires:  systemd-devel >= 1:209
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 libqb is a library with the primary purpose of providing high
29 performance client server reusable features. It provides high
30 performance logging, tracing, ipc, and poll.
31
32 %description -l pl.UTF-8
33 libqb to biblioteka, której głównym celem jest dostarczenie
34 wysoko wydajnych funkcji użytecznych przy architekturze klient-serwer.
35 Udostępnia wysoko wydajne logowanie, śledzenie, IPC oraz poll.
36
37 %package devel
38 Summary:        Header files for libqb library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libqb
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for libqb library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki libqb.
48
49 %package static
50 Summary:        Static libqb library
51 Summary(pl.UTF-8):      Statyczna biblioteka libqb
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static libqb library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka libqb.
60
61 %prep
62 %setup -q
63
64 %build
65 %configure \
66         --disable-silent-rules \
67         %{!?with_static_libs:--disable-static}
68 %{__make}
69
70 %if %{with tests}
71 %{__make} check
72 %endif
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 # obsoleted by pkg-config
81 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libqb.la
82 # packaged as %doc
83 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc ChangeLog README.markdown
94 %attr(755,root,root) %{_sbindir}/qb-blackbox
95 %attr(755,root,root) %{_libdir}/libqb.so.*.*.*
96 %attr(755,root,root) %ghost %{_libdir}/libqb.so.100
97 %{_mandir}/man8/qb-blackbox.8*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libqb.so
102 %{_includedir}/qb
103 %{_pkgconfigdir}/libqb.pc
104 %{_mandir}/man3/qb*.h.3*
105 %{_mandir}/man3/qb_*.3*
106
107 # XXX: subpackage?
108 %attr(755,root,root) %{_bindir}/doxygen2man
109 %{_mandir}/man1/doxygen2man.1*
110
111 %if %{with static_libs}
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libqb.a
115 %endif
This page took 0.056722 seconds and 3 git commands to generate.