]> git.pld-linux.org Git - packages/libqb.git/blob - libqb.spec
0aa2678262991f543aa7c79694f0f15e9b1c6d23
[packages/libqb.git] / libqb.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_with     tests           # "make check" call
5 #
6 Summary:        libqb - high performance client server reusable features
7 Summary(pl.UTF-8):      libqb - wysoko wydajne funkcje architektury klient-serwer
8 Name:           libqb
9 Version:        1.0.5
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 #Source0Download: https://github.com/ClusterLabs/libqb/releases
14 Source0:        https://github.com/ClusterLabs/libqb/releases/download/v%{version}/%{name}-%{version}.tar.xz
15 # Source0-md5:  ee456f27a8f460fe350404ad90709caf
16 URL:            https://github.com/ClusterLabs/libqb
17 %{?with_tests:BuildRequires:    check-devel >= 0.9.4}
18 BuildRequires:  doxygen
19 BuildRequires:  glib2-devel >= 2.0
20 BuildRequires:  pkgconfig
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 libqb is a library with the primary purpose of providing high
27 performance client server reusable features. It provides high
28 performance logging, tracing, ipc, and poll.
29
30 %description -l pl.UTF-8
31 libqb to biblioteka, której głównym celem jest dostarczenie
32 wysoko wydajnych funkcji użytecznych przy architekturze klient-serwer.
33 Udostępnia wysoko wydajne logowanie, śledzenie, IPC oraz poll.
34
35 %package devel
36 Summary:        Header files for libqb library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libqb
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for libqb library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki libqb.
46
47 %package static
48 Summary:        Static libqb library
49 Summary(pl.UTF-8):      Statyczna biblioteka libqb
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static libqb library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka libqb.
58
59 %prep
60 %setup -q
61
62 %build
63 %configure \
64         --disable-silent-rules \
65         %{!?with_static_libs:--disable-static}
66 %{__make}
67
68 %if %{with tests}
69 %{__make} check
70 %endif
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 # obsoleted by pkg-config
79 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libqb.la
80 # packaged as %doc
81 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc ChangeLog README.markdown
92 %attr(755,root,root) %{_sbindir}/qb-blackbox
93 %attr(755,root,root) %{_libdir}/libqb.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libqb.so.0
95 %{_mandir}/man8/qb-blackbox.8*
96
97 %files devel
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/libqb.so
100 %{_includedir}/qb
101 %{_pkgconfigdir}/libqb.pc
102 %{_mandir}/man3/qb*.h.3*
103
104 %if %{with static_libs}
105 %files static
106 %defattr(644,root,root,755)
107 %{_libdir}/libqb.a
108 %endif
This page took 0.024897 seconds and 2 git commands to generate.