]> git.pld-linux.org Git - packages/libpipeline.git/blob - libpipeline.spec
be91f735c7206c1856291fd14ac415c49ad3f8c6
[packages/libpipeline.git] / libpipeline.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library build
4 #
5 Summary:        A pipeline manipulation library
6 Summary(pl.UTF-8):      Biblioteka operacji na linii potoków
7 Name:           libpipeline
8 Version:        1.2.6
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Libraries
12 Source0:        http://download.savannah.gnu.org/releases/libpipeline/%{name}-%{version}.tar.gz
13 # Source0-md5:  6d1d51a5dc102af41e0d269d2a31e6f9
14 URL:            http://libpipeline.nongnu.org/
15 BuildRequires:  libtool >= 2:2
16 BuildRequires:  pkgconfig
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 libpipeline is a C library for setting up and running pipelines of
21 processes, without needing to involve shell command-line parsing which
22 is often error-prone and insecure. This alleviates programmers of the
23 need to laboriously construct pipelines using lower-level primitives
24 such as fork(2) and execve(2).
25
26 %description -l pl.UTF-8
27 libpipeline to biblioteka C do ustanawiania i uruchamiania linii
28 potoków procesów bez potrzeby wykonywania analizy linii poleceń, która
29 jest zwykle błędogenna i niebezpieczna. Ogranicza konieczność
30 pracochłonnego tworzenia linii potoków przez programistów przy użyciu
31 niskopoziomowych wywołań, takich jak fork(2) i execve(2).
32
33 %package devel
34 Summary:        Header file for pipeline manipulation library
35 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki operacji na linii potoków
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 libpipeline-devel contains the header file needed to develop programs
41 that use libpipeline library.
42
43 %description devel -l pl.UTF-8
44 Ten pakiet zawiera plik nagłówkowy potrzebny do tworzenia programów
45 wykorzystujących bibliotekę libpipeline.
46
47 %package static
48 Summary:        Static libpipeline library
49 Summary(pl.UTF-8):      Statyczna biblioteka libpipeline
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static libpipeline library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka libpipeline.
58
59 %prep
60 %setup -q
61
62 %build
63 %configure \
64         --disable-silent-rules \
65         %{?with_static_libs:--enable-static}
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 %{__make} install \
71         prefix=%{_prefix} \
72         INSTALL='install -p' \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 # obsoleted by pkg-config
76 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libpipeline.la
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc ChangeLog NEWS README TODO
87 %attr(755,root,root) %{_libdir}/libpipeline.so.*.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libpipeline.so.1
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/libpipeline.so
93 %{_includedir}/pipeline.h
94 %{_mandir}/man3/libpipeline.3*
95 %{_mandir}/man3/pipecmd_*.3*
96 %{_mandir}/man3/pipeline_*.3*
97 %{_pkgconfigdir}/libpipeline.pc
98
99 %if %{with static_libs}
100 %files static
101 %defattr(644,root,root,755)
102 %{_libdir}/libpipeline.a
103 %endif
This page took 0.074188 seconds and 2 git commands to generate.