]> git.pld-linux.org Git - packages/libp11.git/blob - libp11.spec
- updated to 0.4.12
[packages/libp11.git] / libp11.spec
1 Summary:        Layer on top of PKCS#11 API to make using PKCS#11 implementations easier
2 Summary(pl.UTF-8):      Warstwa powyżej API PKCS#11 ułatwiająca używanie implementacji PKCS#11
3 Name:           libp11
4 Version:        0.4.12
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Libraries
8 #Source0Download: https://github.com/OpenSC/libp11/releases
9 Source0:        https://github.com/OpenSC/libp11/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  2ec3c29523cc06ec60166b320c489c63
11 Patch0:         %{name}-openssl3.patch
12 URL:            https://github.com/OpenSC/libp11
13 BuildRequires:  doxygen
14 BuildRequires:  openssl-devel >= 3.0.0
15 # for proxy_module detection
16 BuildRequires:  p11-kit-devel
17 BuildRequires:  pkgconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %undefine       __cxx
21
22 %description
23 Libp11 is a library implementing a small layer on top of PKCS#11 API
24 to make using PKCS#11 implementations easier.
25
26 %description -l pl.UTF-8
27 Libp11 to biblioteka implementująca niewielką warstwę na wierzchu API
28 PKCS#11 mająca ułatwić używanie implementacji PKCS#11.
29
30 %package devel
31 Summary:        Header files for libp11 library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libp11
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       openssl-devel >= 3.0.0
36
37 %description devel
38 Header files for libp11 library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki libp11.
42
43 %package static
44 Summary:        Static libp11 library
45 Summary(pl.UTF-8):      Statyczna biblioteka libp11
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static libp11 library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka libp11.
54
55 %package apidocs
56 Summary:        API documentation for libp11 library
57 Summary(pl.UTF-8):      Dokumentacja API biblioteki libp11
58 Group:          Documentation
59
60 %description apidocs
61 API documentation for libp11 library.
62
63 %description apidocs -l pl.UTF-8
64 Dokumentacja API biblioteki libp11.
65
66 %package -n openssl-engine-pkcs11
67 Summary:        PKCS#11 engine for OpenSSL
68 Summary(pl.UTF-8):      Silnik PKCS#11 dla OpenSSL-a
69 Group:          Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       openssl >= 3.0.0
72
73 %description -n openssl-engine-pkcs11
74 engine_pkcs11 is an implementation of an engine for OpenSSL. It can be
75 loaded using code, config file or command line and will pass any
76 function call by openssl to a PKCS#11 module. Engine_pkcs11 is meant
77 to be used with smart cards and software for using smart cards in
78 PKCS#11 format, such as OpenSC.
79
80 %description -n openssl-engine-pkcs11 -l pl.UTF-8
81 engine_pkcs11 to implementacja silnika dla OpenSSL-a. Może być
82 wczytany przy użyciu kodu, pliku konfiguracyjnego i linii poleceń;
83 przekazuje wszystkie wywołania funkcji openssl-a do modułu PKCS#11.
84 engine_pkcs11 jest przeznaczony do używania z kartami procesorowymi i
85 oprogramowaniem do używania kart procesorowych w formacie PKCS#11,
86 takim jak OpenSC.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 %build
93 %configure \
94         --enable-api-doc \
95         --disable-silent-rules \
96         --with-enginesdir=/%{_lib}/engines-3
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
106 cp -af examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
107
108 # obsoleted by pkgconfig
109 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libp11.la
110 # loadable module
111 %{__rm} $RPM_BUILD_ROOT/%{_lib}/engines-3/*.la
112 # packaged as %doc
113 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libp11
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc NEWS README.md
124 %attr(755,root,root) %{_libdir}/libp11.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libp11.so.3
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/libp11.so
130 %{_includedir}/libp11.h
131 %{_includedir}/p11_err.h
132 %{_pkgconfigdir}/libp11.pc
133 %{_examplesdir}/%{name}-%{version}
134
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libp11.a
138
139 %files apidocs
140 %defattr(644,root,root,755)
141 %doc doc/api.out/html/*
142
143 %files -n openssl-engine-pkcs11
144 %defattr(644,root,root,755)
145 %attr(755,root,root) /%{_lib}/engines-3/libpkcs11.so
146 %attr(755,root,root) /%{_lib}/engines-3/pkcs11.so
This page took 0.057174 seconds and 3 git commands to generate.