]> git.pld-linux.org Git - packages/libovf-glib.git/blob - libovf-glib.spec
- initial
[packages/libovf-glib.git] / libovf-glib.spec
1 #
2 # Conditional build:
3 %bcond_with     static_libs     # static library
4 #
5 Summary:        A readwrite library to manage ova files
6 Summary(pl.UTF-8):      Biblioteka do odczytu i zapisu plików ova
7 Name:           libovf-glib
8 # meson.build /version:
9 Version:        0.1.0
10 %define gitref  52d35970d385d0beda4b765a7264d77e79736549
11 %define snap    20190308
12 %define rel     1
13 Release:        0.%{snap}.1
14 License:        LGPL v2.1+
15 Group:          Libraries
16 #Source0Download: https://gitlab.gnome.org/felipeborges/libovf-glib/-/tags
17 Source0:        https://gitlab.gnome.org/felipeborges/libovf-glib/-/archive/%{gitref}/%{name}-%{snap}.tar.bz2
18 # Source0-md5:  f6e4c0116e67ea59d4e4dcc76c969148
19 URL:            https://gitlab.gnome.org/felipeborges/libovf-glib
20 BuildRequires:  glib2-devel >= 1:2.50
21 BuildRequires:  gobject-introspection-devel
22 BuildRequires:  libarchive-devel
23 BuildRequires:  libxml2-devel >= 2.0
24 BuildRequires:  meson >= 0.47.0
25 BuildRequires:  ninja >= 1.5
26 BuildRequires:  pkgconfig
27 BuildRequires:  sed >= 4.0
28 BuildRequires:  vala
29 Requires:       glib2 >= 1:2.50
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 libgovf is a library for reading and writing virtual machine images in
34 the Open Virtualization Format.
35
36 %description -l pl.UTF-8
37 libgovf to biblioteka do odczytu i zapisu obrazów maszyn wirtualnych
38 wykorzystujących Open Virtualization Format.
39
40 %package devel
41 Summary:        Header files for libgovf library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgovf
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       glib2-devel >= 1:2.50
46 Requires:       libarchive-devel
47 Requires:       libxml2-devel >= 2.0
48
49 %description devel
50 Header files for libgovf library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki libgovf.
54
55 %package static
56 Summary:        Static libgovf library
57 Summary(pl.UTF-8):      Statyczna biblioteka libgovf
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static libgovf library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka libgovf.
66
67 %package -n vala-libovf-glib
68 Summary:        Vala API for libgovf library
69 Summary(pl.UTF-8):      API języka Vala do biblioteki libgovf
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72 Requires:       vala
73 %if "%{_rpmversion}" >= "4.6"
74 BuildArch:      noarch
75 %endif
76
77 %description -n vala-libovf-glib
78 Vala API for libgovf library.
79
80 %description -n vala-libovf-glib -l pl.UTF-8
81 API języka Vala do biblioteki libgovf.
82
83 %prep
84 %setup -q -n %{name}-%{gitref}
85
86 %if %{with static_libs}
87 %{__sed} -i -e '/^govf_lib = / s/shared_library/library/' govf/meson.build
88 %endif
89
90 %build
91 %meson build
92
93 %ninja_build -C build
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %ninja_install -C build
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc AUTHORS README
109 %attr(755,root,root) %{_libdir}/libgovf-0.1.so
110 %{_libdir}/girepository-1.0/Govf-0.1.typelib
111
112 %files devel
113 %defattr(644,root,root,755)
114 %{_includedir}/govf
115 %{_datadir}/gir-1.0/Govf-0.1.gir
116 %{_pkgconfigdir}/govf-0.1.pc
117
118 %if %{with static_libs}
119 %files static
120 %defattr(644,root,root,755)
121 %{_libdir}/libgovf-0.1.a
122 %endif
123
124 %files -n vala-libovf-glib
125 %defattr(644,root,root,755)
126 %{_datadir}/vala/vapi/govf-0.1.deps
127 %{_datadir}/vala/vapi/govf-0.1.vapi
This page took 0.089154 seconds and 3 git commands to generate.