]> git.pld-linux.org Git - packages/liboping.git/blob - liboping.spec
- Up to 1.5.1
[packages/liboping.git] / liboping.spec
1 # TODO:
2 # - package perl modules
3 #
4 Summary:        Liboping library
5 Name:           liboping
6 Version:        1.5.1
7 Release:        1
8 License:        GPL v2
9 Group:          Libraries
10 Source0:        http://verplant.org/liboping/files/%{name}-%{version}.tar.bz2
11 # Source0-md5:  61d17df8ef0a60ccafc8715de310b3f0
12 URL:            http://verplant.org/liboping/
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 liboping is a C library to generate ICMP echo requests, better known
17 as "ping packets". It is intended for use in network monitoring
18 applications or applications that would otherwise need to fork ping(1)
19 frequently.
20
21 liboping was inspired by ping, libping (homepage vanished) and fping:
22 It differs from these existing solutions in that it can `ping'
23 multiple hosts in parallel using IPv4 or IPv6 transparently. Other
24 design principles were an object oriented interface, simplicity and
25 extensibility: Is simple because there are only a few interface
26 functions and no external dependencies. It's extensible since all
27 (internal) data is kept in "opaque data types", so the storage may
28 change or be extended without applications noticing it.
29
30 %package -n oping
31 Summary:        oping ICMP query tool
32 Group:          Applications/Networking
33
34 %description -n oping
35 Sample application, which demonstrates the liboping's abilities. It is
36 like ping, ping6, and fping rolled into one.
37
38 %package devel
39 Summary:        Header files for liboping library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki liboping
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for liboping library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki liboping.
49
50 %package static
51 Summary:        Static liboping library
52 Summary(pl.UTF-8):      Statyczna biblioteka liboping
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static liboping library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka liboping.
61
62 %prep
63 %setup -q
64
65 %build
66 %{__libtoolize}
67 %{__aclocal}
68 %{__autoconf}
69 %{__autoheader}
70 %{__automake}
71 %configure
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS ChangeLog README
89 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
90
91 %files -n oping
92 %defattr(644,root,root,755)
93 %attr(4754,root,adm) %{_bindir}/oping
94 %{_mandir}/man8/*.8*
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/lib*.so
99 %{_libdir}/lib*.la
100 %{_includedir}/oping.h
101 %{_mandir}/man3/*.3*
102
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/lib*.a
This page took 0.030152 seconds and 3 git commands to generate.