]> git.pld-linux.org Git - packages/liboping.git/blob - liboping.spec
- rel.2
[packages/liboping.git] / liboping.spec
1 Summary:        Liboping library
2 Name:           liboping
3 Version:        0.3.5
4 Release:        2
5 License:        GPL v2
6 Group:          Libraries
7 Source0:        http://verplant.org/liboping/files/%{name}-%{version}.tar.bz2
8 # Source0-md5:  0150a1c1ae6ce847b11543df31d4f952
9 URL:            http://verplant.org/liboping/
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %description
13 liboping is a C library to generate ICMP echo requests, better known as
14 "ping packets". It is intended for use in network monitoring applications
15 or applications that would otherwise need to fork ping(1) frequently.
16
17 liboping was inspired by ping, libping (homepage vanished) and fping:
18 It differs from these existing solutions in that it can `ping' multiple
19 hosts in parallel using IPv4 or IPv6 transparently. Other design principles
20 were an object oriented interface, simplicity and extensibility: Is simple
21 because there are only a few interface functions and no external
22 dependencies. It's extensible since all (internal) data is kept in "opaque
23 data types", so the storage may change or be extended without applications
24 noticing it.
25
26 %package -n oping
27 Summary:        oping ICMP query tool
28 Group:          Applications/Networking
29 Requires:       %{name} = %{version}-%{release}
30
31 %description -n oping
32 Sample application, which demonstrates the liboping's abilities. It is like
33 ping, ping6, and fping rolled into one.
34
35 %package devel
36 Summary:        Header files for liboping library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki liboping
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for liboping library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki liboping.
46
47 %package static
48 Summary:        Static liboping library
49 Summary(pl.UTF-8):      Statyczna biblioteka liboping
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static liboping library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka liboping.
58
59 %prep
60 %setup -q
61
62 %build
63 %configure
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files
79 %defattr(644,root,root,755)
80 %doc AUTHORS ChangeLog README
81 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
82
83 %files -n oping
84 %defattr(644,root,root,755)
85 %attr(4754,root,adm) %{_bindir}/*
86 %{_mandir}/man8/*.8*
87
88 %files devel
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/lib*.so
91 %{_libdir}/lib*.la
92 %{_includedir}/oping.h
93 %{_mandir}/man3/*.3*
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/lib*.a
This page took 0.046045 seconds and 3 git commands to generate.