]> git.pld-linux.org Git - packages/libopenshot.git/blob - libopenshot.spec
bb4701bf1259afba6c708cda6d108fb96cb0447a
[packages/libopenshot.git] / libopenshot.spec
1 Summary:        Library for creating and editing videos
2 Name:           libopenshot
3 Version:        0.1.5
4 Release:        1
5 License:        LGPL-3.0+
6 Group:          Libraries
7 Source0:        https://launchpad.net/libopenshot/0.1/%{version}/+download/%{name}-%{version}.tar.gz
8 # Source0-md5:  842551733c3bd82a7ffd9eaeea1c2b1d
9 Patch0:         imagemagick7.patch
10 Group:          Development/Libraries
11 URL:            http://www.openshot.org/
12 BuildRequires:  ImageMagick-c++-devel
13 BuildRequires:  Qt5Core-devel
14 BuildRequires:  Qt5Multimedia-devel
15 BuildRequires:  Qt5MultimediaWidgets-devel
16 BuildRequires:  cmake
17 BuildRequires:  cppzmq-devel
18 BuildRequires:  doxygen
19 BuildRequires:  ffmpeg-devel
20 BuildRequires:  ffmpeg-libs
21 BuildRequires:  libopenshot-audio-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  python3-devel
24 BuildRequires:  swig
25 BuildRequires:  unittest-cpp-devel
26 BuildRequires:  zeromq-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         skip_post_check_so      libopenshot.so.*
30
31 %description
32 OpenShot Library (libopenshot) is an open-source project dedicated to
33 delivering high quality video editing, animation, and playback
34 solutions to the world. For more information visit
35 <http://www.openshot.org/>.
36
37 %package devel
38 Summary:        Development files for %{name}
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 The %{name}-devel package contains libraries and header files for
44 developing applications that use %{name}.
45
46 %package -n python3-%{name}
47 Summary:        Python bindings for %{name}
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description -n python3-%{name}
52 The python-%{name} package contains python bindings for applications
53 that use %{name}.
54
55 %prep
56 %setup -qc
57 %patch0 -p1
58
59 sed -i -e 's#${_REL_PYTHON_MODULE_PATH}#%{py3_sitedir}#g' src/bindings/python/CMakeLists.txt
60
61 %build
62 install -d build
63 cd build
64 %cmake ..
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} -C build install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %attr(755,root,root) %{_libdir}/libopenshot.so.*.*
82 %attr(755,root,root) %ghost %{_libdir}/libopenshot.so.11
83
84 %files devel
85 %defattr(644,root,root,755)
86 %{_includedir}/libopenshot
87 %attr(755,root,root) %{_libdir}/libopenshot.so
88
89 %files -n python3-%{name}
90 %defattr(644,root,root,755)
91 %{py3_sitedir}/openshot.py
92 %attr(755,root,root) %{py3_sitedir}/_openshot.so
This page took 0.084788 seconds and 2 git commands to generate.