]> git.pld-linux.org Git - packages/libopenshot.git/blob - libopenshot.spec
- initial
[packages/libopenshot.git] / libopenshot.spec
1 Summary:        Library for creating and editing videos
2 Name:           libopenshot
3 Version:        0.1.2
4 Release:        1
5 License:        LGPL-3.0+
6 Group:          Libraries
7 URL:            http://www.openshot.org/
8 Source0:        https://launchpad.net/libopenshot/0.1/0.1.2/+download/%{name}-%{version}.tar.gz
9 # Source0-md5:  1491f454af8ef23b6c2f7f3e4ce39291
10 Group:          Development/Libraries
11 BuildRequires:  ImageMagick-c++-devel
12 BuildRequires:  Qt5Core-devel
13 BuildRequires:  Qt5Multimedia-devel
14 BuildRequires:  Qt5MultimediaWidgets-devel
15 BuildRequires:  cmake
16 BuildRequires:  cppzmq-devel
17 BuildRequires:  doxygen
18 BuildRequires:  ffmpeg-devel
19 BuildRequires:  ffmpeg-libs
20 BuildRequires:  libopenshot-audio-devel
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  python3-devel
23 BuildRequires:  swig
24 BuildRequires:  unittest-cpp-devel
25 BuildRequires:  zeromq-devel
26
27 %description
28 OpenShot Library (libopenshot) is an open-source project dedicated to
29 delivering high quality video editing, animation, and playback
30 solutions to the world. For more information visit
31 <http://www.openshot.org/>.
32
33 %package        devel
34 Summary:        Development files for %{name}
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description    devel
39 The %{name}-devel package contains libraries and header files for
40 developing applications that use %{name}.
41
42 %package        -n python3-%{name}
43 Summary:        Python bindings for %{name}
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description    -n python3-%{name}
48 The python-%{name} package contains python bindings for applications
49 that use %{name}.
50
51 %prep
52 %setup -q -c
53
54 %build
55 install -d build
56
57 sed -i -e 's#${_REL_PYTHON_MODULE_PATH}#%{py3_sitedir}#g' src/bindings/python/CMakeLists.txt
58
59 cd build
60 %cmake ..
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} -C build install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{_libdir}/libopenshot.so.*.*
78 %attr(755,root,root) %ghost %{_libdir}/libopenshot.so.9
79
80 %files devel
81 %defattr(644,root,root,755)
82 %{_includedir}/libopenshot
83 %attr(755,root,root) %{_libdir}/libopenshot.so
84
85 %files -n python3-%{name}
86 %defattr(644,root,root,755)
87 %{py3_sitedir}/openshot.py
88 %attr(755,root,root) %{py3_sitedir}/_openshot.so
This page took 0.141661 seconds and 3 git commands to generate.