]> git.pld-linux.org Git - packages/libodfgen.git/blob - libodfgen.spec
- updated to 0.1.8
[packages/libodfgen.git] / libodfgen.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Library to generate ODF documents from librevenge API calls
6 Summary(pl.UTF-8):      Biblioteka do generowania dokumentów ODF z wywołań API librevenge
7 Name:           libodfgen
8 Version:        0.1.8
9 Release:        1
10 License:        MPL v2.0 or LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/libwpd/%{name}-%{version}.tar.xz
13 # Source0-md5:  08c95c4b18c490a60394cc92fe9cb303
14 URL:            http://libwpd.sourceforge.net/
15 BuildRequires:  autoconf >= 2.65
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  librevenge-devel >= 0.0
18 BuildRequires:  libstdc++-devel >= 6:4.7
19 BuildRequires:  libtool >= 2:2
20 BuildRequires:  libxml2-devel >= 2.0
21 BuildRequires:  pkgconfig >= 1:0.20
22 BuildRequires:  rpm-build >= 4.6
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Library to generate ODF documents from librevenge API calls.
29
30 %description -l pl.UTF-8
31 Biblioteka do generowania dokumentów ODF z wywołań API librevenge.
32
33 %package devel
34 Summary:        Header files for libodfgen library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libodfgen
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       librevenge-devel >= 0.0
39 Requires:       libstdc++-devel >= 6:4.7
40
41 %description devel
42 Header files for libodfgen library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki libodfgen.
46
47 %package static
48 Summary:        Static libodfgen library
49 Summary(pl.UTF-8):      Statyczna biblioteka libodfgen
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static libodfgen library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka libodfgen.
58
59 %package apidocs
60 Summary:        libodfgen API documentation
61 Summary(pl.UTF-8):      Dokumentacja API biblioteki libodfgen
62 Group:          Documentation
63 BuildArch:      noarch
64
65 %description apidocs
66 libodfgen API documentation.
67
68 %description apidocs -l pl.UTF-8
69 Dokumentacja API biblioteki libodfgen.
70
71 %prep
72 %setup -q
73
74 %build
75 %{__libtoolize}
76 %{__aclocal}
77 %{__autoconf}
78 %{__autoheader}
79 %{__automake}
80 %configure \
81         %{?with_static_libs:--enable-static} \
82         --disable-silent-rules
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 # obsoleted by pkg-config
93 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libodfgen-*.la
94 # packaged as %doc in -apidocs
95 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libodfgen
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc AUTHORS ChangeLog NEWS README
106 %attr(755,root,root) %{_libdir}/libodfgen-0.1.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libodfgen-0.1.so.1
108
109 %files devel
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/libodfgen-0.1.so
112 %{_includedir}/libodfgen-0.1
113 %{_pkgconfigdir}/libodfgen-0.1.pc
114
115 %if %{with static_libs}
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/libodfgen-0.1.a
119 %endif
120
121 %files apidocs
122 %defattr(644,root,root,755)
123 %doc docs/doxygen/html/*
This page took 0.131629 seconds and 3 git commands to generate.