]> git.pld-linux.org Git - packages/libodfgen.git/blob - libodfgen.spec
- updated to 0.1.2
[packages/libodfgen.git] / libodfgen.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Library to generate ODF documents from librevenge API calls
6 Summary(pl.UTF-8):      Biblioteka do generowania dokumentów ODF z wywołań API librevenge
7 Name:           libodfgen
8 Version:        0.1.2
9 Release:        1
10 License:        MPL v2.0 or LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/libwpd/%{name}-%{version}.tar.xz
13 # Source0-md5:  6ed5513ad9a7cb568100487d22e5874a
14 URL:            http://libwpd.sourceforge.net/
15 BuildRequires:  autoconf >= 2.65
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  librevenge-devel >= 0.0
18 BuildRequires:  libstdc++-devel >= 6:4.3
19 BuildRequires:  libtool >= 2:2
20 BuildRequires:  pkgconfig >= 1:0.20
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Library to generate ODF documents from librevenge API calls.
27
28 %description -l pl.UTF-8
29 Biblioteka do generowania dokumentów ODF z wywołań API librevenge.
30
31 %package devel
32 Summary:        Header files for libodfgen library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libodfgen
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       librevenge-devel >= 0.0
37 Requires:       libstdc++-devel
38
39 %description devel
40 Header files for libodfgen library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki libodfgen.
44
45 %package static
46 Summary:        Static libodfgen library
47 Summary(pl.UTF-8):      Statyczna biblioteka libodfgen
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static libodfgen library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka libodfgen.
56
57 %package apidocs
58 Summary:        libodfgen API documentation
59 Summary(pl.UTF-8):      Dokumentacja API biblioteki libodfgen
60 Group:          Documentation
61
62 %description apidocs
63 libodfgen API documentation.
64
65 %description apidocs -l pl.UTF-8
66 Dokumentacja API biblioteki libodfgen.
67
68 %prep
69 %setup -q
70
71 %build
72 %{__libtoolize}
73 %{__aclocal}
74 %{__autoconf}
75 %{__autoheader}
76 %{__automake}
77 # -stdc++11 for std::shared_ptr
78 CXXFLAGS="%{rpmcxxflags} -std=c++11"
79 %configure \
80         %{?with_static_libs:--enable-static} \
81         --disable-silent-rules \
82         --with-sharedptr=c++11
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 # obsoleted by pkg-config
92 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libodfgen-*.la
93 # packaged as %doc in -apidocs
94 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libodfgen
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc AUTHORS ChangeLog NEWS README
105 %attr(755,root,root) %{_libdir}/libodfgen-0.1.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/libodfgen-0.1.so.1
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/libodfgen-0.1.so
111 %{_includedir}/libodfgen-0.1
112 %{_pkgconfigdir}/libodfgen-0.1.pc
113
114 %if %{with static_libs}
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/libodfgen-0.1.a
118 %endif
119
120 %files apidocs
121 %defattr(644,root,root,755)
122 %doc docs/doxygen/html/*
This page took 0.062567 seconds and 3 git commands to generate.