]> git.pld-linux.org Git - packages/libnspsl.git/blob - libnspsl.spec
- pl
[packages/libnspsl.git] / libnspsl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        NetSurf public suffix list handling
6 Summary(pl.UTF-8):      Obsługa listy przyrostków publicznych (Public Suffix List) dla projektu NetSurf
7 Name:           libnspsl
8 Version:        0.1.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13 # Source0-md5:  b09c9141bc157bf486a6950d2a5df58b
14 URL:            http://www.netsurf-browser.org/projects/libnspsl/
15 BuildRequires:  netsurf-buildsystem >= 1.5
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 The public suffix list is a database of top level domain names
20 (https://publicsuffix.org/). The database allows an application to
21 determine if if a domain name requires an additional label to be
22 valid.
23
24 %description -l pl.UTF-8
25 Lista przyrostków publicznych (Public Suffix List) to baza danych nazw
26 domen głównego poziomu (https://publicsuffix.org/). Baza pozwala
27 aplikacjom określić, czy nazwa domeny wymaga dodatkowej etykiety, aby
28 była poprawna.
29
30 %package devel
31 Summary:        libnspsl library headers
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libnspsl
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 This package contains the include files and other resources you can
38 use to incorporate libnspsl into applications.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe pozwalające na używanie biblioteki libnspsl w swoich
42 programach.
43
44 %package static
45 Summary:        libnspsl static library
46 Summary(pl.UTF-8):      Statyczna biblioteka libnspsl
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description static
51 This is package with static libnspsl library.
52
53 %description static -l pl.UTF-8
54 Statyczna biblioteka libnspsl.
55
56 %prep
57 %setup -q
58
59 %build
60 export AR="%{__ar}"
61 export CC="%{__cc}"
62 export CFLAGS="%{rpmcflags}"
63 export LDFLAGS="%{rpmldflags}"
64
65 %{__make} \
66         Q= \
67         PREFIX=%{_prefix} \
68         COMPONENT_TYPE=lib-shared
69
70 %if %{with static_libs}
71 %{__make} \
72         Q= \
73         PREFIX=%{_prefix} \
74         COMPONENT_TYPE=lib-static
75 %endif
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 export AR="%{__ar}"
80 export CC="%{__cc}"
81 export CFLAGS="%{rpmcflags}"
82 export LDFLAGS="%{rpmldflags}"
83
84 rm -rf $RPM_BUILD_ROOT
85 %{__make} install \
86         PREFIX=%{_prefix} \
87         LIBDIR=%{_lib} \
88         COMPONENT_TYPE=lib-shared \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %if %{with static_libs}
92 %{__make} install \
93         PREFIX=%{_prefix} \
94         LIBDIR=%{_lib} \
95         COMPONENT_TYPE=lib-static \
96         DESTDIR=$RPM_BUILD_ROOT
97 %endif
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc COPYING
108 %attr(755,root,root) %{_libdir}/libnspsl.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libnspsl.so.0
110
111 %files devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/libnspsl.so
114 %{_includedir}/nspsl.h
115 %{_pkgconfigdir}/libnspsl.pc
116
117 %if %{with static_libs}
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/libnspsl.a
121 %endif
This page took 0.092867 seconds and 3 git commands to generate.