]> git.pld-linux.org Git - packages/libnspsl.git/blob - libnspsl.spec
df7fa769700508f26889a9a35e587d491ad96d29
[packages/libnspsl.git] / libnspsl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        NetSurf public suffix list handling
6 Name:           libnspsl
7 Version:        0.1.0
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  b09c9141bc157bf486a6950d2a5df58b
13 URL:            http://www.netsurf-browser.org/projects/libnspsl/
14 BuildRequires:  netsurf-buildsystem >= 1.5
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 The public suffix list is a database of top level domain names
19 (https://publicsuffix.org). The database allows an application to
20 determine if if a domain name requires an additional label to be
21 valid.
22
23 %package devel
24 Summary:        libnspsl library headers
25 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libnspsl
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}-%{release}
28
29 %description devel
30 This package contains the include files and other resources you can
31 use to incorporate libnspsl into applications.
32
33 %description devel -l pl.UTF-8
34 Pliki nagłówkowe pozwalające na używanie biblioteki libnspsl w swoich
35 programach.
36
37 %package static
38 Summary:        libnspsl static library
39 Summary(pl.UTF-8):      Statyczna biblioteka libnspsl
40 Group:          Development/Libraries
41 Requires:       %{name}-devel = %{version}-%{release}
42
43 %description static
44 This is package with static libnspsl library.
45
46 %description static -l pl.UTF-8
47 Statyczna biblioteka libnspsl.
48
49 %prep
50 %setup -q
51
52 %build
53 export AR="%{__ar}"
54 export CC="%{__cc}"
55 export CFLAGS="%{rpmcflags}"
56 export LDFLAGS="%{rpmldflags}"
57
58 %{__make} \
59         Q= \
60         PREFIX=%{_prefix} \
61         COMPONENT_TYPE=lib-shared
62
63 %if %{with static_libs}
64 %{__make} \
65         Q= \
66         PREFIX=%{_prefix} \
67         COMPONENT_TYPE=lib-static
68 %endif
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 export AR="%{__ar}"
73 export CC="%{__cc}"
74 export CFLAGS="%{rpmcflags}"
75 export LDFLAGS="%{rpmldflags}"
76
77 rm -rf $RPM_BUILD_ROOT
78 %{__make} install \
79         PREFIX=%{_prefix} \
80         LIBDIR=%{_lib} \
81         COMPONENT_TYPE=lib-shared \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %if %{with static_libs}
85 %{__make} install \
86         PREFIX=%{_prefix} \
87         LIBDIR=%{_lib} \
88         COMPONENT_TYPE=lib-static \
89         DESTDIR=$RPM_BUILD_ROOT
90 %endif
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc COPYING
101 %attr(755,root,root) %{_libdir}/libnspsl.so.*.*.*
102 %attr(755,root,root) %ghost %{_libdir}/libnspsl.so.0
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libnspsl.so
107 %{_includedir}/nspsl.h
108 %{_pkgconfigdir}/libnspsl.pc
109
110 %if %{with static_libs}
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/libnspsl.a
114 %endif
This page took 0.115628 seconds and 2 git commands to generate.