]> git.pld-linux.org Git - packages/libnsbmp.git/blob - libnsbmp.spec
- adjusted -devel description, package MIT COPYING file
[packages/libnsbmp.git] / libnsbmp.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Decoding library for BMP and ICO file formats
6 Summary(pl.UTF-8):      Biblioteka dekodująca pliki w formatach BMP oraz ICO
7 Name:           libnsbmp
8 Version:        0.1.1
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13 # Source0-md5:  f9552402c748f976e68bb40a14bb82c7
14 URL:            http://www.netsurf-browser.org/projects/libnsbmp/
15 BuildRequires:  netsurf-buildsystem >= 1.1
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Libnsbmp is a decoding library for BMP and ICO image file formats,
20 written in C. It was developed as part of the NetSurf project and is
21 available for use by other software under the MIT licence.
22
23 %description -l pl.UTF-8
24 Libnsbmp to napisana w C biblioteka dekodująca pliki obrazów w
25 formatach BMP oraz ICO. Powstała jako część projektu NetSurf i jest
26 dostępna do wykorzystania przez inne programy na licencji MIT.
27
28 %package devel
29 Summary:        libnsbmp library headers
30 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libnsbmp
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 This package contains the include files and other resources you can
36 use to incorporate libnsbmp into applications.
37
38 %description devel -l pl.UTF-8
39 Pliki nagłówkowe pozwalające na używanie biblioteki libnsbmp w swoich
40 programach.
41
42 %package static
43 Summary:        libnsbmp static library
44 Summary(pl.UTF-8):      Statyczna biblioteka libnsbmp
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 This is package with static libnsbmp library.
50
51 %description static -l pl.UTF-8
52 Statyczna biblioteka libnsbmp.
53
54 %prep
55 %setup -q
56
57 %build
58 export CC="%{__cc}"
59 export CFLAGS="%{rpmcflags}"
60 export LDFLAGS="%{rpmldflags}"
61
62 %{__make} \
63         Q= \
64         PREFIX=%{_prefix} \
65         LIBDIR=%{_lib} \
66         COMPONENT_TYPE=lib-shared
67
68 %if %{with static_libs}
69 %{__make} \
70         Q= \
71         PREFIX=%{_prefix} \
72         LIBDIR=%{_lib} \
73         COMPONENT_TYPE=lib-static
74 %endif
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 %{__make} install \
79         Q= \
80         PREFIX=%{_prefix} \
81         LIBDIR=%{_lib} \
82         COMPONENT_TYPE=lib-shared \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %if %{with static_libs}
86 %{__make} install \
87         Q= \
88         PREFIX=%{_prefix} \
89         LIBDIR=%{_lib} \
90         COMPONENT_TYPE=lib-static \
91         DESTDIR=$RPM_BUILD_ROOT
92 %endif
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc COPYING
103 %attr(755,root,root) %{_libdir}/libnsbmp.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libnsbmp.so.0
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libnsbmp.so
109 %{_includedir}/libnsbmp.h
110 %{_pkgconfigdir}/libnsbmp.pc
111
112 %if %{with static_libs}
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/libnsbmp.a
116 %endif
This page took 0.070801 seconds and 3 git commands to generate.